Announcement

Collapse
No announcement yet.

Is HS running? When your away?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Originally posted by socalsharky View Post
    Could either of you provide some details on how to set up uptimerobot to work with an HS3 server? Since my HS3 server doesn't have a typical web address, not sure how to access it through uptimerobot. Thanks!
    That is a problem. I'm not sure if there's a stable way to get "direct" access via MyHS.
    HSPro 3.0.0.458, Z-NET with Z-wave plugin 3.0.1.190, RFXCOM + 2x RFXtrx433E, HSTouch, Squeezebox plugin, iTach IP/WF2IR & GC-100-6 with UltraGCIR, BLDenon, NetcamStudio, Jon00s Webpage builder, Harmony Hub plugin, SCSIP (with FreePBX), Arduino plugin, IFTTT, Pushalot plugin, Device History plugin.
    Running on Windows 10 (64) virtualized
    on ESXi (Fujitsu Primergy TX150 S8).
    WinSeer (for Win10) - TextSeer - FitbitSeer - HSPI_MoskusSample

    Are you Norwegian (or Scandinavian) and getting started with HomeSeer? Read the "HomeSeer School"!

    Comment


    • #32
      I have a script that checks to see if HS is running via myHS:
      https://forums.homeseer.com/forum/ho...e-notification
      HS3Pro Running on a Raspberry Pi3
      64 Z-Wave Nodes, 168 Events, 280 Devices
      UPB modules via OMNI plugin/panel
      Plugins: Z-Wave, BLRF, OMNI, HSTouch, weatherXML, EasyTrigger
      HSTouch Clients: 3 Android, 1 Joggler

      Comment


      • #33
        Originally posted by rmasonjr View Post
        I have a script that checks to see if HS is running via myHS:
        https://forums.homeseer.com/forum/ho...e-notification
        Where is the script running? Within HS3 on a separate machine?

        Comment


        • #34
          Correct - runs on my HS server and checks some other HS servers I manage for customers.
          HS3Pro Running on a Raspberry Pi3
          64 Z-Wave Nodes, 168 Events, 280 Devices
          UPB modules via OMNI plugin/panel
          Plugins: Z-Wave, BLRF, OMNI, HSTouch, weatherXML, EasyTrigger
          HSTouch Clients: 3 Android, 1 Joggler

          Comment


          • #35
            Originally posted by socalsharky View Post



            Could either of you provide some details on how to set up uptimerobot to work with an HS3 server? Since my HS3 server doesn't have a typical web address, not sure how to access it through uptimerobot. Thanks!
            How uptimerobot works: it triggers on a port and web address or iport
            So if it can't make connection u get a pushnotification.

            regards
            Preferred -> Jon's Plugins, Pushover, Phlocation, Easy-trigger,
            Rfxcom, Blade Plugins, Pushbullet, homekit, Malosa Scripts




            HS3Pro 4.0.1.18 on windows 10 enterprise X64 on hp quadcore laptop 8 GB.

            Comment


            • #36
              This may be ancient but it works. While I've just purchased TON of the new HS and Plugins to upgrade from 1.7 to the current, I created a simple event 15 years ago.

              I both HS and Omnipro run a Ping/Pong dead man timer. Each one counts down from 30 minutes (offset of course depending on restart time) and Pings the other via turning on an phantom X-10 (M10) device. The other see the 'Ping' M10 ON, and sets M10 to Off. If M10 stays on for more than 5 seconds then both of them run a Event(script) and Omni Program that speaks through the house that "The Alarm system has not responded, please investigate", for OmniPro the voice message is, of course, much shorter.

              Then the one that thinks the other is dead will email me that it's cousin has not responded to a ping. Please investigate.

              For HS I just use the built in email functionality. For Omni I use an OmniNotififer.

              As I'm an old fart, this was the easiest to implement before there was the enhanced feature set of both. Just a simple Ping (are you there?) and a Pong (Yup, I'm still here). In both cases each one records that it send and received a Ping and/or a Pong.

              Simple but effective.

              Comment


              • #37
                BTW, Being I'm still on HS 1.7 on a stabilized Windows XP machine (server), with HS being the only thing running on it. HS 1.7 rock stable. I only restart the XP machine as I think about it to get the cobwebs out every once in a while.

                I think that I won't have that luxury when I install HS3 Pro on my Windoze 7 machine soon.

                Comment


                • #38
                  I have a sequence of things that runs every evening starting at sunset. Since I also have email from my ISP as well as the domain I registered, I have Homeseer send an email for the event to two different email addresses. In addition to knowing if Homeseer is running when I am away, if I only get one out of two emails then I know to look for email problems with one of them.

                  Comment


                  • #39
                    For me, 1.7 (don't laugh) has been so stable on my Pentium 4, 1Gig machine that it just runs. But I have a heartbeat timer that I setup between my OmniPro and HS. Every 10 minutes (random as they both count down on their own) one controller will Ping (Set M9 ON), and the other will Pong (my setting M9 OFF). When they see that their M9 ON was set to OFF, they just restart the timer. If HS sends a Ping and doesn't get a Pong in 10 seconds, it will email me that the OmniPro is offline. Same with the OmniPro, it will text me if it doesn't get a Pong from HS and also both announce over the home speakers that it's cousin is not responding and to please investigate.

                    Other than that, if I don't get any messages, no news is good news. I solved the Internet out issue last year when I got a Synology router that has a fail-over cellular modem option, so if the broadband fails, it will turn up the cellular connection and reestablish an Internet connection until the broadband comes back.

                    As for power, everything are on at least 1500VA UPS's, backed up with a 22KW Generac whole home generator that will kick in as within 40 seconds of a power failure. So the UPS's only have to run everything for about 1-4 minutes tops. Also when power is lost, HS emails me that the home has lost power and is running on generator, and when power comes back, it emails me again saying that it's back on utility power. Same again with announcements throughout the home.

                    Comment


                    • #40
                      Here is what happens here.

                      Every day at 5am I get an email (from an event) telling me the system is up and running. I have a timer that starts whenever HS3 starts so I can also report the uptime in that daily email. If I don't get the email, I check into it.

                      When ever HS3 is restarted, in the startup routines I set the uptime timer to zero and send an email that HS3 was restarted. So I know when it restarts, which clues me to look into why. This almost never happens and if it does, it is usually a power fail.

                      Also, since I use a custom HSTouch app, I can look on there for additional indications of system health.

                      Now let me say, these indicators weren't built because I was experiencing problems but rather my background told me they would be useful. I run HS3 on Win 10 Home. It works great. I tend to lag a bit on updates but not too far behind. I just like to let the dust settle on new releases. As example, I just installed Win10 1903 a few days ago. The system is super stable. I've seen uptimes of over 90 days and that only ended because I needed to reboot because of stuff I was doing.

                      Just remembered one other thing that has been useful. Whenever my ISP assigns a new IP address, my firewall (pfSense) sends me an email telling me it has changed. If that is changing often, it clues me to take a look at the network.

                      Comment

                      Working...
                      X