Announcement

Collapse
No announcement yet.

Way to Replace a Device (ref#) with a New Device?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Way to Replace a Device (ref#) with a New Device?

    Searched "replace"... no joy... would'a thought...
    Is there a way to get HS3 to replace all references to one device (ref#) with a different device (ref#)?
    Or is it possible to delete a device and reassign it's ref# to a new device?

    #2
    There was a HS2 replace that I think is still available in HS3 try YourHSIP:Port/repl There is no guarantee it will work so backup first.
    Zwave = Z-Stick, 3xHSM100� 7xACT ZDM230, 1xEverspring SM103, 2xACT HomePro ZRP210.
    X10 = CM12U, 2xAM12, 1xAW10, 1 x TM13U, 1xMS13, 2xHR10, 2xSS13
    Other Hardware = ADI Ocelot + secu16, Global Cache GC100, RFXtrx433, 3 x Foscams.
    Plugings = RFXcom, ActiveBackup, Applied Digital Ocelot, BLDeviceMatrix, BLGarbage, BLLAN, Current Cost, Global Cache GC100,HSTouch Android, HSTouch Server, HSTouch Server Unlimited, NetCAM, PowerTrigger, SageWebcamXP, SqueezeBox, X10 CM11A/CM12U.
    Scripts =
    Various

    Comment


      #3
      Not possible. That's right from HST anyway. Maybe someone has another way?

      Comment


        #4
        If it is a z-wave device, there is a "replace" function on the z-wave tab of the device page(in HS3)---assume it is still available in HS4. Before trying be sure the old device is not "removed"(from z-wave) but is physically disconnected or dead and not communicating with your z-wave interface or the replace function will not work. I always to a "test connectivity" function before I try replace.

        Comment


          #5
          Originally posted by BobSpen View Post
          If it is a z-wave device, there is a "replace" function on the z-wave tab of the device page(in HS3)---assume it is still available in HS4. Before trying be sure the old device is not "removed"(from z-wave) but is physically disconnected or dead and not communicating with your z-wave interface or the replace function will not work. I always to a "test connectivity" function before I try replace.
          It's still gonna get a new refID though. The question was how to reuse a HS refID.

          I should add, I don't use zwave devices but I'm assuming a HS refID is a HS refID regardless of protocol

          Comment


            #6
            Just checked HS3 and /repl is still there.
            Zwave = Z-Stick, 3xHSM100� 7xACT ZDM230, 1xEverspring SM103, 2xACT HomePro ZRP210.
            X10 = CM12U, 2xAM12, 1xAW10, 1 x TM13U, 1xMS13, 2xHR10, 2xSS13
            Other Hardware = ADI Ocelot + secu16, Global Cache GC100, RFXtrx433, 3 x Foscams.
            Plugings = RFXcom, ActiveBackup, Applied Digital Ocelot, BLDeviceMatrix, BLGarbage, BLLAN, Current Cost, Global Cache GC100,HSTouch Android, HSTouch Server, HSTouch Server Unlimited, NetCAM, PowerTrigger, SageWebcamXP, SqueezeBox, X10 CM11A/CM12U.
            Scripts =
            Various

            Comment


              #7
              Thanks for the responses!!
              I searched on "/repl" and did find good info: https://forums.homeseer.com/forum/ho...e-reference-id

              Reading that thread decided the replacement may be too risky especially since I'm replacing a zwave device with a mqtt wifi device... I'll just do the individual event fixes... at least with Jon00 Event Viewer I can be sure to find all the affected events.

              Would be a nice feature for HS4 to provide if can be done reliably.

              Comment

              Working...
              X