Announcement

Collapse
No announcement yet.

Alexa/Echo TTS using HomeSeer and Node Red - A “begginers” guide.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #31
    Originally posted by ksum View Post
    You want to set an event to run a script, check the box for immediate command and save, then you can enter the code:
    Code:
    &nhs.SetDeviceString(ZZZZ, "My String", True)
    Replace ZZZZ with the device ID.

    It can get more complex but then you may want to make it a full blown script.
    Thanks This is working great . All TTS is working even without using Easy Triiger.

    Click image for larger version

Name:	Capture.PNG
Views:	250
Size:	33.7 KB
ID:	1423948

    Comment


      #32
      Originally posted by ksum View Post
      You want to set an event to run a script, check the box for immediate command and save, then you can enter the code:
      Code:
      &nhs.SetDeviceString(ZZZZ, "My String", True)
      Replace ZZZZ with the device ID.

      It can get more complex but then you may want to make it a full blown script.
      Thanks ksum , I've added this to the original post.

      Now if only I could fix that spelling mistake in the title

      Comment


        #33
        Thank you for an excellent guide, Fellhahn.

        Is there a way to set the device string to null/"X" at the end of the flow, rather than repeating the wait/reset actions in each event?

        I tried to create a flow like this, but haven't yet figured out the node to change the payload to "X" and update the HS4 device status string.

        Any suggestions, please?

        Click image for larger version

Name:	Capture.JPG
Views:	211
Size:	49.8 KB
ID:	1426392

        Comment


          #34
          I think I've cracked it ... updated flow and rules for the change node are enclosed for info.

          Click image for larger version

Name:	Capture.JPG
Views:	196
Size:	36.0 KB
ID:	1426518

          Click image for larger version

Name:	Capture.JPG
Views:	197
Size:	55.5 KB
ID:	1426519

          Comment


            #35
            You only need the quotes around the X if you want to pass a string with quotes inside it. If that is what you need, then great. If you want a string passed that is just the letter X, then remove the quotes.

            Also note that on some cases I have had to Remove msg.payload before I could set it. This has happened when msg.payload contained multiple items, meaning msg.payload was an Object and not just a string of other simple variable. It can be done in the same change node, you just remove it then set it.
            Karl S
            HS4Pro on Windows 10
            242 Devices
            56 Z-Wave Nodes
            37 Events
            HSTouch Clients: 3 Android, 1 iOS
            Google Home: 3 Mini units 1 display

            Comment


              #36
              Does anybody know if we have to use a different Alexa host for Canada. I thought I had it working with the US settings but it doesn't stay authorized and there isn't a cookie file.

              Comment


                #37
                Doesn't look like there is a Canadian server to use
                USA pitangui.amazon.com amazon.com en-US
                UK alexa.amazon.co.uk amazon.co.uk en-UK
                GER layla.amazon.de amazon.de de-DE
                ITA alexa.amazon.it amazon.it it-IT
                AUS alexa.amazon.com.au

                I think as part of my troubleshooting I did 2 things that may help. Create the file you are using to store your cookie. Restart node red.
                HS4 Pro on Shuttle NC10U, Win10; Z-NET
                Number of Devices: 449
                Number of Events: 210

                Plug-Ins: Arduino, BLLock, DirecTv, EasyTrigger, Honeywell WiFi Thermostat, MeiHarmonyHub, PHLocation2, Pushover 3P, UltraM1G3, WeatherXML, Worx Landroid, Z-Wave

                External applications: Homebridge-homeseer, Geofency, EgiGeoZone.

                Comment


                  #38
                  Click image for larger version

Name:	screencapture-192-168-1-15-1880-2020-10-19-08_36_51.png
Views:	164
Size:	48.6 KB
ID:	1427048Click image for larger version

Name:	screencapture-192-168-1-15-1880-2020-10-19-08_31_31.png
Views:	154
Size:	58.2 KB
ID:	1427049 I entered in the file location in my server info as C:\Users\Homeseer-Server\Documents\Node-Amazon\authfile but there isn't anything being created. I don't see the red dots or green dots. And there isn't anything showing to login to the server.

                  Comment


                    #39
                    You will now see a flashing message below the Alexa Routine node telling you the address to browse to
                    I deleted the alexa-remote-2 node and imported it again and set everything up again and I don't get the message below. Mine says Authentication Failed with a red square beside it. I haven't logged into my Alexa account. I didn't ask me to. What do I do to correct this?

                    Update....I redid the account and left everything as is in the settings. I created a folder in the C drive for the authentication file. C:\Node-Amazon\authfile is what I entered in the file path. This worked and it told me to open localhost:3456 in my browser, which I did and logged into my Alexa account. I now see the green dot and it says Ready. However, when I look in the folder I created there isn't a file. Shouldn't it had created a file?

                    Comment


                      #40
                      Have any Canadians gotten this to work? I am pulling my hair out trying to get this to work. It seems to work but then there is no authorization file created. I have gone through the steps over and over again and it doesn't speak. When I try again to do an authorization of a new account with the same things filled in I get Authentication Failed. I really don't think it works right here in Canada. Any help would be appreciated.

                      Comment


                        #41
                        Originally posted by pcgirl65 View Post
                        Have any Canadians gotten this to work? I am pulling my hair out trying to get this to work. It seems to work but then there is no authorization file created. I have gone through the steps over and over again and it doesn't speak. When I try again to do an authorization of a new account with the same things filled in I get Authentication Failed. I really don't think it works right here in Canada. Any help would be appreciated.
                        Can you check the permissions on that directory where you're trying to create the file? As a catch all check, set the permissions on the folder to "Everyone -> Read and Modify".

                        If it works, don't leave it that way obviously. It just sounds a little like whatever account the node red service is running as, doesn't have permissions to create the required file.


                        Edit: You might also try specifying en-CA as the language, instead of en-US. I can't find any details about a separate regional address, but I do know that skills are limited by regional language and Amazon differentiates between en-CA and en-US for that reason. Might have some bearing here.

                        Comment


                          #42
                          Originally posted by Walnut2000 View Post
                          I think I've cracked it ... updated flow and rules for the change node are enclosed for info.

                          Click image for larger version

Name:	Capture.JPG
Views:	196
Size:	36.0 KB
ID:	1426518

                          Click image for larger version

Name:	Capture.JPG
Views:	197
Size:	55.5 KB
ID:	1426519
                          So that I don't have to reset the string in each event I created an event that does the resetting. It uses EasyTrigger to see if the string changed to anything that isn't an empty string, waits 1s and then sets the device to an empty string.

                          Click image for larger version

Name:	ResetAlexa.png
Views:	135
Size:	29.3 KB
ID:	1427635

                          Comment


                            #43
                            Originally posted by tenholde View Post
                            Anyone using node-red announcements with Sonos One speakers with Alexa built in? If I speak to an echo dot, I can use either a REGULAR message or an ANNOUNCEMENT and the speaker works both ways, with and without a leading chime. However, the Sonos One speakers work fine with REGULAR messages, but if I try an ANNOUNCEMENT I get nothing, not even the message.

                            Can anyone try this to see if they get the same results?
                            Did you have any luck with the sonos one?
                            I have the same issue.

                            Thanks,
                            Cor

                            Comment


                              #44
                              Originally posted by Corvl1 View Post

                              Did you have any luck with the sonos one?
                              I have the same issue.

                              Thanks,
                              Cor
                              Have not found a solution
                              tenholde

                              Comment


                                #45
                                Check this topic. https://forums.homeseer.com/forum/ho...he-same-phrase
                                I have this working great and I use 2 echo dots and one Sonos One. It seems to be working great. If you need the flow, just let me know.

                                Comment

                                Working...
                                X