Announcement

Collapse
No announcement yet.

Homeseer Zee Backup

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Here try to purchase micro SD card with SD sleeves.

    That said I also have a small combo USB device with a little tray in it for holding SD cards. This device has USB ports and slots for just about any sort of memory card (even CF cards). Cheapo Ebay $5 purchase.

    Still doesn't help me when a microsd card shoots across my home office and lands on the rug.

    Playing with a new Pine64 2 Gb machine with a Pine64 provided case. Interesting that the case snaps together with plastic tabs and there is no micro sd slot on the case such that you have to remove the motherboard (4 screws) to get to the sd slot. Real mickey mouse design.

    Note that the guitar maker's Pine64 case has a slot for the microsd card on it.
    - Pete

    Auto mator
    Homeseer 3 Pro - 3.0.0.534 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU - Mono 6.00
    Homeseer Zee2 (Lite) - 3.0.0.534 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.00

    X10, UPB, Zigbee, ZWave and Wifi MQTT automation.

    Comment


    • #17
      Pete,

      I did find my adapter a few minutes ago. It was under a piece of mail.
      Moved it to my workbench for safe keeping.

      Re Pine64, Wow, at those prices, that is amazing! The price of computer power has come down SO much!

      --Dan
      Tasker, to a person who does Homeautomation...is like walking up to a Crack Treatment facility with a truck full of 3lb bags of crack. Then for each person that walks in and out smack them in the face with an open bag.

      Comment


      • #18
        This is Pine64 2 Gb machine #2.

        Been running one now for about a year for the Zee-2 HS3 OS.

        Flip flopping between this device and the Xi5A running Ubuntu 64 bit with 2Gb of RAM.
        The AMD Xi5A has an SSD drive rather than a microSD card.

        Mostly because it runs Ubuntu 64 bit and circles around the RPi3 (running Jessie 32 bit) and is cheaper than the RPi3.

        The Pine64 has a bigger footprint, more connectivity, built in RTC than the RPi. Mine is not running hot such that there are no heatsinks current setup.

        [ATTACH]60481[/ATTACH]


        Instead of the built in WLAN / Bluetooth the RPi folks should have just increased the memory and provided modular WLAN / Bluetooth connectivity.
        Last edited by Pete; April 5th, 2017, 02:00 PM.
        - Pete

        Auto mator
        Homeseer 3 Pro - 3.0.0.534 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU - Mono 6.00
        Homeseer Zee2 (Lite) - 3.0.0.534 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.00

        X10, UPB, Zigbee, ZWave and Wifi MQTT automation.

        Comment


        • #19
          Originally posted by zwolfpack View Post
          Some time ago I posted about this - see https://github.com/billw2/rpi-clone

          rpi-clone is a shell script that will back up a running Raspberry Pi file system to a destination SD card plugged into a Pi USB port. I have one of these for each of my rpi's. The resulting SD card is 100% identical to the source.

          A nice feature is that a larger source disk can be copied to a smaller destination, as long as the used data will fit. Another nice feature is that only changed data is written to the disk, so subsequent runs are very fast.

          I've made a couple additions to the posted version which allow it to be used as an automatic backup solution. Included in the attachment is the modified rpi-clone script and an example cron script that performs a daily (or weekly) backup when installed in the /etc/cron.daily (or /etc/cron.weekly) directory.
          Have tried this on a Rpi2 and Rpi3 but SD card will not boot. As I am a Linux novice this may be due to file permissions.

          Rpi2
          root/usr/local/sbin rpi-clone -rwxr-xr-x owner root staff
          root/etc/cron.daily rpi-clone-sda -rwxr-xr-x owner root root

          RPi3 is identical.

          Have also used the original rpi-clone from Billw2 and this works on Rpi3 but I cannot schedule it as it unmounts the USB SD card.

          My only observation is that the line sudo rpi-clone -f -y sda the sda has to be changed to sdb as it does not recognise sda.
          Any help or kick in the right direction will be much appreciated
          Thanks
          Jo

          HS3 ZEE S2 Edition 3.0.0.368
          Last edited by Jo; October 29th, 2017, 05:06 AM.

          Comment


          • #20
            Those permissions are correct.

            The current version of Billw2's script has a lot of improvements from what it did when I posted. It now has similar options to what I'd added, so I'm now using his version 2.0.19 unmodified. https://github.com/billw2/rpi-clone/archive/master.zip
            The -y option I added is instead -q so you'll need to change that in the rpi-clone-sda script if you continue to use that.

            The value added in the script rpi-clone-sda is that it has a check to compare the boot partition labels to help prevent accidental overwrite if you leave the wrong disk in the drive. If the labels don't match, the backup won't run. This means the disk needs to be initialized first by running rpi-clone with the -f option.

            If you find that your backup device is on /dev/sdb rather than /dev/sda, just change the DEST variable in rpi-clone-sda to
            DEST=sdb

            If you don't want the disk label check, you can schedule rpi-clone directly -
            create a file /etc/cron.daily with permissions 755 and contents
            Code:
            #!/bin/sh
            dest=sdb
            rpi-clone -q $dest
            change dest as appropriate.

            Comment


            • #21
              Thank you Zwolfpack

              Will try out your suggestions.

              Jo

              Comment

              Working...
              X