Announcement

Collapse
No announcement yet.

Fibaro Dimmer 2 FGD-212 status not reporting

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Fibaro Dimmer 2 FGD-212 status not reporting

    Hi all

    I have several Fibaro dimmers I'm trying to add. The older ones work fine, but the newer dimmers (Dimmer 2, or FGD-212) don't seem to report their status. It just appears as "Unknown"

    They do respond to commands and work appropriately otherwise, though.

    Is there something simple I'm missing?

    Current Date/Time: 3/13/2018 9:21:38 AM
    HomeSeer Version: HS3 Pro Edition 3.0.0.368
    Linux version: Linux hometrollerSEL 3.16.0-031600-generic #201408031935 SMP Sun Aug 3 23:56:17 UTC 2014 i686 i686 i686 GNU/Linux System Uptime: 0 Days 19 Hours 13 Minutes 9 Seconds
    IP Address: 192.168.86.203
    Number of Devices: 172
    Number of Events: 2
    Available Threads: 199

    Enabled Plug-Ins
    3.0.0.16: Chromecast
    3.0.0.30: Nest
    3.0.0.82: weatherXML
    3.0.1.190: Z-Wave

  • #2
    Assuming you are not controlling any other devices by direct association from the FGD-212, if you remove all the associations that the Z-Wave plug-in creates, set up associations as in the attached screenshot and then do a full optimize on the node, does it then report status?

    Paul..
    Attached Files

    Comment


    • #3
      Hi sooty

      Nope I did a reset when I moved it over to the Homeseer, so there shouldn't be any associations. I removed all the existing ones (see screenshots) but I can't see a way to make the first line association that appears in yours?

      Did the full optimise and it still doesn't display properly. Any other ideas?

      Click image for larger version

Name:	dimmer2_scrn1.jpg
Views:	1
Size:	95.1 KB
ID:	1195849
      Click image for larger version

Name:	dimmer2_scrn2.jpg
Views:	1
Size:	79.4 KB
ID:	1195850
      Click image for larger version

Name:	dimmer2_scrn4.jpg
Views:	1
Size:	87.8 KB
ID:	1195851

      Comment


      • #4
        In your 2nd screenshot hit the red X next to each association (one at a time) and you should get a message near the top of the page saying that the association was removed.

        Hit the update button until the association group drop down populates.

        You should then be able to add new associations as in my screenshot.

        I've just deleted and re-added associations here on one of my FGD-212's without issue running Z-Wave plug-in 3.0.1.202.

        Paul..

        Comment


        • #5
          Sorry, I wasn't clear -- I did that but could only get the second line of your screenshot to appear; I can't get the first line that s ays ID1 and doesn't give an endpoint.

          My last screenshot was of before, to show what was there after a hard reset. Here is a screenshot of what's there now.

          Homeseer reports the FGD-212 as firmware v3.5
          My z-wave plugin is 3.0.1.190. The update column says N/A. Is your version a beta?

          Any ideas?

          Click image for larger version

Name:	dimmer2_scrn3.jpg
Views:	1
Size:	35.6 KB
ID:	1195852

          Comment


          • #6
            The display of association data can be a bit hit and miss in the HS3 user interface and sometimes requires multiple clicks on the update button and / or a full optimize before it will show correctly.

            As shown in your last screenshot with "Group 1 : HomeSeer : (No Endpoint) what happens if you hit the Add Association button?

            Do you get a message in red saying that the association was added successfully?

            If so, then close the associations, hit the full optimize button and re-open associations.

            Hit the Audit button and see what it shows for associations at the bottom of the list.

            Yes, I'm running a beta version of the Z-Wave plug-in but these devices were added to my system with a previous version.

            Paul..

            Comment


            • #7
              Hi again Paul

              I was tinkering with the "status graphics" tab and managed to get it to show a status sometimes, but it would keep going back to "unknown"

              I didn't screenshot the original settings so I thought I'd give it another reset. This time I removed the node and re-added it non-secure (hadn't thought of that before) and it seems to work now.

              No idea if it was just the removing/re-adding that did it or if the 212 supports secure inclusion and this somehow resulted in the problem?

              Either way, thanks for putting the effort in to helping me out!

              Comment


              • #8
                Device state not updating

                Hi again

                I've only just found time to get back to tinkering with this, which is frustrating!

                The same FGD-212 Fibaro Dimmer 2 now shows a status, but it will not update the status from the device. If I use the physical switch to change the device, its status in Homeseer does not change.

                I have played around but I can't get the associations to show the same way as your screenshot. It will only let me add an association to Homeseer with no "endpoint". If I select an endpoint, the red writing says it was successfully set but it never shows up even on refresh. All I can do is this:

                Click image for larger version

Name:	dimmer_x.jpg
Views:	1
Size:	34.7 KB
ID:	1195913

                Help!!

                Comment


                • #9
                  Just to update: finally managed to get the FGD-212 working correctly but I have no idea how. I've been trying various combinations of adding, removing, restarting, resetting etc etc etc, and trying what has worked for others on the forum. After another remove/reset/add (secure) it seems to be working, without any further tinkering on my part.

                  In case it helps anyone, here is how the setup looks after the latest include:

                  Click image for larger version

Name:	yaay1.jpg
Views:	1
Size:	52.1 KB
ID:	1195921
                  Click image for larger version

Name:	yaay2.jpg
Views:	1
Size:	38.0 KB
ID:	1195922
                  Click image for larger version

Name:	yaay3.jpg
Views:	1
Size:	60.4 KB
ID:	1195923

                  Comment


                  • #10
                    Hi all

                    I'm still really struggling with this.

                    I had a bunch of Fibaro FGD-211s and one FGD-212 all working on my old (Fibaro HC2) system.

                    When I add FGD-212 to Homeseer, it either: a) won't update its status, so you can change it from the physical light switch and Homeseer doesn't change, or b) will update its status, but the status icon only briefly flashes up with "On" or "Off" before being replaced with "Unknown" and a question mark.

                    It took me a whole afternoon (of adding, removing, resetting, re-adding, in various combinations including secure and non-secure), but I eventually got the FGD-212 to work, although I have no idea how.

                    I can't for the life of me set Parameter 20 on the FGD-211s. I can set other parameters fine. I need to change Parameter 20 to get the FGD-212s to work with my LED lights, and no one on here could help.

                    I decided to sell the FGD-211s on ebay and replace them with FGD-212s.

                    I am now trying to add the FGD-212s and I can't get any of them to add properly. They all have the same problems as the first one!

                    Help!!!

                    Comment


                    • #11
                      Im having the same issue here.

                      All my light switches (40+) are Fibaro Dimmer 2's and would love to know the secret of getting the statuses updated.

                      I came from Vera, where they worked slowly but updated perfectly. It would appear to be something inside HS then.

                      Any help is super appreciated.

                      Comment


                      • #12
                        I FOUND IT!!!!!

                        It would appear if you add the node as a SECURE node, the response back from the dimmer doesnt make sense to HS.

                        If you add all your nodes as unsecure (not ideal) it will show all the statuses without issue.

                        Comment


                        • #13
                          Any update on this? Don't like to add my nodes unsecured

                          Comment


                          • #14
                            Originally posted by kriz83 View Post
                            Any update on this? Don't like to add my nodes unsecured
                            Are you worried your neighbors are going to try to take over your lights? Based on the thread, not sure if anyone has actually reported this issue to HS, so if you want to get it fixed, you may need to report it to them.
                            HS 3.0.0.548: 1970 Devices 1149 Events
                            Z-Wave 3.0.1.262: 123 Nodes on one Z-Net

                            Comment

                            Working...
                            X