Announcement

Collapse
No announcement yet.

Kwikest 888 lock - Issue Fixed!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Kwikest 888 lock - Issue Fixed!

    Hi All,

    I just got two kwikset 888 z-wave locks. locks are paired to Homeseer, one via a smart stick + and one via a z-net. locks are working and get all notifications except when I unlock using the user code on the keypad, then the notification in the log is "Notification Event Exception: Index was outside the bounds of the array."

    updated to the latest z-wave beta 3.0.1.227 and made no difference. and running the current version of HS3 3.0.0.435

    any ideas?

    Thanks

  • #2
    Same issue here with a Kwikset 914

    Lock control is fine from Homeseer... but when using a user code to unlock..

    Door Locks FrontDoor Access Control Notification Set to NOTIFICATION for type Access Control Notification, Event: Notification Event Exception: Index was outside the bounds of the array.

    Any idea/direction is appreciated

    Regards,

    Andrew B.

    Comment


    • #3
      I have been working with Homeseer Support on this issue for a couple of days. My problem was with the Kwikset Smartcode 888 lock. The "Index was outside the bounds of the array" was fixed with Zwave beta 3.0.1.238 however, I still do not get the User number when I access the door and therefore cannot determine who accessed the house.

      I have a Kwikset 914 lock that is working properly in all respects with 3.0.1.238. My only problem is with the Kwikset 888 lock.

      Bob

      Comment


      • #4
        Thanks for the update.. I’ll try the 238 and post back what I find

        Thanks again


        Sent from my iPad using Tapatalk
        Regards,

        Andrew B.

        Comment


        • #5
          Any update on this?

          Build a brand new 3.0.0.435 server
          HomeSeer SmartStick + Z-Wave
          Z-Wave Plugin 3.0.1.190

          Everything works on the lock, but I also get the "Index was outside the bounds of the array" message in the log when unlocking by user code. This is a show stopper for me, so any help would be appreciated.

          Comment


          • #6
            If you install ZWave Beta 3.0.1.239 it will fix the "index was outside the bounds of the array" error. The problem now is that the lock will still not report the "User" that accessed the door. The Zwave protocol changed significantly with the new ZWave + lock. The old ZWave lock used an event type "1" for user access by keypad and the new Zwave + lock uses event type "6" for this. If you look at the lock "Notification Device" and select the tab for Status Graphics you will see that code 5 and 6 do not even get created during the lock enroll (include). Event 5 is the door lock by keypad and event 6 is door unlock.

            I was told today by Homeseer support that they were trying to obtain a Kwikset 888 lock from Kwikset to be able to work on this problem. I offered to drop ship them a lock for testing if it would help.

            Bob

            Comment


            • #7
              Thank you for that reply Bob. After turning on ZWave debugging I did notice that event type 6 is being returned by the lock upon keypad entry. It just stops there though when that exception gets thrown. I have a non ZWave plus Smartcode 916 that is working just fine. When I look at the debug log from that device, as you mentioned, the event 1 gets returned quickly followed by a user code. It seems to me like HS isn't setting up the device properly on inclusion.

              Appreciate you following up with HS support. Do you think I should reach out to them as well?

              Rich

              Comment


              • #8
                Do you think I should reach out to them as well?
                It would not hurt...

                Bob

                Comment


                • #9
                  Originally posted by Bob_Linux_User View Post

                  I was told today by Homeseer support that they were trying to obtain a Kwikset 888 lock from Kwikset to be able to work on this problem. I offered to drop ship them a lock for testing if it would help.

                  Bob
                  Same symptoms on a kwikset 914.

                  Put a support request in... HS notified me that they were trying to get a lock to test..

                  I figure they will to it as soon as practical after they get a lock.




                  Sent from my iPad using Tapatalk
                  Regards,

                  Andrew B.

                  Comment


                  • #10
                    Put a support request in... HS notified me that they were trying to get a lock to test..
                    I hope they get this fixed soon. The Zwave plus lock is much more reliable than the old lock. I can only use it on my garage due to the User problem but it has been rock solid since I installed the lock. I would get frequent communication errors with the old lock and often it did not lock/unlock from HS3. I am just waiting on a HS3 fix to purchase more locks.

                    Bob

                    Comment


                    • #11
                      Zwave 3.0.1.243 (non-Beta) is available which will fix the Kwikset Smartcode 888 Zwave Plus lock. The User Code is now recognized and will trigger events. Be aware that the HS3 Log does not display the User Code but it is displayed in the Device Management Page on the lock Notification device. Thanks to HS for getting this fixed.

                      Bob

                      Comment


                      • #12
                        Was notified of ZWave 3.0.1.243 update via email (in response to bug report i had made earlier)..
                        That Took care of the issue

                        Thank you HS Tech for the prompt solution !!!
                        Regards,

                        Andrew B.

                        Comment


                        • #13
                          You can use the below .vb script in your door events to log the User number that accesses your door until HS fixes the logging. Just change the "Device_Code" to match your device number of your lock "Notification" device and the write_string to match the description of your door. It will report the user number as "6001 - 6030" for unlock and "5001 - 5030" for lock which relates to User 1 - 30.

                          Code:
                          Sub Main(parm as object)
                             Dim Device_Code as integer = 2140
                             Dim write_string as String = ""
                             Dim User as integer
                             User = hs.DeviceValue(Device_Code)
                             write_string = "Kitchen Door Access by User " & CStr(User) & ControlChars.CrLf
                             hs.Writelog("Z-Wave",write_string)
                          End Sub
                          Bob

                          Comment

                          Working...
                          X