Announcement

Collapse
No announcement yet.

z-wave delay

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • z-wave delay

    Hi,

    since a few weeks, I am experiencing a delay when executing commands. When manually switching a light on or asking google Home to do it, it can take 10 seconds or longer to get an action. Any idea's what could be the issue here? Using Aeon USB stick on Linux box.

    Thanks

  • #2
    I had similar issues. Try to turn off polling on plugins manage zwave. If that helps, you will need to reduce polling on your devices. This was my issue.
    How many devices do you have ?

    Comment


    • #3
      I have 21 nodes, but 2 of those are 5 way sockets (greenwave) 10 nodes are polled every 90 seconds or else they go into some kind of panic mode. The other ones are off......... so don't think it is too much poling?

      Comment


      • #4
        darkjamzi you must separate the issues first.
        1. Google Home response time has far too many internet dependencies/lag possibilities to every try and diagnose a "speed" issue.
        2. Local execution time of on/off. There is a slight delay in the web interface of visible change versus physical change. Just the timing based on the time stamp or physical view of the lights

        Next up... is this "slow" issue with a single action to a single device or to a group of devices and the last device is the one where the "time" is being accounted for?

        Comment


        • #5
          It doesnt sound like excessive polling. Saying that. Do you poll the root devices every 90 seconds ? Did you check your node list (Plugins - zwave - node list) for polling ? I found there were a lot of devices polling I was not aware...
          Did you try to turn polling off to see what happens ? I agree, Google home or Alexa are useless as a measure for reaction speed.

          Comment


          • #6
            Simplex Technology it is not 1 specific device, it is all Z-wave devices, and ONLY Z-wave devices. I have a rule that at a certain time lights switch off. A lot of these lights are Ikea light bulbs controlled with the Jowihue plug-in. Some are lightwaveRF sockets with a light plugged in and some are Z-wave switches. Normally these all would switch off almost instant and together, but now the z-wave devices go off around 10 seconds later.

            My curtains are controlled via the remotec z-wave IR controller. It used to be that at sunset, the curtains would close and 7 seconds later the lights would come one (as it takes roughly 7 seconds for the curtains to close). At the moment however, the light come on and then few seconds later the curtains close.......

            Asking google or switching manually through HS touch makes no difference.

            Comment


            • #7
              mikee123 I checked node list, and most are disabled. I noticed 3 battery devices who poll every 12 hrs. I'll run optimize a network, maybe that will help.....

              Comment


              • #8
                Maybe it isn't the polling then. It could be a faulty device flooding the network. Very hard to find. If you suspect it is, you'll have to turn off one device at the time to see if that improves. Also, what has been suggested to me was to turn the power of to all devices to reset them (main breaker)

                Comment


                • #9
                  I had same problem.
                  1. Using Z-Seer app I found that I had a few devices which were not connected - I added them to network, but never used. I suspect that controller tries to use them to send commands and waits for responce. So I removed the unused devices (you can use "Remove Bad Node").
                  2. Regarding optimisation. I found that optimisation in HS web interface works better than "Full Optimize" in Z-Seer. But you have to optimize each device separately. Be patient.

                  Use "Optimise" first - not less than three times. It helps the node to discover neighbour nodes properly. Then do "Full Optimize". It takes time and a lot of patience, but it pays in the end. I was going to giveup on Z-Wave and find something more responsive. But after this procedure - it's now immidiate!

                  And remember to remove unused devices first, before I removed them optimization was taking really long time.

                  Click image for larger version

Name:	Capture.PNG
Views:	78
Size:	4.8 KB
ID:	1282744

                  Comment


                  • #10
                    Optimization has different recommendations depending on whether you have Z-Wave (and/or Z-Wave+) devices. See this post for recommendations.


                    https://r.tapatalk.com/shareLink?url...3&share_type=t

                    Comment


                    • #11
                      Originally posted by NetworkGuy View Post
                      Optimization has different recommendations depending on whether you have Z-Wave (and/or Z-Wave+) devices. See this post for recommendations.
                      I spent a lot of time troubleshooting the latency issue. What I found - in Z-Seer automatic optimisation sometimes produces funny results.
                      So again, have to be patient and optimize each node. In Z-Seer you can double click on a node - it will show the route to this node. You may find some unnecessary hops there, may be including 40k devices. In this case I try to optimise (only) this node again.

                      I find when you optimise a few times - it discovers more neighbours. Assuming your Z-Wave network is NOT dense. The more devices you add - the better it becomes. If I find devices with small number of neighbours (i.e. only 1) in some part of my house - I install a 100k Z-Wave power point plug in this area - you can always find a use for it. And don't waste money on range extenders - they function same way as other Z-Wave devices (for routing), but don't add any functionality.

                      If automatic optimisation doesn't give good results - there's also an option to set command route manually. But again - this option allows only choosing from discovered neighbours. So you need to try optimize device first for that.

                      The aim is of course - (1) minimise number of hops for each device and (2) try to make sure that fastest (100k) devices are used for routing.

                      And after you optimise a node - must repeat this process for neighbours as they depend on this node too. There's a lot of inter-dependencies and I don't think automatic optimisation can resolve them unless it's using CNN algorithms (which I doubt Z-Seer does).


                      Comment


                      • #12
                        Thanks guys, I'll play around a bit with this optimization.

                        Comment


                        • #13
                          In the past when I was doing a fair amount of polling I would vary the times. Only odd numbers for times and never the same for more than one node. So if I was polling 10 nodes every 90 seconds I would do something like 87, 91,97, etc so the pattern would always vary over time.
                          stuart

                          Comment


                          • #14
                            Is there much difference in delay with secured vs non-secured devices ?

                            Comment

                            Working...
                            X