Announcement

Collapse
No announcement yet.

Lockup HT-SEL & Spontaneous Unwanted HS3 Restarting

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Lockup HT-SEL & Spontaneous Unwanted HS3 Restarting

    HELP!
    For some unknown reason(s), my HomeTrollerSEL occasionally locks up and HS3 become unresponsive (a few times a week)... my only solution to date has been to unpowered-repower the HT-SEL (hard reboot)
    After re-powering and watching the log, it seems that the HS3 starts & restarts spontaneously numerous times

    ("HomeSeer version 3.0.0.435 Edition: HS3 Pro (SEL) Starting Now")
    ...
    ("
    STARTUP COMPLETE: All configured interfaces were successfully initialized")

    ...then within a few minutes the entire process repeats for no apparent reason. This can occur up to 3 times.

    After this cycling the HomeTrollerSEL- HS3 works pretty flawlessly for a few day until for some unknown reason it all begins again.

    Anybody have any ideas how I can troubleshoot this?

    thanks, Scott




    Current Date/Time: 1/1/2019 10:44:18 AM
    HomeSeer Version: HS3 Pro Edition 3.0.0.435
    Linux version: Linux hometrollerSEL 3.16.0-031600-generic #201408031935 SMP Sun Aug 3 23:56:17 UTC 2014 i686 i686 i686 GNU/Linux System Uptime: 0 Days 4 Hours 39 Minutes 44 Seconds
    IP Address: 192.168.1.3
    Number of Devices: 49
    Number of Events: 89
    Available Threads: 199
    HSTouch Enabled: True
    Event Threads: 1
    Event Trigger Eval Queue: 0
    Event Trigger Priority Eval Queue: 0
    Device Exec Queue: 0
    HSTouch Event Queue: 0
    Email Send Queue: 0
    Anti Virus Installed:

    Enabled Plug-Ins
    3.0.0.36: X10
    3.0.1.249: Z-Wave

    #2
    How long have you had the SEL? Were there any recent changes? How long has this been happening?

    Comment


      #3
      Maybe try to disable HSSentry (Software system monitor).
      - Pete

      Auto mator
      Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb
      Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro
      HS4 Lite - Ubuntu 20.04 / VB W7e Jetway JBC420U591
      Fanless Intel® Celeron N3160 SoC 8Gb
      HS4 Pro - V4.1.18.1 - Ubuntu 20.04/VB W7e 64 bit Intel Kaby Lake CPU - 32Gb
      HSTouch on Intel tabletop tablets

      X10, UPB, Zigbee, ZWave and Wifi MQTT automation-Tasmota-Espurna. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

      Comment


        #4
        Originally posted by drhtmal View Post
        How long have you had the SEL? Were there any recent changes? How long has this been happening?
        Hardware in my possession since Feb, but didn't start migrating from an archaic X-10 system to a more robust Z-Wave starting around September...
        I don't know when these issues first arose, but I've noticed it most in the last few months.
        No big changes lately... (in Sept: installed ZWave addin, added a few lighting network nodes) ... ongoing, just creating a few events.

        Thanks for the assists



        Comment


          #5
          Originally posted by Pete View Post
          Maybe try to disable HSSentry (Software system monitor).
          Didn't really look at this switch in the setup... but reading the background seems to explain restarting my recent experience...

          ..but,
          when I disable the HSSentry then won't the system just stop responding completely?

          I'm going to disable it anyway and see what happens or doesn't happen going forward

          Thanks for the assists

          Comment


            #6
            It is unlikely that HSSentry is causing the controller to lock up. HSSentry will restart HS3 if it becomes unresponsive. Disabling it will stop HS3 from restarting if it freezes. Maybe with it disabled you might be able to see what is happening when it locks up. Have you looked at the HomeSeer log at the time it shuts down for clues as to why? If there is nothing apparent in the HS log, it would be reasonable to assume it is either a hardware or O/S issue with the SEL. The first step is to try to figure out what is happening when it "locks up".

            Comment


              #7
              I concur with Randy on the HSentry purpose and use.

              That said in Linux (RPi or Intel) versions of Homeseer 3 here never had it enabled from the start and that was because it caused issues with Homeseer 2.

              It was broken in HS3 Linux (documented here on the forum a while ago). Thinking now it is fixed.

              I do not believe there is a mechanism to throttle or adjust how it works.

              To get granular and maybe see what is causing the start restart thing you could:

              1 - ssh to your SEL
              2 - Use the browser interface to enable developer mode and then shut down Homeseer
              3 - start Homeseer 3 in logging mode via the remote ssh terminal (and watch the window)
              4 - concurrent to #3 you can also open a second ssh terminal window and watch the utilization via HTOP as Homeseer 3 starts.

              It is very chatty kathy and you will see everything. It could be something simple like Homeseer is starting faster than the ZWave hardware load.

              - Pete

              Auto mator
              Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb
              Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro
              HS4 Lite - Ubuntu 20.04 / VB W7e Jetway JBC420U591
              Fanless Intel® Celeron N3160 SoC 8Gb
              HS4 Pro - V4.1.18.1 - Ubuntu 20.04/VB W7e 64 bit Intel Kaby Lake CPU - 32Gb
              HSTouch on Intel tabletop tablets

              X10, UPB, Zigbee, ZWave and Wifi MQTT automation-Tasmota-Espurna. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

              Comment


                #8
                Sorry if it seems I've been ignoring you... Not... I've gone quiet whilst I monitored my system for a number of days.

                I simply disabled the HSSentry, but had expected the underlying issue(s) to remain and at sometime halt the system response....
                but...after about 5 days [GNU/Linux System Uptime: 4 Days 23 Hours 9 Minutes 28 Second] the HomeTroller SEL / HS3 system seems to be operating without any problems.

                Alas, I am unsure what caused the original non-response, but without the HSSentry enabled there have not been any recent lockups.

                Thanks for the help... I'll continue to watch.

                Comment


                  #9
                  Good news Smitty!

                  As mentioned HSSentry used to be an issue and I think it was fixed. I shut off HSSentry from the get go of running HS3 on Linux (2 machines) a few years back.

                  Let us know if you have any more issues.
                  - Pete

                  Auto mator
                  Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb
                  Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro
                  HS4 Lite - Ubuntu 20.04 / VB W7e Jetway JBC420U591
                  Fanless Intel® Celeron N3160 SoC 8Gb
                  HS4 Pro - V4.1.18.1 - Ubuntu 20.04/VB W7e 64 bit Intel Kaby Lake CPU - 32Gb
                  HSTouch on Intel tabletop tablets

                  X10, UPB, Zigbee, ZWave and Wifi MQTT automation-Tasmota-Espurna. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

                  Comment

                  Working...
                  X