Announcement

Collapse
No announcement yet.

New SEL throwing error on Chromecast.exe

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    New SEL throwing error on Chromecast.exe

    I've got brand new SEL-Pro delivered today. I get this message in the logs after I register. How do I fix this? I did not even load any plugins yet.

    Warning, Cannot load EXE file (possibly missing dependencies) HSPI_Chromecast.exe: Exception of type 'System.Reflection.ReflectionTypeLoadException' was thrown.Warning, Error details with EXE HSPI_Chromecast.exe: Could not load file or assembly 'System.Runtime, Version=4.0.10.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies.
    HS3 SEL running Pro Edition 3.0.0.531 on Ubuntu 18.04, mono 5.20, 656 devices, 209 events.
    Plug-Ins: Chromecast, Device History, EasyTrigger, Ecobee, JowiHue, LutronCaseta, MeiUnifi, PHLocation2, Pushover 3P, SDJ-Health, Sonos, WeatherFlow, weatherXML
    Scripts: SparkMan's Lock Event, 5 of Jon00 scripts.

    #2
    If you never installed the Chromecast plugin yourself, it means someone else did before the SEL was sent to you.
    If you don't need the Chromecast plugin, then you have to delete the HSPI_Chromecast.exe file from your HomeSeer directory. The easiest way would be to run the linux tools command:

    Code:
    sudo rm HSPI_Chromecast.exe

    Comment


      #3
      Here's the thing. I did a factory reset. Booting the SEL up with keyboard, mouse and monitor attached and picking restore the factory defaults from restore partition.

      It was still there after a reimage. I then tried to install the plugin, because I do want it, and it won't install. Got this in the log
      Jan-02 9:07:59 PM Error Warning, Cannot load EXE file (possibly missing dependencies) HSPI_Chromecast.exe: Exception of type 'System.Reflection.ReflectionTypeLoadException' was thrown. Could not load file or assembly 'System.Runtime, Version=4.0.10.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies.Warning, Error details with EXE HSPI_Chromecast.exe: Could not load file or assembly 'System.Runtime, Version=4.0.10.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies.
      Jan-02 9:07:59 PM Updater Install/Update of package Chromecast was successful.
      Jan-02 9:07:59 PM Updater Extraction Complete.
      Jan-02 9:07:59 PM Updater Extracting files from zip file: images.zip
      Jan-02 9:07:59 PM Updater Warning File exists, not overwriting: \usr\local\HomeSeer\Config\\Chromecast.ini
      Jan-02 9:07:59 PM Updater Copying file: /usr/local/HomeSeer/bin/Chromecast/avahi-sharp.dll.config
      Jan-02 9:07:59 PM Updater Copying file: /usr/local/HomeSeer/bin/Chromecast/avahi-sharp.dll
      Jan-02 9:07:59 PM Updater Copying file: /usr/local/HomeSeer/bin/Chromecast/Mono.Zeroconf.Providers.Avahi.dll
      Jan-02 9:07:59 PM Updater Copying file: /usr/local/HomeSeer/bin/Chromecast/Mono.Zeroconf.dll
      Jan-02 9:07:59 PM Updater Copying file: /usr/local/HomeSeer/bin/Chromecast/Sockets.Plugin.dll
      Jan-02 9:07:59 PM Updater Copying file: /usr/local/HomeSeer/bin/Chromecast/Sockets.Plugin.Abstractions.dll
      Jan-02 9:07:59 PM Updater Copying file: /usr/local/HomeSeer/bin/Chromecast/SharpCaster.dll
      Jan-02 9:07:59 PM Updater Copying file: /usr/local/HomeSeer/bin/Chromecast/Newtonsoft.Json.dll
      Jan-02 9:07:59 PM Updater Copying file: /usr/local/HomeSeer/bin/Chromecast/Google.Protobuf.dll
      Jan-02 9:07:59 PM Updater Copying file: /usr/local/HomeSeer/HSPI_Chromecast.exe.config
      Jan-02 9:07:59 PM Updater Copying file: /usr/local/HomeSeer/HSPI_Chromecast.exe
      Jan-02 9:07:58 PM Updater Installing package Chromecast
      Jan-02 9:07:58 PM Updater Update hspi_chromecast.exe downloaded successfully
      Jan-02 9:07:58 PM Updater Downloading update: Chromecast
      HS3 SEL running Pro Edition 3.0.0.531 on Ubuntu 18.04, mono 5.20, 656 devices, 209 events.
      Plug-Ins: Chromecast, Device History, EasyTrigger, Ecobee, JowiHue, LutronCaseta, MeiUnifi, PHLocation2, Pushover 3P, SDJ-Health, Sonos, WeatherFlow, weatherXML
      Scripts: SparkMan's Lock Event, 5 of Jon00 scripts.

      Comment


        #4
        Check if there is a file Newtonsoft.Json.dll in the HS3 root (/usr/local/HomeSeer). If so, remove or rename it and try again.

        Comment


          #5
          No that file is not there. I'm also getting an error trying to install Ecobee. I found this thread https://forums.homeseer.com/forum/th...seer-sel/page2

          I'm getting the exact same error as he did a year later, I just bought it. So they did nothing to fix the missing the mono file for over a year! I'm pretty sure the issue is mono related, but I only know enough to be dangerous.

          So I removed EcoBee from the plugin screen and also used putty to connect into the box and deleted anything that said EcooBee or Chromecast.

          I ran
          sudo apt-get -y install libmono-microsoft-csharp4.0-cil
          sudo apt-get update
          sudo apt-get upgrade
          I copied over Ecobee version 22 zip update and the override file. I installed plugin 22 and still get the issue it did not fix it like it did in the thread above. I also tried to load the load the Chromecast plug in and get the same thing again.


          HS3 SEL running Pro Edition 3.0.0.531 on Ubuntu 18.04, mono 5.20, 656 devices, 209 events.
          Plug-Ins: Chromecast, Device History, EasyTrigger, Ecobee, JowiHue, LutronCaseta, MeiUnifi, PHLocation2, Pushover 3P, SDJ-Health, Sonos, WeatherFlow, weatherXML
          Scripts: SparkMan's Lock Event, 5 of Jon00 scripts.

          Comment


            #6
            What version of mono does it come with?

            Code:
            mono --version

            Comment


              #7
              So I went searching and found a thread were zwolfpack walked somebody through getting mono updated on SEL. I finally got to a point were:
              sudo apt-get install mono-devel
              sudo apt-get install mono-complete
              sudo apt-get -y install libmono-microsoft-csharp4.0-cil
              sudo apt-get install avahi-daemon

              All worked and now EcobBee and ChromeCast are working.

              IT SEEMS very Vera like, that I would have to do all this on brand new $700 box. Thank goodness for the user community. It worries me slightly.

              Here's the thread I used to get mono working and plugins working.
              https://forums.homeseer.com/forum/ho...-upgrade/page3


              HS3 SEL running Pro Edition 3.0.0.531 on Ubuntu 18.04, mono 5.20, 656 devices, 209 events.
              Plug-Ins: Chromecast, Device History, EasyTrigger, Ecobee, JowiHue, LutronCaseta, MeiUnifi, PHLocation2, Pushover 3P, SDJ-Health, Sonos, WeatherFlow, weatherXML
              Scripts: SparkMan's Lock Event, 5 of Jon00 scripts.

              Comment


                #8
                HOMESEER WE HAVE A PROBLEM. Same thing here, new unit. I just wasted and entire day on this! Fortunately my Zee S2 is up again. Order (#38389) now has a RMA. Contacting Sales in the morning.

                Comment


                  #9
                  Andy, since getting the installed Ubuntu 14:04 running. IT was bothering me that system was running an old OS and version of Mono. I blew away the factory install and did a clean install of Ubuntu 18.04 LTS with Mono 5.18 and applied the VBNC patch so ASPX pages work.

                  Oh, I also had to configure the system to start HS3 on boot.
                  HS3 SEL running Pro Edition 3.0.0.531 on Ubuntu 18.04, mono 5.20, 656 devices, 209 events.
                  Plug-Ins: Chromecast, Device History, EasyTrigger, Ecobee, JowiHue, LutronCaseta, MeiUnifi, PHLocation2, Pushover 3P, SDJ-Health, Sonos, WeatherFlow, weatherXML
                  Scripts: SparkMan's Lock Event, 5 of Jon00 scripts.

                  Comment


                    #10
                    Thanks for the reply! Brand new, cost $419. The lost time and putting my Smart Home back together with the slower Zee. Hopefully HomeSeer pulls the stock and checks them, suspect a bad software load? At first, I thought "I've got to be doing something wrong." The instructions talk about HS touch (page 3 "Once HS Touch has finished installing...") which I didn't understand either.

                    Comment


                      #11
                      Don't turn purple holding your breath As I understand it this was brought to their attention a while ago.

                      I was also very unhappy to find that the brand new SEL I got could not run current plugins without errors. This was especially maddening since I tested everything on a trial Raspberry Pi and it worked fine there. That was the basis for deciding to invest in an HS3 based system, I kind of felt cheated.




                      HS3 SEL running Pro Edition 3.0.0.531 on Ubuntu 18.04, mono 5.20, 656 devices, 209 events.
                      Plug-Ins: Chromecast, Device History, EasyTrigger, Ecobee, JowiHue, LutronCaseta, MeiUnifi, PHLocation2, Pushover 3P, SDJ-Health, Sonos, WeatherFlow, weatherXML
                      Scripts: SparkMan's Lock Event, 5 of Jon00 scripts.

                      Comment


                        #12
                        I'm working with Jon in Sales. They are trying to duplicate the problem? They have my config info and my $420 so I'll stay on top of it! I also suggested they read these posts in the SEL forum. Thanks for your help and info!

                        Comment


                          #13
                          Thanks to the help of zwolfpack I was able to fix the issue on the SEL master. I am working on a script version of the fix to issue to users experiencing this issue. Currently the script requires SSH, but I am working on getting it to work in Linux tools. I appreciate everyone's patience and thank you zwolfpack!
                          Jon Smith
                          website | products | support | youtube

                          Comment


                            #14
                            Success! After several hours of work got the SEL working via SSH:

                            1. sudo rm HSPI_Chromecast.exe

                            2. ALL my imported events from the ZEE backup were broken as described here under SEL forum:
                            I even tried exporting my events via the LABS tab but they were saved in a file C:/… that linux couldn’t access. forum topic - event triggers gone after mono upgrade

                            3. I recreated all my 70 events again and my home is running on the new SEL! My old Zee (backup only) is ready to be plugged back in as a backup to my Smart Home.

                            4. So far everything looks good and I have Imperihome running and Alexa. Here is my SEL as of a few minutes ago:

                            Current Date/Time: 1/29/2019 7:28:32 AM
                            HomeSeer Version: HS3 Standard Edition 3.0.0.495
                            Linux version: Linux HomeTrollerSELv2 3.16.0-031600-generic #201408031935 SMP Sun Aug 3 23:56:17 UTC 2014 i686 i686 i686 GNU/Linux System Uptime: 0 Days 18 Hours 57 Minutes 11 Seconds
                            IP Address: 127.0.0.1
                            Number of Devices: 207
                            Number of Events: 70
                            Available Threads: 199
                            HSTouch Enabled: False
                            Event Threads: 0
                            Event Trigger Eval Queue: 0
                            Event Trigger Priority Eval Queue: 0
                            Device Exec Queue: 0
                            HSTouch Event Queue: 0
                            Email Send Queue: 0

                            Enabled Plug-Ins
                            3.0.0.29: ImperiHome
                            3.0.1.252: Z-Wave

                            5. The last UNRESOLVED PROBLEM is if I have the SEL connected directly with a monitor and keyboard I can log into the SEL but the USB mouse doesn’t work. I suspect that is from the bad software load on the unit (Linux Mouse Driver?), not critical but would be nice to fix.

                            This was a brand new box so please pull any units from stock and fix so someone else won’t go through this!

                            As others have stated on the forum, you really get to learn Linux.

                            The good news is HS response is zippy compared to my old ZEE!

                            Comment


                              #15
                              Here is a script to fix the issue: https://homeseer.com/linux/sel/selmonocomplete.sh
                              Jon Smith
                              website | products | support | youtube

                              Comment

                              Working...
                              X