Announcement

Collapse
No announcement yet.

HS3 in Linux on a Hometroller SEL - locks up after remote logon

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    HS3 in Linux on a Hometroller SEL - locks up after remote logon

    Seems that I will get a black square maybe 1/2 in x 1/2 in. in the upper left quadrant of the screen, and local control of the HS3 is gone after I have logged on from another pc on the network to view and program the software. It stays locked up until I reboot the Chromium interface.

    Anyone else seen this and have a suggestion?

    #2
    I have never seen that with my two HS3 boxes running in Linux.

    I do not utilize Chrome here on any Wintel or Linux device. Rather it is Firefox.

    That said I also never utilize the web browsers on the two Linux boxes and do all management of the boxes remotely and all homeseer stuff via other computers remotely.

    Might be good to update the SEL via SSH. It will probably upgrade Chromium.

    1 - shut down Homeseer via the gui.
    2 - SSH to your SEL
    3 - sudo apt-get update
    4 - sudo at-get upgrade.
    5 - reboot

    Might take a while depending on how many files are being updated.

    Here I utilize Webmin to monitor and manage the two Homeseer boxes.

    Read about Webmin here.

    Just noticed too that I had a build of of old kernels that utilized a bunch of space.

    Here is a little script that will remove all of the old ones leaving only most current one in place.

    Code:
    #!/bin/bash
    
    kernel_list=$(dpkg -l | awk '{print $2}' | grep linux-image- | grep -v $(uname -r) | grep -v linux-image-generic)
    headers_list=$(dpkg -l | awk '{print $2}' | grep linux-headers- | grep -v $(uname -r | cut -d \- -f 1,2) | grep -v linux-headers-generic)
    
    apt-get purge -y $kernel_list $headers_list
    Attached Files
    Last edited by Pete; February 1, 2016, 07:51 PM.
    - Pete

    Auto mator
    Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb
    Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro
    HS4 Lite - Ubuntu 20.04 / VB W7e Jetway JBC420U591
    Fanless IntelĀ® Celeron N3160 SoC 8Gb
    HS4 Pro - V4.1.18.1 - Ubuntu 20.04/VB W7e 64 bit Intel Kaby Lake CPU - 32Gb
    HSTouch on Intel tabletop tablets

    X10, UPB, Zigbee, ZWave and Wifi MQTT automation-Tasmota-Espurna. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

    Comment


      #3
      Thank you for the guidance. I truly appreciate the help, thats why I am here. But I am so intensely frustrated


      Here's my problem...I am not a code writer and I am nearly illiterate when it comes to Linux. I got this box to replace an SE that died. Promised the client it would only take me an hour to install the backup file from the previous unit.

      Here I am 25 -30 hours ( unbillable) into setting this up and I have a unit that is still giving me grief and it seems the fixes involve coding and digging into the bowels of an OS I do not know or understand, probably because all my experience is windows based.

      Meanwhile, my client is blowing up my phone and I have no good answers for him.


      Apparently I am going on a new learning adventure since I will need to do some Linux tutorials or something to get to the point of even understanding what SSH is.

      Comment


        #4
        Yeah browsers these days are very resource intensive. It could be just that relating to Chrome.

        It is much faster to manage your HS3 box remotely via browser and letting the SEL do the automation stuff only.

        It does take some getting used running Homeseer 3 headless and on Linux.

        I would test the export of Windows to the import in to Linux using WinSCP or just copy the files over to a USB stick?

        Try it first. IE: do an export of the Homeseer configuration to a file then import that file over on the SEL box. (IE: HS3 to HS3).

        Relating to Homeseer 2 to Homeseer 3 there used to be a conversion program posted here for first generation of HS3. You can give that a try too if that is what you are doing.

        It might be faster to recreate all of the stuff from scratch using screenshots of the variables, plugins, events et al type of stuff.
        Attached Files
        Last edited by Pete; February 2, 2016, 10:03 AM.
        - Pete

        Auto mator
        Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb
        Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro
        HS4 Lite - Ubuntu 20.04 / VB W7e Jetway JBC420U591
        Fanless IntelĀ® Celeron N3160 SoC 8Gb
        HS4 Pro - V4.1.18.1 - Ubuntu 20.04/VB W7e 64 bit Intel Kaby Lake CPU - 32Gb
        HSTouch on Intel tabletop tablets

        X10, UPB, Zigbee, ZWave and Wifi MQTT automation-Tasmota-Espurna. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

        Comment


          #5
          Thank you again. Sorry for my rant earlier, but it frustrating sometimes

          I do have all the programming done and , for the most part, it is ready to go once the gmail sends, but doesn't receive issue is corrected. I know there is a beta to correct an issue with event actions resorting themselves and I may do the beta update. This issue was something I would see if there was a fix for, it is relatively minor , I think, as mostly it will be accessed headless or thru myhs

          Comment

          Working...
          X