Announcement

Collapse
No announcement yet.

WD200+ LED Color

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Timon
    replied
    As I said, I can handle replacing a simple dimmer by hand since you're mainly looking at a minimum number of events. In the case of moving from a WD100 to a WD200 you can have lots of events because you're taking advantage of the scene controller.

    So, although I'd love to see the ability to replace any node if we can easily replace WD100 with WD200 I'd be very pleased. And since I think it's likely that many people who buy WD200 will likely put some of them in place of WD100s due to the status ability. I think they would be very pleased as well.

    Leave a comment:


  • rjh
    replied
    It would be a lot of work to allow you to repace one dimmer with a totally different dimmer. This is due to the way child devices are created and maintained. Yes, the multilevel device is the same between the 2 dimmers but the underlying data is different. So figuring out what to change between the 2 would be a nightmare. Also, I think the number of users upgrading dimmers is very small.

    I will take a look as to why data is not being saved on a re-scan, that does not make sense.

    As for dimming the LEDS, that would require new hardware and even then, I am not sure we have enough I/O lines left. Maybe something we could look at for the 700 series Z-Wave chip.

    Originally posted by Timon View Post
    I found that if you use the audit function that the ID does change to 3036 which seem to be the one for the WD200 from the WD100's 3034 and you can then access the LEDs. However, it looks like it's not saved and thus goes away when you restart HS so you have to do the audit again. So, IMHO, I don't see and issue refreshing and saving it.

    Is there ANY way to force saving the information that was updated by the audit command? I've got 4 more WD100 that I want to update to WD200, total of 5, in the next few days and I really don't want to have to go in manually, EVERYTIME I restart, and do an audit on all 5 of my new WD200. I also don't want to go though all of them and exclude and include due to the time it takes to rebuild some 50 or more scenes.


    I know I've been vocal on this but excluding and including and breaking scenes, IMHO, is totally unacceptable when upgrading dimmers. One should always be able to update any simple, no features, dimmer that has no extra features to either a WD100 or WD200 or updating a WD100 to a WD200 without loosing anything. There should be a much simpler and user friendly way to do the upgrading. I can't see a non technical person trying to swap dimmers which is not good for sales of HS3.

    Downgrading as far as I'm concerned is not an issue that really needs to be addressed. If you need to do that then you've got many more problems to worry about and you're going to do a lot of manual changes since you're loosing the ability to control events.

    The ability to upgrade dimmers, IMHO, should be a priority and any feature upgrades to HS3 should be on hold till that's fixed.

    Might I make a suggestion? I've run beta programs and product software releases cycles. One thing we always did was to keep a copy of any release, or at least the last one, so if something came up it could be patched and released without having to wait till the current one in beta was released. That way small bugs could be patched quickly without waiting for the next release or in this case allowing the audit data to be saved. We would just and a decimal point number to the current release such as 435.1. Just something to think about.

    Can you PWM the LEDs? If so that would allow for color adjustments or dimming. Still I suspect that you're already running them in a matrix, to keep the pins count down, and in that case PWMing would be quite difficult.

    Leave a comment:


  • wpiman
    replied
    Originally posted by Deimos_Anomaly View Post
    Also I would like to see a way to adjust the brightness of the leds, I can only use red as the other colors will light up my room at night and make it hard to sleep.
    I have the LEDs blink when a door is open or some other bad thing is occuring. The light keeping me awake is what I want. Though- having the ability to dim would be nice.

    Leave a comment:


  • Timon
    replied
    I found that if you use the audit function that the ID does change to 3036 which seem to be the one for the WD200 from the WD100's 3034 and you can then access the LEDs. However, it looks like it's not saved and thus goes away when you restart HS so you have to do the audit again. So, IMHO, I don't see and issue refreshing and saving it.

    Is there ANY way to force saving the information that was updated by the audit command? I've got 4 more WD100 that I want to update to WD200, total of 5, in the next few days and I really don't want to have to go in manually, EVERYTIME I restart, and do an audit on all 5 of my new WD200. I also don't want to go though all of them and exclude and include due to the time it takes to rebuild some 50 or more scenes.

    Originally posted by rprade View Post
    If you used "Replace Node" on the HS-WS100+ Z-Wave tab, it will not work. The correct root for the 200 will not be built, despite the fact that the Central Scene VS pairs are updated. You will have to exclude/include it in order for the correct root to be built. This will break any events, so be sure and filter and print your event list for both the multilevel and central scene of the device so that you can edit them.
    See post #33 above.
    I know I've been vocal on this but excluding and including and breaking scenes, IMHO, is totally unacceptable when upgrading dimmers. One should always be able to update any simple, no features, dimmer that has no extra features to either a WD100 or WD200 or updating a WD100 to a WD200 without loosing anything. There should be a much simpler and user friendly way to do the upgrading. I can't see a non technical person trying to swap dimmers which is not good for sales of HS3.

    Downgrading as far as I'm concerned is not an issue that really needs to be addressed. If you need to do that then you've got many more problems to worry about and you're going to do a lot of manual changes since you're loosing the ability to control events.

    The ability to upgrade dimmers, IMHO, should be a priority and any feature upgrades to HS3 should be on hold till that's fixed.

    Might I make a suggestion? I've run beta programs and product software releases cycles. One thing we always did was to keep a copy of any release, or at least the last one, so if something came up it could be patched and released without having to wait till the current one in beta was released. That way small bugs could be patched quickly without waiting for the next release or in this case allowing the audit data to be saved. We would just and a decimal point number to the current release such as 435.1. Just something to think about.

    Originally posted by rjh View Post
    We will note the feedback and see. If the colors are not correct or consistent, we will look into that. Bust as for adjusting them, the Z-Wave chip does not have enough I/O ports to any further settings from the software.
    Can you PWM the LEDs? If so that would allow for color adjustments or dimming. Still I suspect that you're already running them in a matrix, to keep the pins count down, and in that case PWMing would be quite difficult.

    Leave a comment:


  • Deimos_Anomaly
    replied
    Also I would like to see a way to adjust the brightness of the leds, I can only use red as the other colors will light up my room at night and make it hard to sleep.

    Leave a comment:


  • rjh
    replied
    We will note the feedback and see. If the colors are not correct or consistent, we will look into that. Bust as for adjusting them, the Z-Wave chip does not have enough I/O ports to any further settings from the software.

    Originally posted by benginerd View Post
    Any chance that could change with a future firmware update?

    Leave a comment:


  • benginerd
    replied
    Originally posted by rjh View Post
    Unfortunately, no, the colors cannot be changed.
    Any chance that could change with a future firmware update?

    Leave a comment:


  • integlikewhoa
    replied
    Originally posted by NutsyHome View Post
    You need the WD (dimmer) version to get seven LEDs on the side. Which means you don't get the multi-LED feature unless you have an old fashioned incandescent bulb to control
    Even the old 100 series is that way. Only dimmers have a row of lights. And I use my dimmers with LED light bulbs not old fashioned incandescent bulbs.

    Leave a comment:


  • rjh
    replied
    Unfortunately, no, the colors cannot be changed.

    Originally posted by benginerd View Post
    Can we adjust the rgb value for the set colors? My amber is pretty green..

    Leave a comment:


  • benginerd
    replied
    LED rgb setting?

    Can we adjust the rgb value for the set colors? My amber is pretty green..

    Leave a comment:


  • rprade
    replied
    Originally posted by paweljakalak View Post
    Ok, that makes sense. Also is there a way I can change dimming increments as I use harmony hub brightness using a remote control but with this new switch the lowest diming level is not dim enough. With the wd100+ it would dim really low like 1% and with wd200+ it only dims to 20%.
    Thank you
    Unfortunately no. The HS-WD100+ were close to correct with 5.14 firmware, but with 5.17+ they were bad as well. The HS-WD200+ is the same as the later firmware on the 100s. I have 4 HS-WD100+ dimmers with 5.14 firmware in my basement theater and they will not go dim enough to enjoy movie night on the projection screen. I wish there was a parameter for minimum brightness that would allow us to pick the dimming floor - all the way to the point where the lights are off.
    Last edited by rprade; March 6th, 2018, 10:28 AM.

    Leave a comment:


  • paweljakalak
    replied
    Ok, that makes sense. Also is there a way I can change dimming increments as I use harmony hub brightness using a remote control but with this new switch the lowest diming level is not dim enough. With the wd100+ it would dim really low like 1% and with wd200+ it only dims to 20%.
    Thank you

    Leave a comment:


  • rprade
    replied
    Originally posted by paweljakalak View Post
    I just installed the wd200+ by replace node option in homeseer. But I do not see in zwave actions the led options.I replaced node where my old wd100 was.
    I am on the newest beta .199 zwave and using znet lan.
    If you used "Replace Node" on the HS-WS100+ Z-Wave tab, it will not work. The correct root for the 200 will not be built, despite the fact that the Central Scene VS pairs are updated. You will have to exclude/include it in order for the correct root to be built. This will break any events, so be sure and filter and print your event list for both the multilevel and central scene of the device so that you can edit them.

    See post #33 above.

    Leave a comment:


  • paweljakalak
    replied
    I just installed the wd200+ by replace node option in homeseer. But I do not see in zwave actions the led options.I replaced node where my old wd100 was.
    I am on the newest beta .199 zwave and using znet lan.

    Leave a comment:


  • scorp508
    replied
    Originally posted by rprade View Post
    Unless you need extremely low dimming levels, the dimmer will control CCFL or LED loads in addition to "old fashioned incandescent bulbs".


    I'm still bummed the WS200 is a single LED as I can't mix the WD with my switched outlets or smart bulbs.


    Sent from my iPhone using Tapatalk

    Leave a comment:

Working...
X