Announcement

Collapse
No announcement yet.

HS-WD200+ Association Group Commands Not Working

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • HS-WD200+ Association Group Commands Not Working

    Hello,

    I have a HS-WD200+ dimmer in the wall which is powered but has no load connected to it.

    Its main job is to control a Qubino 0-10V Flush Dimmer which is connected to the overhead lighting.

    The best and obvious way to achieve this is with association groups. I should be able to add the Qubino dimmer into association group 1 of the HomeSeer dimmer, and have the dimmer transmit commands directly to the Qubino with no need of a controller. This solution provides rapid control, and redundancy if the controller fails. Both devices are multilevel switches.

    However placing the Qubino into the HomeSeer dimmer's association group results in nothing. Turning the HomeSeer dimmer on and off results in no change to the Qubino.

    The REVERSE configuration works perfectly. If I place the HomeSeer dimmer into association group 4 of the Qubino (Qubino device supports multiple association groups), then remote commands issued to the Qubino via the HS3 GUI also control the HomeSeer dimmer. Eg turning on, setting dim level. The status of the HomeSeer device is not updated in HS3 instantly, but the LED indicators on the device change instantly. Configuring a polling interval for the homeseer dimmer updates its status and reveals that the dimming level is being controlled.


    The Qubino dimmer supports:

    Association
    Multi Channel Association
    Multilevel Switch Command Class version 3.


    The HomeSeer dimmer supports:

    Association
    Multilevel Switch Command Class version 4.


    What I think is going wrong:

    Option 1) Because the Homeseer dimmer uses a newer command class for multilevel switch, it is transmitting association commands that the Qubino does not understand, 4 > 3. When the reverse is true, the version 4 capable homeseer is able to understand the version 3 Qubino.

    Option 2) The HomeSeer device is not transmitting multilevel switch commands at all, but is instead sending commands related to the scene controller. When the Qubino receives these, not being a scene controller, it ignores them/cannot interpret them

    Option 3) The HomeSeer dimmer is not correctly encapsulating the association group commands. Thus when they arrive at the Qubino root node, not having a destination endpoint ID, they are not passed to the multilevel switch child device.

    Option 4) The Qubino is receiving association group commands unencapsulated for endpoint ID 0, but for some reason does not pass a multilevel switch command to the multilevel switch child device?


    I have tried alternative approaches of using "Linked Device" in the HomeSeer dimmer device settings, I have also tried configuring an event that turns on the Qubino when Scene Key One is pressed.

    Both of those solutions work, however they are unacceptably slow. In both cases there is a delay of about 4 seconds turning the lights on.
    It seems the switch is waiting while it turns on before sending a status update to the controller, which then triggers either the linked device or the event. Adjusting the ramp rates reduces this slightly but not enough.

    Using an event that triggers off of 'Scene Key One Pressed Twice' (in which case there is no need to process a local load on, and status is sent immediately) works and works acceptably fast, however having to double tap the paddle to turn on overhead lights is unacceptable for intuitive use of a light switch.


    Outcomes I'm looking for:

    Please confirm the root cause of the issue and provide,

    Best: A fix for the association group problem so it works as intended.

    Alternatively: A guide on how to unmarry single paddle taps from powering the local load, effectively turning the WD200 into a scene controller only. Is this possible through the expanded configuration parameters? If I could make the single tap events work as fast as the double tap event, I'd be happy.

    Also alternatively: Please release a hardware product that is the WD200 minus the switch. Ie a paddle scene controller with LED indicators, but no local load and immediate status response on single paddle taps.



    Current Date/Time: 3/06/2018 1:02:03 AM
    HomeSeer Version: HS3 Standard Edition 3.0.0.435
    Operating System: Microsoft Windows Server 2016 Datacenter - Server
    System Uptime: 0 Days 5 Hours 52 Minutes 20 Seconds
    IP Address: 192.168.10.211
    Number of Devices: 24
    Number of Events: 34
    Available Threads: 200
    HSTouch Enabled: True
    Event Threads: 0
    Event Trigger Eval Queue: 0
    Event Trigger Priority Eval Queue: 0
    Device Exec Queue: 0
    HSTouch Event Queue: 0
    Email Send Queue: 0
    Anti Virus Installed:

    Enabled Plug-Ins
    3.8.527.3: HSBuddy
    3.0.2.215: Z-Wave

  • #2
    Taking another look at the node information, I'm now reasonably convinced that Option 2 of my scenarios is what's taking place, the HomeSeer dimmer is not issuing Basic, Multilevel Switch commands to it's association group.

    Is someone from HST able to confirm?

    Click image for larger version

Name:	dimmers_HL.jpg
Views:	1
Size:	109.6 KB
ID:	1196988

    Comment

    Working...
    X