Announcement

Collapse
No announcement yet.

Status of LED's on the WD200 switches

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Status of LED's on the WD200 switches

    Is there a way in Homeseer 3 Pro to remotely read the status of the LED's on a WD200 switch?

  • #2
    Originally posted by mlacrosse View Post
    Is there a way in Homeseer 3 Pro to remotely read the status of the LED's on a WD200 switch?
    There is no way to do it with an event. You can set parameters with an Event, but you cannot read them. You can read the parameters on the Z-Wave tab of the root device. Down at the bottom of the page you will see

    Click image for larger version  Name:	capture.png Views:	1 Size:	15.4 KB ID:	1249546

    Choose the parameter number make sure the value is blank (not 0) and click "set".

    Here you can see that parameter 14 on mine is set to 0

    Click image for larger version  Name:	capture2.png Views:	1 Size:	11.7 KB ID:	1249548

    Using this chart you can see that means my normal mode (parameter 14) is set to White (0)

    Click image for larger version  Name:	capture1.png Views:	1 Size:	107.5 KB ID:	1249547

    It may be possible to read the parameter value with a scripting call, but I don't know the call.
    Randy Prade
    Aurora, CO
    Prades.net

    PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

    Comment


    • #3
      I was pretty sure that was the case but just wanted to double check. I have several events setting the LED's (garage door left open, sprinklers on, alarm panel status) and they all work great but I was looking to trigger other events based on lights, I know I can do it by creating virtual switches tied to the events so . . looks like that is the path I am headed down. Thank you for your quick response!

      Comment


      • #4
        I have mixed feeling about what I'm about to suggest and maybe in the end it should be configurable or left the way it is.

        I have had many times where I'd like to see what the LEDs are set to for the WD200, WS200 and now the FC200 from the devices page like can be done with the multi-sensor. The down side is that it would take another 1, 4 or 8 entries on each one which would tend to clutter up each device.

        Maybe there is a way to either be able to enable these or some kind of virtual device cluster that would allow any 200 series device to be associated with a switch so the LEDs could be displayed. This might be better as you could create them as needed. Might make for a nice plugin.
        John (N6BER), Joyce, Lucas (Golden Ret mix), Bella (Great Pyrenees) and Lance (GP).

        HomeSeer Version: HS3 Standard Edition 3.0.0.478
        Linux version: Linux auto 4.15.0-43-generic #46-Ubuntu SMP Thu Dec 6 14:45:28 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
        Number of Devices: 347
        Number of Events: 535
        Available Threads: 399
        HSTouch Enabled: True

        Enabled Plug-Ins
        3.0.0.13: AirplaySpeak
        2.0.59.0: BLBackup
        3.0.0.56: EasyTrigger
        1.3.6927.42284: LiftMaster MyQ
        3.4.18.2: mcsMQTT
        3.0.1.109: PHLocation
        0.0.0.45: Pushover 3P
        3.0.1.252: Z-Wave

        Comment

        Working...
        X