Announcement

Collapse
No announcement yet.

Firmware for HS-WD100+

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Firmware for HS-WD100+

    Does anyone have firmware for HS-WD100+ switch?

    I deiced to update my switch to the latest and didn't pay attention to the "D" and "S". Flashed my dimmers to the latest On/Off firmware and sort of broke them. Looking for original dimmer firmware for the HS-WD100+ switch which I don't see on their sight.

    Any help?

  • #2
    See the HomeSeer downloads page using the blue Downloads page above.
    -Rupp
    sigpic

    Comment


    • #3
      Originally posted by Rupp View Post
      See the HomeSeer downloads page using the blue Downloads page above.
      And then where is it? I only see the on/off switch firmware which is the sameone that got me in trouble in the first place.

      Comment


      • #4
        Originally posted by Rupp View Post
        See the HomeSeer downloads page using the blue Downloads page above.
        There is only firmware for the HSWS100+. The OP accidentally uploaded that firmware to HSWD100+ dimmers. He is looking for the 5.13 firmware for the dimmers.

        I'm surprised that there isn't a model check in the update procedure to prevent this from happening.
        Randy Prade
        Aurora, CO
        Prades.net

        PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

        Comment


        • #5
          Originally posted by rprade View Post
          There is only firmware for the HSWS100+. The OP accidentally uploaded that firmware to HSWD100+ dimmers. He is looking for the 5.13 firmware for the dimmers.

          I'm surprised that there isn't a model check in the update procedure to prevent this from happening.
          Yup my stupid mistake but I dont see the right firmware to correct it. Ill call HS tomorrow but was hoping for a quick fix today if someone has seen or done this before.

          Comment


          • #6
            Originally posted by integlikewhoa View Post
            And then where is it? I only see the on/off switch firmware which is the sameone that got me in trouble in the first place.
            Ah yes I was confused thinking you went the other way. Let me check to see if that firmware is available.
            -Rupp
            sigpic

            Comment


            • #7
              Rich said he was testing a new firmware for the HS-WD100+ switch and it should be ready in the next day or so. A link will be posted when it ready.
              -Rupp
              sigpic

              Comment


              • #8
                Originally posted by Rupp View Post
                Rich said he was testing a new firmware for the HS-WD100+ switch and it should be ready in the next day or so. A link will be posted when it ready.
                Hmmmm, well hopefully in the mean time they wiuld be kind enough to give me older firmware or let me test the new one so i can stop locking up the zwave network when someone presses these switches.

                Comment


                • #9
                  Let me ask.
                  -Rupp
                  sigpic

                  Comment


                  • #10
                    Originally posted by Rupp View Post
                    Let me ask.
                    I tried calling in but got left on hold 20 min. Then it sent me to voicemail. I did leave a voicemail.

                    I'm hoping maybe an email attachment, private link, private message or something along those lines of either older orginal firmware or the new beta to hold me over until they release and post a link of the new firmware.

                    I could live without the dimming right now but problem is when they use these switches it errors out in the log of trying to get device dimming % and during that time of it trying and before erroring out it locks up all zwave traffic. Well when my kid presses it multiple times trying to get the light to work it really locks up for several minutes.

                    I'm hoping a simple email attachment of a few hundred kilobytes can fix this in a matter of minutes rather then days if at all possible.

                    Thanks

                    Comment


                    • #11
                      I must confess I made the same mistake when the WS firmware came out. I have two switches for a room, one fan and one light right next to each other physically and in Device Manager and accidentally selected the dimmer. I asked Mark offline and he said new WD firmware was coming soon so I stood down to wait for that. Interesting that the status reporting of things like double clicks still works and local load control still works (on/off only) but it no longer responds to commands from the controller and LEDs no longer work.

                      Comment


                      • #12
                        Originally posted by jhearty View Post
                        I must confess I made the same mistake when the WS firmware came out. I have two switches for a room, one fan and one light right next to each other physically and in Device Manager and accidentally selected the dimmer. I asked Mark offline and he said new WD firmware was coming soon so I stood down to wait for that. Interesting that the status reporting of things like double clicks still works and local load control still works (on/off only) but it no longer responds to commands from the controller and LEDs no longer work.
                        Thanks for " Confessing" .

                        So are you still waiting to this day and how longs that been?

                        I'm hoping that what could be a 5 min. Fix really dont take me days or weeks as i feel this should be an easy no effort fix. I would be supirsed if they dont have even the orginal firmware at their fingertips already. And altho it could take time to update website and add links and such they should be able to provide you with it via email.

                        Comment


                        • #13
                          I did get ahold of HS tech support and they told me to RMA the switch and I eat shipping or wait until the new firmware is released which is currently scheduled for Thursday the 9th.

                          They said the old firmware will not go on with the now mixed or updated firmware thats I installed on the switch. (My guess is that it only converts the dragons firmware up to their custom HS firmware and they what to keep that firmware locked up for obious reasons) and the new firmware for updates isnt ready yet to beta or send me.

                          Comment


                          • #14
                            Originally posted by integlikewhoa View Post
                            I tried calling in but got left on hold 20 min. Then it sent me to voicemail. I did leave a voicemail.

                            I'm hoping maybe an email attachment, private link, private message or something along those lines of either older orginal firmware or the new beta to hold me over until they release and post a link of the new firmware.

                            I could live without the dimming right now but problem is when they use these switches it errors out in the log of trying to get device dimming % and during that time of it trying and before erroring out it locks up all zwave traffic. Well when my kid presses it multiple times trying to get the light to work it really locks up for several minutes.

                            I'm hoping a simple email attachment of a few hundred kilobytes can fix this in a matter of minutes rather then days if at all possible.

                            Thanks
                            I suggest taking the node off the network for now. We would like to not give out the older firmware when we are very close to having the new firmware finished. We are in the testing phase as of right now.
                            Jon Smith

                            website | products | support | youtube

                            Comment


                            • #15
                              If the current one won't go over the wrong firmware to fix it, I would be concerned that the switch is bricked enough that it won't take an update to the new one being released.

                              Maybe HS can confirm that it will update before making you wait a few days just to have to RMA it anyways and add to the delays to getting it fixed.

                              Comment

                              Working...
                              X