Announcement

Collapse
No announcement yet.

BASH bug and HomeTroller Zee

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    Originally posted by rjh View Post
    I will look into this, the update worked ok when I tested it. Can you tell me if you had a soft float or hard float version of the OS? That info would have been displayed on the Linux Tools page at the top. If you don't know, how long ago did you purchase the Zee?
    The first line after SSH login (pre-upgrade) was:
    Linux HomeTrollerZEE 3.6.11+ #538 PREEMPT Fri Aug 30 20:42:08 BST 2013 armv6l

    I've moved a few Zees around, so don't know exactly when I bought this one...

    Comment


      #17
      Originally posted by rjh View Post
      Ok, this problem is caused by /boot being read-only. We set this partition as read-only to protect the boot code. On some Zee's, the update is trying to install new boot code. To fix your system, ssh to the box and enter:
      Happy Joy

      That fixed the issue, my Zee is now running normally.

      PS: My LinuxTools status now displays...
      Linux version: Linux HomeTrollerZEE 3.12.28+ #709 PREEMPT Mon Sep 8 15:28:00 BST 2014 armv6l GNU/Linux Soft Float

      Comment


        #18
        How do I get the Beta's

        Originally posted by rjh View Post
        We are about ready to put out another update, but we have been putting out Betas right along. I would suggest that you try one of the Betas since if that does not work for you then the next release probably won't.

        We do testing, but we do not have the hundreds of different configurations that all of our users have so there is no way to test it in the way everyone users it.
        It us to come out in the posting a new beta was out there, I never seen one for Zee. Could you tell me how I go about finding them, then how do I go about installing it. That would be a great big help, I am sure.
        Thanks so much
        danielbo

        Comment


          #19
          I never seen one for Zee.
          @danielbo

          Yes you have and have also participated in the updating here:

          http://board.homeseer.com/showthread.php?t=167138

          This OP is related to updating the Zee with current bash bug update and it does touch on updating the OS.

          It would be better to keep this thread on the subject at hand here.

          Your questions relating to updating the Zee have been already answered in another thread and I would suggest that you post in that thread such as not to change the subject in this thread.
          - Pete

          Auto mator
          Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb
          Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro
          HS4 Lite - Ubuntu 20.04 / VB W7e Jetway JBC420U591
          Fanless IntelĀ® Celeron N3160 SoC 8Gb
          HS4 Pro - V4.1.18.1 - Ubuntu 20.04/VB W7e 64 bit Intel Kaby Lake CPU - 32Gb
          HSTouch on Intel tabletop tablets

          X10, UPB, Zigbee, ZWave and Wifi MQTT automation-Tasmota-Espurna. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

          Comment


            #20
            I see what you are talking about, I was taking those as just regular updates, not beta. It come through my zee as a new update, nothing says beta. I don't know what is going on, but I have lights going on and off and doing crazy things. I have done nothing, not added anything. I went in and checked the events and all is fine, but its crazy. It just really started to get worse last week. Lights not coming one when they should , and lights coming on that are not even in a event. Lights coming on dim, its just a mess. We have done nothing different around the house to cause interference, the only thing I have done was a reboot and that was after this all started. It just keeps getting worse. I am hoping I can get my TI hooked back up and maybe this all will stop. Its like the house is haunted. So yes I am up to date, but I thought I was up to date on program upgrades, not Betas. That needs changed on the program from new updates to new Betas, since you say I have been getting them. I remember with HS2pro, you had upgrades and you had betas upgrades, they was two different things. So sorry for the statement but I believe you can tell where the confusion came from. This is what I posted about a while back, the people that put a lot of time into homeseer talk to each other, and us who buys the system and relay on purchasing packages do not have a clue on what you are talking about. If you want me to do something I need it in a way that I understand. Such as the difference between upgrades and beta. I ask questions to learn and either do not get a answer, or give me a bunch of stuff I do not understand. When I go back and ask, "what do you mean by" that is the end of the post, no one take time to tell you. I did not buy the program to learn how to write software. I bought the software, and I pay for new programs. I can not tell you how many time I have asked about backing up Zee. I tried to tell what I was doing, and I am told it can be done that way. I then ask so what should I be doing, and nothing. I have be coping the program with Winscp. I said I download the program, and got the comment "what do you mean by downloaded", then I will say "Well ok I ftp everything that was on the zee" Seems to me if I ftp everything on the zee unit, that should be a good back up, but I am told you can not do that. That is it. I purchase a program to work, not something I have to work on, I purchase add ons, not something I have to rewrite. When I purchase something I expect it to work. When you buy a car, you expect it to run. Its been over 3 months that I lost the use of my TI, and who cares. I should have never have lost it. Thinking that I backed up the complete unit, I can restore it from my back up. Well that does not work. So this is why I can not go back to the version that worked.
            I am sure this is in the wrong message board, I get those answers. People on here love to point out how stupid you are. I can not say everyone one. I have had maybe two people who really worked with me. But really its not up to them, the program I purchased should had been working, and if a issue pops up, it should be addressed. I feel as if now I have thrown away money that I did not really have. I worked hard to get extra money to purchase the zee. Something I could plug in, load my stuff and go. It doesn't work that way with homeseer. I have a expensive program we use in our business, they do upgrades or updates, but that is for adding new features.
            danielbo

            Comment


              #21
              If you see an update available from the setup page, then its a release. If you update manually using SSH, then its most likely a Beta.

              Open a helpdesk ticket and we can get a tech to help you.

              Obviously, lights should not be going and off randomly, I have never seen that happen. Note the time that a light came on when it was not suppose to, then look at the HS log and see if it notes a reason why the light changed. That will help narrow it down.

              Originally posted by danielbo View Post
              I see what you are talking about, I was taking those as just regular updates, not beta. It come through my zee as a new update, nothing says beta. I don't know what is going on, but I have lights going on and off and doing crazy things. I have done nothing, not added anything. I went in and checked the events and all is fine, but its crazy. It just really started to get worse last week. Lights not coming one when they should , and lights coming on that are not even in a event. Lights coming on dim, its just a mess. We have done nothing different around the house to cause interference, the only thing I have done was a reboot and that was after this all started. It just keeps getting worse. I am hoping I can get my TI hooked back up and maybe this all will stop. Its like the house is haunted. So yes I am up to date, but I thought I was up to date on program upgrades, not Betas. That needs changed on the program from new updates to new Betas, since you say I have been getting them. I remember with HS2pro, you had upgrades and you had betas upgrades, they was two different things. So sorry for the statement but I believe you can tell where the confusion came from. This is what I posted about a while back, the people that put a lot of time into homeseer talk to each other, and us who buys the system and relay on purchasing packages do not have a clue on what you are talking about. If you want me to do something I need it in a way that I understand. Such as the difference between upgrades and beta. I ask questions to learn and either do not get a answer, or give me a bunch of stuff I do not understand. When I go back and ask, "what do you mean by" that is the end of the post, no one take time to tell you. I did not buy the program to learn how to write software. I bought the software, and I pay for new programs. I can not tell you how many time I have asked about backing up Zee. I tried to tell what I was doing, and I am told it can be done that way. I then ask so what should I be doing, and nothing. I have be coping the program with Winscp. I said I download the program, and got the comment "what do you mean by downloaded", then I will say "Well ok I ftp everything that was on the zee" Seems to me if I ftp everything on the zee unit, that should be a good back up, but I am told you can not do that. That is it. I purchase a program to work, not something I have to work on, I purchase add ons, not something I have to rewrite. When I purchase something I expect it to work. When you buy a car, you expect it to run. Its been over 3 months that I lost the use of my TI, and who cares. I should have never have lost it. Thinking that I backed up the complete unit, I can restore it from my back up. Well that does not work. So this is why I can not go back to the version that worked.
              I am sure this is in the wrong message board, I get those answers. People on here love to point out how stupid you are. I can not say everyone one. I have had maybe two people who really worked with me. But really its not up to them, the program I purchased should had been working, and if a issue pops up, it should be addressed. I feel as if now I have thrown away money that I did not really have. I worked hard to get extra money to purchase the zee. Something I could plug in, load my stuff and go. It doesn't work that way with homeseer. I have a expensive program we use in our business, they do upgrades or updates, but that is for adding new features.
              website | buy now | support | youtube

              Comment


                #22
                Yup; understanding your frustration Danielbo.

                I did though review your stuff as you requested of me and I volunteered to do (some time a while ago); then explained mechanisms of action relating to why and what was happening on your Zee a bit ago.

                Note too that I do not work for Homeseer and just really been here on the forum a long time.

                I did notice stuff though that was out of my control and most likely the reasons for the issues you were having which I explained to you a while ago along with methodologies of backup, upgrading, changing events, so forth and so on.

                I am now though feeling a bit amiss thinking that your acknowledgements of what we wrote about in our dialog relating to your Zee were not understood?

                Did I skip anything or miss anything?
                - Pete

                Auto mator
                Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb
                Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro
                HS4 Lite - Ubuntu 20.04 / VB W7e Jetway JBC420U591
                Fanless IntelĀ® Celeron N3160 SoC 8Gb
                HS4 Pro - V4.1.18.1 - Ubuntu 20.04/VB W7e 64 bit Intel Kaby Lake CPU - 32Gb
                HSTouch on Intel tabletop tablets

                X10, UPB, Zigbee, ZWave and Wifi MQTT automation-Tasmota-Espurna. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

                Comment


                  #23
                  Originally posted by rjh View Post
                  If it does not display anything, you are probably on an older HS3 build, as HS3 is displaying that message. Which build are you on?
                  HomeSeer Version: HS3 Zee Edition 3.0.0.55 (Linux)

                  Thanks Rich!

                  --Dan
                  Tasker, to a person who does Homeautomation...is like walking up to a Crack Treatment facility with a truck full of 3lb bags of crack. Then for each person that walks in and out smack them in the face with an open bag.

                  Comment


                    #24
                    I am currently o 3.0.0.106. Its just strange that this is all going on and not have done any changes. I believe the Zee is going down. It hurts financially that I purchased this about 6 months ago and now have to replace it. I do not that happening. I should have stayed with the HS3 pro upgrade. But I thought this would be energy saving and doing all I need it to do which was just turning on and off.
                    You mentioned about contacting the help desk. The last time I did, I was notified of the fee and it best that I work with the message board first. When I purchased the Zee, there was a issue and my 30 day free help, was used up just to get my system to work with X10 and was not even fixed by the homeseer help desk, it was take care of by a great guy on the message board.
                    I believe maybe reset the zee and see if this helps, but I do not believe it would because, nothing was changed to make it start acting up. The only issue I had was that I couldn't use TI, but now its getting worse with many other issues. I have done nothing to cause it on my part to cause any issues, but I have them. I can not afford another Zee. I have health issues that what money I do have needs to go to. Go back to the old way of flipping switch's. I bet I have been with X10 for over 20 years, so I have a huge collection of HS stuff. I don't know how long I had been with homeseer, but long before joining the message board. I guess if Zee doesn't starts making changes to the good, I will have to go back to HS2 pro until I can get back on my feet to upgrade to HS3. But can not afford a new Zee that will only last a few months, if I make a new investment into homeseer I see it to be HS3 pro. I have tons of plugins that I have purchased for HS2 pro. I really thought this was a great deal and perfect for me, but I can not afford to replace it. I just wish I could see a update, or beta, whatever you want to call it, and get my TI back on line and be in hopes it helps. As I had mentioned before, I started this as a hobby, not to learn programming. I was leaving that to the programmers. At first Homeseer was that way, it was a fun hobby to get plugins and do different things, but now you have to be a programmer and that I am not. I don't have the time for a project. I thought I paid others to do that. Sorry to sound so hateful, but this has been a disappointment to me, then seeing Homeseer adding another unit, and not having the zee working without issues yet. I know the time was taken away from the Zee in order to get the new system up and running, which is unfair to us. I know a lot of the homeseer family have money to do all this new stuff, like changing the system over from X10. But fur us that don't of this money to purchase all your changes, please do forget us and keep the basic service working. So forgive me for sounding hateful, I really am not. I have a business where I help people find a place to call home. We do not make a fortune doing this, but it dose give it to your heart knowing you have helped someone. We get a little grant money, but know where enough. As we are talking the light just clicked on in the room that I am in, that should not come on until 12:30 tonight. I checked and the AM and PM is correct. Who knows why it clicked on. As I was getting to, just want what I paid for.
                    danielbo

                    Comment

                    Working...
                    X