Announcement

Collapse
No announcement yet.

HSM100 - Firmware Update Service

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • HSM100 - Firmware Update Service

    Hi
    I noticed "HSM100 - Firmware Update Service (HomeSeer) Item #HSM100-FIRM" item in homeseer.com shop.
    I bought HSM100 in mid 2008.
    what do we gain with this firmware Update?
    Please advice if I need it. my controller is Vera 2.
    Thanks
    Sam

  • #2
    What version of the firmware is on the HSM100 and are you experiencing any issues currently?

    Comment


    • #3
      i haven't noticed any issues.
      i cannot find the firmware version on the back of the device.
      i noticed following info from vera config page

      Capabilities 81,140,0,4,33,1|49,96:2,112,114,119,128,132:2,133,134,
      Version 6,2,40,1,10
      Manufacturer Express Controls
      Model EZmotion 3-in-1


      how do i find the firmware version?

      Comment


      • #4
        If it were included within HomeSeer you could use the Z-Who page to find this information.
        -Rupp
        sigpic

        Comment


        • #5
          A Z-Wave device reports its version as Lib: x.xx App y.yy - the numbers arriving as bytes. I did not put too much effort into trying to figure out what Vera is trying to do, but it appears they are converting each byte into a decimal value instead of to something useful.

          You will have to ask them to decipher their output - the Version information should contain what you need - the "App" value is the device's firmware version.
          Regards,

          Rick Tinker (a.k.a. "Tink")

          Comment


          • #6
            Yes more info please

            I own like 6 or 8 of these HSM-100's. several are flaky, and just dont act right. What does this firmware upgrade accomplish, and if it fixes bugs and flakiness shouldn't this be a free update? I have stopped purchasing the HSM-100 because I have found them to be unsuitable for me, but would like to salvage what I already own.

            Comment


            • #7
              What version of HomeSeer are you running? What version of the firmware are the HSM100's that you are having issues with? What problems are you having when you say flakey?

              Comment


              • #8
                So... Does anyone know what the fw does.

                I also have several hsm100, sometimes they work and sometimes not. I have never gotten all of them to work at the same time, and now recently I had to change batteries in one of them that have worked fine for a long time... And now it does not update motion anymore.

                If the fw fixes these issues it should of course be free, but since that does not seem to happen, at least someone from HS could tell us what the fw does....

                Thanks,
                Dolfren

                Comment


                • #9
                  I have two HSM100 units, one reports firmware of 1.4 the other of 1.5

                  Hint: you can get the firmware version (I believe) by querying the device then looking in the log for "version: Lib: 2.31 App: 1.5" the App: is your version number.

                  My firmware version 1.4 seems to work fine for everything but motion. It is very flaky when it comes to reporting the motion back to Homeseer. Sometimes it appears to work, others it doesn't. One thing I noticed is that when I put the device into LED ON and Always-On mode. The sensor does pick-up the motion, it just doesn't notify Homeseer.

                  It is a pretty big disappointment that I may have to pay an additional $25 to get an $85 device to work as it was intended to.

                  Too bad these devices can't flash over the air. I guess I have a $85 luminosity and temp sensor now.

                  Is this what others are seeing from the older HSM100 devices?

                  Comment


                  • #10
                    I usually stick up for HS here-- but charging $25 to update the firmware is a complete boning of the customer who already bought in.

                    I could see them charging $25 to update ALL your HSM100 devices-- but if you have 10 of them- it is just wrong.



                    Originally posted by ChuckP View Post
                    I have two HSM100 units, one reports firmware of 1.4 the other of 1.5

                    Hint: you can get the firmware version (I believe) by querying the device then looking in the log for "version: Lib: 2.31 App: 1.5" the App: is your version number.

                    My firmware version 1.4 seems to work fine for everything but motion. It is very flaky when it comes to reporting the motion back to Homeseer. Sometimes it appears to work, others it doesn't. One thing I noticed is that when I put the device into LED ON and Always-On mode. The sensor does pick-up the motion, it just doesn't notify Homeseer.

                    It is a pretty big disappointment that I may have to pay an additional $25 to get an $85 device to work as it was intended to.

                    Too bad these devices can't flash over the air. I guess I have a $85 luminosity and temp sensor now.

                    Is this what others are seeing from the older HSM100 devices?
                    HS3 Pro Edition 3.0.0.435 (Windows Server 8.1 on ESXi box)

                    Plug-Ins Enabled:
                    Z-Wave:,RaspberryIO:,AirplaySpeak:,Ecobee:,
                    weatherXML:,JowiHue:,APCUPSD:,PHLocation:,Chromecast:,EasyTr igger:

                    Comment


                    • #11
                      HSM100 firwmare upgrade

                      Does anybody has the file and procedure how to upgrade the hsm100? I have 6 of them and I lost a lot of time with flacky hsm100, I got so much frustrations that I developed my own software to control them. that could be finally the solution after 3plus years of questions... Thank you

                      Comment


                      • #12
                        If I were to guess I would say it isn't possible to update them over the air. Likely they are reprogramming the device by connecting to a programming interface on the device. This would be why they require a service and we don't see a download link as well.

                        Did you find out what firmware version you are running? I would be interested to know the version of others with the same issue, and what device you are using the communicate with the HSM100.

                        I am using a Ztroller running the latest firmware. Anyone out there having issues with the ZStick and a sub-1.5 version HSM100?

                        Comment


                        • #13
                          I too have a couple of HSM-100's which have been flakey or simply do not function. It does seem to matter how you configure them, how you install them, and whether the velcro's adhesive actually holds the unit 6+ ft off the floor.

                          Once they smack the floor, all bets are off due to the high weight of the battery smashing the thing pretty hard onto the floor once the velcro cuts loose unexpectedly.

                          I have one HSM-100 that works for about 5 minutes of a fresh set of batteries, then dies. I think it was probably the one that had the velcro problem....

                          Yes, $25 to update the firmware on the two units which are paperweights right now, or installed but useless motion sensor looking devices, seems a bit high to me. I'd say that since quite a few of us are more than amateur hobbyists with some electrical/electronic slant and we'd likely be able to cobble up the necessary hardware / software to flash the upgrades ourselves. Maybe for those around, we could get a copy of the instructions and software (perhaps with some agreement we will not sell our sevices to others)...

                          That said, for $50, I'd have 2 functioning HSM-100's, which is a deal if I hadn't already suck a good amount previously on useless paperweights.
                          huggy_d1

                          Automating made easy

                          Comment


                          • #14
                            Flaky HSM100

                            I have several units and they are not very reliable. The biggest issue that I have not been able to get any support on is that when I have an HSM100 use a route back it stops reporting. If I activate it,it reports via the route.

                            I had intended to use them as a temperature control but with the flakiness I have not deployed them.

                            Does anyone know if the firmware upgrade solves the routing problem?

                            Comment


                            • #15
                              Originally posted by wpiman View Post
                              I usually stick up for HS here-- but charging $25 to update the firmware is a complete boning of the customer who already bought in.

                              I could see them charging $25 to update ALL your HSM100 devices-- but if you have 10 of them- it is just wrong.
                              If you have multiple units to upgrade, contact us directly and we'll work out a special arrangement for you.
                              website | products | support | youtube

                              Comment

                              Working...
                              X