Announcement

Collapse
No announcement yet.

HSM's - taking too long to send command ...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • HSM's - taking too long to send command ...

    Lately I've been getting these messages logged in the HS log -

    5/6/2013 10:09:13 AM Warning Aborting Z-Wave send, taking too long to send command to node 23 waited 6 seconds
    5/6/2013 10:09:20 AM Warning Aborting Z-Wave send, taking too long to send command to node 23 waited 6 seconds
    5/6/2013 10:09:26 AM Warning Aborting Z-Wave send, taking too long to send command to node 23 waited 6 seconds

    Same for a few other HSM's, but not all.

    What I get on all of them is -
    5/6/2013 10:11:15 AM Z-Wave Z-Wave WakeUp 'No More Info' Notification sent to Node 33

    I am running 2.50.79 (.80 does same thing).

    Have done multiple Full Optimizations, everything works while the device is awake, but when it goes to sleep these messages start to appear.

    How do I fix?

    These HSM are in line of sight of the Z-Troller - about 10 feet.

  • #2
    Here's a new one I just found... More HSM craziness.

    5/6/2013 6:47:28 PM Warning In converting Z-Wave data bytes to a value, Size is reported as 2, but length is 1 and is=03

    After that message

    5/6/2013 6:47:28 PM Device Update Device: HSM100-1 - Temperature (26) value set to 0 (0/F)
    5/6/2013 6:47:28 PM Z-Wave Z-Wave WakeUp 'No More Info' Notification sent to Node 26
    5/6/2013 6:47:28 PM Device Update Device: HSM100-1 - Temperature (26) value set to 77.9 (7790/F)

    Comment


    • #3
      Another new one...

      5/6/2013 8:51:08 PM Device Update Device: HSM100-6 - Luminance (33) value set to 1 (100/%)
      5/6/2013 8:51:08 PM Error NodeChange event called for node 1, and no Parent/Child devices could be found for class COMMAND_CLASS_BATTERY
      5/6/2013 8:51:08 PM Device Update Device: HSM100-6 - Battery (33) Battery Level 97%
      5/6/2013 8:51:09 PM Z-Wave Z-Wave WakeUp 'No More Info' Notification sent to Node 33

      Comment


      • #4
        Originally posted by Eddiie View Post
        Another new one...

        5/6/2013 8:51:08 PM Device Update Device: HSM100-6 - Luminance (33) value set to 1 (100/%)
        5/6/2013 8:51:08 PM Error NodeChange event called for node 1, and no Parent/Child devices could be found for class COMMAND_CLASS_BATTERY
        5/6/2013 8:51:08 PM Device Update Device: HSM100-6 - Battery (33) Battery Level 97%
        5/6/2013 8:51:09 PM Z-Wave Z-Wave WakeUp 'No More Info' Notification sent to Node 33
        A rescan might fix this. If not, a delete and re-add might be in order...
        HS3Pro Running on a Raspberry Pi3
        64 Z-Wave Nodes, 168 Events, 280 Devices
        UPB modules via OMNI plugin/panel
        Plugins: Z-Wave, BLRF, OMNI, HSTouch, weatherXML, EasyTrigger
        HSTouch Clients: 3 Android, 1 Joggler

        Comment


        • #5
          Rescan didn't fix.

          I guess I'll try removing and re-add one. Since these are battery powered devices they will not impact the routing of other devices.

          Comment


          • #6
            What is the firmware level on the HSM100 sensors you are getting these messages? Are all your Sensors the same firmware level?

            Comment


            • #7
              I have removed and readded 2 sensors I think this has helped.
              It seems waiting for these nodes to reply jams up the network and will cause other devices to not receive their commands, causing a cascade effect, then they get logged too.

              By removing one of the HSM100's and re-adding it cleared up some of the other failing devices that were reporting problems at the same time.

              More clean up tonight.

              Just noticed this from the Aeon Multi-Sensor, low battery...
              5/7/2013 5:41:53 PM Device Update Device: 1st Floor Patio Patio Sensor - Luminance (41) value set to 291 (29100/Lux)
              5/7/2013 5:41:53 PM Device Update Device: 1st Floor Patio Patio Sensor - Humidity (41) value set to 51 (5100/%)
              5/7/2013 5:41:54 PM Z-Wave Z-Wave WakeUp 'No More Info' Notification sent to Node 41
              5/7/2013 5:41:54 PM Z-Wave Z-Wave WakeUp 'No More Info' Notification sent to Node 41
              5/7/2013 5:41:56 PM Z-Wave Z-Wave WakeUp 'No More Info' Notification sent to Node 41
              5/7/2013 5:41:56 PM Z-Wave Z-Wave WakeUp 'No More Info' Notification sent to Node 41
              5/7/2013 5:41:56 PM Z-Wave Z-Wave WakeUp 'No More Info' Notification sent to Node 41
              5/7/2013 5:41:57 PM Z-Wave Z-Wave WakeUp 'No More Info' Notification sent to Node 41
              5/7/2013 5:41:57 PM Z-Wave Z-Wave WakeUp 'No More Info' Notification sent to Node 41
              5/7/2013 5:41:57 PM Z-Wave Z-Wave WakeUp 'No More Info' Notification sent to Node 41
              5/7/2013 5:41:58 PM Z-Wave Z-Wave WakeUp 'No More Info' Notification sent to Node 41
              5/7/2013 5:41:58 PM Z-Wave Z-Wave WakeUp 'No More Info' Notification sent to Node 41
              5/7/2013 5:41:58 PM Z-Wave Z-Wave WakeUp 'No More Info' Notification sent to Node 41
              5/7/2013 5:41:59 PM Z-Wave Z-Wave WakeUp 'No More Info' Notification sent to Node 41
              5/7/2013 5:41:59 PM Z-Wave Z-Wave WakeUp 'No More Info' Notification sent to Node 41
              5/7/2013 5:41:59 PM Z-Wave Z-Wave WakeUp 'No More Info' Notification sent to Node 41
              5/7/2013 5:42:00 PM Z-Wave Z-Wave WakeUp 'No More Info' Notification sent to Node 41
              5/7/2013 5:42:00 PM Z-Wave Z-Wave WakeUp 'No More Info' Notification sent to Node 41
              5/7/2013 5:42:00 PM Z-Wave Z-Wave WakeUp 'No More Info' Notification sent to Node 41
              5/7/2013 5:42:01 PM Z-Wave Z-Wave WakeUp 'No More Info' Notification sent to Node 41
              5/7/2013 5:42:01 PM Z-Wave Z-Wave WakeUp 'No More Info' Notification sent to Node 41
              5/7/2013 5:42:01 PM Z-Wave Z-Wave WakeUp 'No More Info' Notification sent to Node 41
              5/7/2013 5:42:02 PM Z-Wave Z-Wave WakeUp 'No More Info' Notification sent to Node 41
              5/7/2013 5:42:02 PM Z-Wave Z-Wave WakeUp 'No More Info' Notification sent to Node 41
              5/7/2013 5:42:02 PM Z-Wave Z-Wave WakeUp 'No More Info' Notification sent to Node 41
              5/7/2013 5:42:03 PM Z-Wave Z-Wave WakeUp 'No More Info' Notification sent to Node 41
              5/7/2013 5:42:03 PM Z-Wave Z-Wave WakeUp 'No More Info' Notification sent to Node 41
              5/7/2013 5:42:03 PM Z-Wave Z-Wave WakeUp 'No More Info' Notification sent to Node 41
              5/7/2013 5:42:03 PM Z-Wave Z-Wave WakeUp 'No More Info' Notification sent to Node 41
              5/7/2013 5:42:04 PM Z-Wave Z-Wave WakeUp 'No More Info' Notification sent to Node 41
              5/7/2013 5:42:04 PM Z-Wave Z-Wave WakeUp 'No More Info' Notification sent to Node 41
              5/7/2013 5:42:05 PM Z-Wave Z-Wave WakeUp 'No More Info' Notification sent to Node 41
              5/7/2013 5:42:05 PM Z-Wave Z-Wave WakeUp 'No More Info' Notification sent to Node 41
              5/7/2013 5:42:05 PM Z-Wave Z-Wave WakeUp 'No More Info' Notification sent to Node 41
              5/7/2013 5:42:05 PM Z-Wave Z-Wave WakeUp 'No More Info' Notification sent to Node 41
              5/7/2013 5:42:06 PM Z-Wave Z-Wave WakeUp 'No More Info' Notification sent to Node 41
              5/7/2013 5:42:06 PM Z-Wave Z-Wave WakeUp 'No More Info' Notification sent to Node 41
              5/7/2013 5:42:06 PM Z-Wave Z-Wave WakeUp 'No More Info' Notification sent to Node 41


              Firmware -

              HSM100-1 2.40 (ZDK Version 4.27) App: 1.10
              HSM100-2 2.40 (ZDK Version 4.27) App: 1.10
              HSM100-3 2.40 (ZDK Version 4.27) App: 1.13
              HSM100-4 2.40 (ZDK Version 4.27) App: 1.13
              HSM100-5 2.40 (ZDK Version 4.27) App: 1.13
              HSM100-6 2.40 (ZDK Version 4.27) App: 1.10

              Aeon Multi Sensor - 3.28 (ZDK Version 5.03) App: 1.18

              Ztroller - 1.17 (is there an update coming soon?)


              Next devices to delete and re-add, Node 23 (HSM100-4), Node 60 (wall switch), Node 89 (Aeon Intelligent Power switch), now that the other clutter is gone from the first two devices these are appearing now.

              Comment


              • #8
                Removing these devices and re-adding them resolved all the taking too long messages.

                I still get -
                Z-Wave WakeUp 'No More Info' Notification sent to Node xx


                I've gone back to .80 - I think there's a bug in the send/replicate z-wave data (not really sure what triggers it) that forces a rediscover of all devices on the network, it screws things up.

                The HS code must have changed with HSM's between releases at some point.

                Closing this one for now.

                Comment

                Working...
                X