Announcement

Collapse
No announcement yet.

Problems setting up HSM100 in HS3 Pro

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problems setting up HSM100 in HS3 Pro

    Hello,

    I just upgraded my system to HS3 and am setting up all my devices again. All have gone well except for my HSM100. I wake it up and and press add on my Z-Troller, I press the blue button on the HSM100 and a node is assigned to the HSM100. Then I go into homeseer and import new devices. It finds the HSM100 and then I get the next row of errors in my log...

    May-26 9:18:40 PM Z-Wave Z-Troller: Node 14 CONTROLS class: COMMAND_CLASS_MULTI_CHANNEL_V2
    May-26 9:18:40 PM Z-Wave Z-Troller: Node 14 CONTROLS class: COMMAND_CLASS_BASIC
    May-26 9:18:40 PM Z-Wave Z-Troller: Node 14 supports class: COMMAND_CLASS_MARK
    May-26 9:18:40 PM Z-Wave Z-Troller: Node 14 supports class: COMMAND_CLASS_VERSION_V2
    May-26 9:18:40 PM Z-Wave Z-Troller: Node 14 supports class: COMMAND_CLASS_MANUFACTURER_SPECIFIC_V2
    May-26 9:18:40 PM Z-Wave Z-Troller: Node 14 supports class: COMMAND_CLASS_BATTERY
    May-26 9:18:40 PM Z-Wave Z-Troller: Node 14 supports class: COMMAND_CLASS_WAKE_UP
    May-26 9:18:40 PM Z-Wave Z-Troller: Node 14 supports class: COMMAND_CLASS_CONFIGURATION
    May-26 9:18:40 PM Z-Wave Z-Troller: Node 14 supports class: COMMAND_CLASS_ASSOCIATION_COMMAND_CONFIGURATION
    May-26 9:18:40 PM Z-Wave Z-Troller: Node 14 supports class: COMMAND_CLASS_ASSOCIATION_V2
    May-26 9:18:40 PM Z-Wave Z-Troller: Node 14 supports class: COMMAND_CLASS_SENSOR_MULTILEVEL_V2
    May-26 9:18:40 PM Z-Wave Z-Troller: Node 14 supports class: COMMAND_CLASS_SENSOR_BINARY_V2
    May-26 9:18:40 PM Z-Wave Z-Troller: Node 14 is reporting 11 command classes in the node information.
    May-26 9:18:40 PM Z-Wave Z-Troller: Contacting node 14 to get supported features
    May-26 9:18:40 PM Z-Wave Z-Troller: Device Z-Wave Node 14 Z-Wave Interface Sigma On/Off Sensor Node 14 (14) is missing Z-Wave Command Class information, Wake-Up Notification is attempting to retrieve it.
    May-26 9:17:19 PM Z-Wave Warning Failed to retrieve Z-Wave class information for node 14, device synchronization/creation will not continue for this node.
    I am not super advanced in my HS skills and am hoping I am just missing something basic.

    Thanks for taking the time to look at this.

  • #2
    Hi Rob,

    What version of the z-wave plugin are you running? You may want to try with the latest (beta) version which is .156 as there have been a number of fixes to it. Backing up your HS folder prior to updating is recommended.

    Cheers
    Al
    HS 3.0.0.548: 1976 Devices 1156 Events
    Z-Wave 3.0.1.262: 123 Nodes on one Z-Net

    Comment


    • #3
      Thanks I gave it a try and updated. Removed the device, rebooted and then readded. I think I got further but still not working. I get this in my logs when I try to import devices from the z-troller.

      Code:
      Synchronize nodes finished. Number of device nodes to be created/added = 1
      Device synchronization does not need to create any new devices.
      Device synchronization needs to create 1 device.
      Node: 14 Supports Class(es): SENSOR_BINARY_V2, SENSOR_MULTILEVEL_V2,  ASSOCIATION_V2, ASSOCIATION_COMMAND_CONFIGURATION, CONFIGURATION,  WAKE_UP, BATTERY, MANUFACTURER_SPECIFIC_V2, VERSION_V2
      Node: 14 Controls Class(es): MARK, BASIC, MULTI_CHANNEL_V2
      Error: Node 14 did not provide Wake-Up Command Class information - it will not be processed further.
      Warning: The device at node 14 should result in 3  child devices being created, but the node interrogation currently has 0.   This may still result in a successful child creation.
      Finished with Z-Wave device synchronization.

      Comment


      • #4
        Maybe try adding it from within HS, rather than from the z-troller using the "Add/Include a Node" command. If you add it from the z-troller, it needs to be awake when you import it. If it's not, it'll fail.

        Cheers
        Al
        HS 3.0.0.548: 1976 Devices 1156 Events
        Z-Wave 3.0.1.262: 123 Nodes on one Z-Net

        Comment


        • #5
          I have a love/hate relationship with my HSM100. Like Al said, you have to wake it and rescan/import the device. Mine is mounted and powered and it's a real circus to hit the button and run back to click the button.
          HS3Pro Running on a Raspberry Pi3
          64 Z-Wave Nodes, 168 Events, 280 Devices
          UPB modules via OMNI plugin/panel
          Plugins: Z-Wave, BLRF, OMNI, HSTouch, weatherXML, EasyTrigger
          HSTouch Clients: 3 Android, 1 Joggler

          Comment

          Working...
          X