No announcement yet.

Adventures with Google Play Store on the WFTT07-2 Control Pad 2

  • Filter
  • Time
  • Show
Clear All
new posts

    Adventures with Google Play Store on the WFTT07-2 Control Pad 2

    I've just been through four nights and about 60 some-odd web pages trying to figure out how to make the Google Play Store work properly on my two Control Pad 2 units. Hopefully, this will make it easier for folks to get this working. Of course, proceed at your own risk, and YMMV.

    First, after trying to root the unit unsucessfully using different methods, I thought to check if it had been shipped rooted - YES! Life just got easier.

    Then, I tried side-loading Google Play Store and Google Play Services, using an SD card and File Manager. This resulted in being able to access the Store once, and then afterwards only getting recurring "Unfortunately, Google Play Store has stopped" errors.

    After more nights of research, I finally found what seemed to be the key: set Google Play Store as a system app. When sideloaded, it is a user app. To accomplish that, one more app, Link2SD, was needed.

    Here are the apk files I used:

    [APK][04-DEC-2014] Google Play Store v5.1.11 ~ Newest version, unmodded.
    This is the Google Play Store app.

    Google Play Services 6.5.99 (1642632-034) APK for Android.
    Google Play Services is used to update Google apps and apps from Google Play.

    Link2SD 3.6.2 APK for Android.
    This utility is used to convert a user app (Google Play Store, in this instance) to a system app.

    I think it's probably best to start by setting up your Google account on the Control Pad 2. After doing that, I was getting sync errors, reminiscent of my Google TV days. Onward!

    Download the above 3 apks to an SD card. You might be able to use the Control Pad 2 browser to download them directly - I didn't try this, as I was working from my main PC.

    Install each, using File Manager.

    Then, to prevent the recurring "Unfortunately, Google Play Store has stopped" error:
    Start Link2SD, scroll down to "Google Play Store", and select it. Touch the "Action" button, and choose "Convert into system app".

    Unmount the SD card (if you used it) by going to Settings/Storage/Unmount SD Card. Remove the card, then reboot the Control Pad 2.

    After the system restarts, downloads might start to automatically happen (depending on if you've already set up your Google account under Settings/Accounts/Google), followed by an error. Start Google Play Store, and you should get a box for accepting Google's terms and conditions. After you do this, system downloads should automatically continue.

    I had already sideloaded some updates, but after this, I saw "AutoStart-No root" and "Google Text-to-Speech" automatically update.

    You can uninstall Link2SD after this, as it shouldn't be needed for this anymore.

    Hope this helps - Happy New Year!

    Thank you !

    I've just purchased the HS Touchscreen... and disapointed by the fact that no Google play store was available (while this is clearly explained in the Homeseer YouTube video that you can easily use the tab as an Android tab !). I've followed your instructions and evething ran well.

    Thank you very much.

    Hoping that Homeseer will fix this problem and take into account users expectations...


      I can't seem to login to google on these touchscreens at all.....can't contact server?

      But no issues from my PC....any ideas?
      HS3 Pro Edition (Windows 10 vmware)
      BLOccupied:,UltraNetCam3:,weatherXML:,RFXCOM:,Current Cost 3P:,UltraGCIR3:


        Have you been able to go successfully through steps 1 & 2 of the quickstart guide? If not, under Settings/Wi-Fi, is everthing correct there and showing connectivity?

        What happens if you try to use the browser to connect to another web site?

        Under Settings/Accounts/+ Add account, what happened when you tried to sign into your Google account?


          Works perfectly!! Thank you VERY much for this! I had tried so many different versions of play services and play store trying to hit on a combo that worked. Would have never of thought of making it a system app.
          Software/Hardware: Win10 Pro, HS 3 Pro, HS Touch, Echo, Edgeport/4, Z-Net w/88 Devices, Insteon PLM w/19 Devices, Nest, GC-100-6, W800RF32A, WS-2080 Weather Station (KMADRACU10)
          Plug-in/Scripts: Alexa API, BLBackup, BLGData, BLLED, BLLock, BLRF, BLTVGuide, Blue Iris, BLUPS, Current Cost 3P, DirectTV, FitbitSeer, Insteon, Nest, Pushover 3P, Random, Restart, Tasker, UltraGCIR3, UltraWeatherWU, Z-Wave


            That worked great. Thanks for the tip.


              Work perfect!


                File Manager

                I am new to android devices. Where is and how do you use the File Manager on the WFTT07-2?


                  Originally posted by bilesb View Post
                  I am new to android devices. Where is and how do you use the File Manager on the WFTT07-2?
                  Astro file manager is pretty good.

                  Sent from my SCH-R970X using Tapatalk
                  HS4Pro Running on a Raspberry Pi4
                  72 Z-Wave Nodes, 111 Events, 422 Devices
                  Z-Wave, UPB, WiFi
                  Plugins: EasyTrigger, weatherXML, OMNI, Z-Wave, Tuya, Device History
                  HSTouch Clients: 3 Android, 1 Joggler


                    File Manager

                    Thanks for the quick reply. I guess I was a little misleading. I am trying to side-load Google Play Store on to the WFTT07-2. Using my computer I downloaded Google Play Store to a SD card and then plugged the SD card into the WFTT07-2. The next step is using the File Manager on the WFTT07-2 to install Google Play Store. I can't find how to start the File Manager. Checking from Settings then Apps I can see that there is a File Manager there but I haven't found how to start it. Like I said I am a novice with Androids.


                      Thanks, this worked perfectly!
                      HSPro, Z-NET with Z-wave plugin, RFXCOM + 2x RFXtrx433E, HSTouch, Squeezebox plugin, iTach IP/WF2IR & GC-100-6 with UltraGCIR, BLDenon, NetcamStudio, Jon00s Webpage builder, Harmony Hub plugin, SCSIP (with FreePBX), Arduino plugin, IFTTT, Pushalot plugin, Device History plugin.
                      Running on Windows 10 (64) virtualized
                      on ESXi (Fujitsu Primergy TX150 S8).
                      WinSeer (for Win10) - TextSeer - FitbitSeer - HSPI_MoskusSample

                      Are you Norwegian (or Scandinavian) and getting started with HomeSeer? Read the "HomeSeer School"!



                        Your hard work and research has been a great help. I was having exactly the same problems and your fix took care of them. I would not have had a clue how to deal with this without your post. Thanks a bunch!