Announcement

Collapse
No announcement yet.

Z-Troller and ethernet connection problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Z-Troller and ethernet connection problem

    I have a new Z-Troller and connected it to my HomeSeer using the ethernet to serial adapter from the HomeSeer store. I am observing a problem with it when I try to use it after a period of inactivity.

    If I don't do anything in HomeSeer for a while (on the order of minutes) and then I try to do anything to a ZWave device there is about a 30 second lag. After about 15 seconds I get the following entry in the HomeSeer event log:


    10/4/2009 10:08:34 PM - Z-Wave - Z-Wave Ethernet interface re-connected to IP 192.168.1.170


    Another 10 seconds later, and the ZWave switch finally executes most of the time.

    After this initial lag, the ZWave devices are very responsive, on the order of sub-second. But if I leave for a while and then come back to excercise more ZWave devices, the first one gives me the lag again.

    Sometimes, the first switch I try to access also fails with an entry like the following in the HomeSeer event log:

    10/4/2009 10:08:54 PM - Warning - Unable to send a command to Z-Wave device 7
    10/4/2009 10:08:54 PM - Warning - No reply to get node level request for device Hallway Hall Overhead


    But then everything including the failed ZWave device will work after this initial lag & failure.

    Is this an ethernet to serial adapter problem? Does the USB to serial adapter do the same thing? I really like the ease of use of the ethernet based Z-Troller combo.
    Last edited by PetersenSeer; October 5th, 2009, 02:56 AM.

  • #2
    Ethernet Z-Troller lag causes race condition

    I wanted to see if this 30 second lag when communicating with Z-Troller over ethernet might cause some of the WARNINGs I have been seeing in the HomeSeer event log, so I set up a simple experiment and verified that this is the case and there is a definite pattern.

    If I leave HomeSeer alone for over 5 minutes, then when I do my next Z-Wave command with HomeSeer, I get a "Z-Wave Ethernet interface re-connected ..." message in the log. This message comes conspicuously just BEFORE a Warning that whatever ZWave command I just issued failed in some way. For example the following entries come when requesting an optimization after leaving HomeSeer alone for 5 minutes:


    10/5/2009 12:19:33 AM - Z-Wave - Instructing node # 6,Downstairs Hallway Butler Overhead, to re-discover its neighbors...

    10/5/2009 12:19:53 AM - Warning - Unable to optimize node 6, Downstairs Hallway Butler Overhead, it did not respond.

    10/5/2009 12:19:53 AM - Z-Wave - Z-Wave Ethernet interface re-connected to IP 192.168.1.170
    10/5/2009 12:20:14 AM - Z-Wave - Instructing node # 7,Downstairs Hallway Hall Overhead, to re-discover its neighbors...
    10/5/2009 12:20:15 AM - Z-Wave - Device 7, Downstairs Hallway Hall Overhead successfully optimized.


    I believe the warning above was a result of a timeout, but the culprit was not the ZWave node 6, but rather that the ethernet Z-Troller had not finished reconnecting yet. The remaining ZWave device optimization commands succeeded.

    Here is another simple race condition where I left HomeSeer alone for 11 minutes, then just turned ON a rope light:


    10/5/2009 12:22:52 AM - Database Item - Saving Device Downstairs Scullery Overhead Light
    10/5/2009 12:33:49 AM - Info - Device: Downstairs Family Room Rope (Q11) ON
    10/5/2009 12:34:09 AM - Z-Wave - Z-Wave Ethernet interface re-connected to IP 192.168.1.170

    10/5/2009 12:34:29 AM - Warning - Failed sending Z-Wave command to device(s): Downstairs Family Room Rope (Q11)


    You can see at 12:22 was my last ZWave command. At 12:33 I issued a LIGHT ON command. At 12:34:09 I get the Z-Wave Ethernet re-connected message. Finally, at 12:34:29 I get the Warning - Failed sending Z-Wave command. (Note HomeSeer actually shows the light ON now, but the Z-Wave command did in fact fail and the light did not turn on. Hitting refresh, and now the HomeSeer shows the light status as UNKNOWN).

    In this final example, I wait 5 minutes, issue a ZWave command and get the ethernet re-connect race condition induced failure of that ZWave command. I then repeat the command a few times, and the remainder all succeed since the Ethernet is not needing to re-connect first.


    10/5/2009 12:35:11 AM - Database Item - Saving Device Downstairs Scullery Overhead Light
    10/5/2009 12:40:44 AM - Info - Device: Downstairs Family Room Rope (Q11) ON
    10/5/2009 12:41:04 AM - Z-Wave - Z-Wave Ethernet interface re-connected to IP 192.168.1.170

    10/5/2009 12:41:24 AM - Warning - Failed sending Z-Wave command to device(s): Downstairs Family Room Rope (Q11)

    10/5/2009 12:41:33 AM - Info - Device: Downstairs Family Room Rope (Q11) ON
    10/5/2009 12:42:33 AM - Info - Device: Downstairs Family Room Rope (Q11) OFF
    10/5/2009 12:42:53 AM - Info - Device: Downstairs Family Room Rope (Q11) ON


    Is this behavior indicative of using the Z-Troller on an ethernet adapter, or is there something wrong with my setup causing the Z-Troller to go through a reconnect after 5 minutes?

    As a work around, I think I will set up some random switch to be polled every 240 seconds. I will see if that keeps the ethernet Z-Troller connection alive for me so that I don't get these re-connect messages in my log. I will run it for a day this way and post my results.

    Comment


    • #3
      Inactivity timeout & Cyclic Connection Interval

      I have three Z-trollers. Two use the ethernet and LS100 Serial interfaces the Primary is directly connected to PRO100 II. In the past I have noticed the same problem you are describing. Somewhere on this forum it was mentioned that this had been documented and Rich (rjh) had fixed it. I can't find it and I may be dreaming. What I did with my two remotes was to set "cyclic connection interval = 0 (disable) and Inactivity Timeout = 0 (unlimited) . I have not noticed any time outs since. I use to have just one z-troller but finally came to the realization that this zwave network is slow and if I wanted a faster network I would have to add remote controllers.

      Comment


      • #4
        Thanks! That did it! cyclic connection interval was already 0. But setting Inactivity Timeout to 0 (unlimited) worked perfectly.

        BTW: Having one of my ZWave devices polling interval set to less than 300 seconds also worked, but no need to do that anymore.

        Comment

        Working...
        X