No announcement yet.

My new IP2SL is connecting to z-troller at 9600 baud, not 115,200 baud

  • Filter
  • Time
  • Show
Clear All
new posts

    A few things:
    1. I hooked up the first z-troller to a direct serial connection. According to Windows device manager, the z-troller is connected to the direct serial port at 9600 baud.
    2. When I hooked the second z-troller (i.e. the z-troller that succeeded at 115,200 baud) up to the IP2SL, I used exactly the same cables and power supply that I had used with the first z-troller (i.e. the z-troller that fails at 115,200 baud, but which can connect and function at 9600 baud).
    3. I'm having no luck flashing the first z-troller using the direct serial connection. The v1.17 installer software can't read the z-troller's version number, and it reports it isn't able to flash the z-troller either. I'm puzzled as to what the issue could be. For comparison, I tried hooking up the second z-troller to the very same cable as the first controller, and the v1.17 installer software could read its version number just fine.
    4. Lastly, I tried connecting the first z-troller to the direct serial port using the second z-troller's new cable (fresh out of the box). No joy that time either in using the v1.17 installer software. It can't read the z-troller's version number, and it can't flash it either.

    Hence, I could not reflash the firmware on the problematic z-troller. Also, it does not appear to be a cabling issue.

    What else can I do or try? Is there any sort of hidden reset button on the z-troller itself that I can press?



      Can you do a full erase on the 9600 Baud Z-troller?

      If you try that, be sure to back up your network before you do it if it has any vital info on it.

      I had a "stuck" Z-troller when I was trying to add multiple ones and the only way I could get it to work was do to a complete erase, then reflash the firmware.

      Barring that trick, I would say the Z-troller may be defective if it cant accept a firmware reflash.

      I am unaware of any hard reset button. I have never opened up the box to look however.

      If all else fails, put in a ticket to the help desk.


        Per your suggestion I just did the full erase, but it had no effect on the issue at hand. It still connects at 9600 baud, and the flash software can't flash it.


          I was afraid of that.

          I'm wondering if the firmware upgrade program requires a 115,200 Baud rate connection.

          HomeSeer folks need to chime in here.

          There has to be a way to reset the rate back to its native 115k, but I'm unaware of the procedure other than the holding button down trick that Rupp mentioned, which you say is not working.


            Did you try just removing the batteries ?



              The batteries are only rarely in it. The z-troller doesn't need them to remember the nodes in the network.

              I don't put the batteries in the z-troller unless I'm using the z-troller to add and/or delete z-wave devices. Afterward, I take the batteries out. That way, when it's AC powered, I don't have the batteries in.

              I don't honestly know whether this is the proper way or not, but I've seen postings on this forum which say that's how to do it and which warn against running the z-troller on AC power when the batteries are in. Putting them in and taking them out is definitely a hassle. If there's actually no reason to take them out, I'd rather leave them in.


                They say to remove them, for the obvious battery related leaking issues I'd surmise. I find that's a pain.
                Nonetheless, the point was that removing them would be the best Reset you're going to get.
                Have you swapped the cable as noted earlier, and I'd still try the ADD/DELETE pushed at the same time just for grins..