Announcement

Collapse
No announcement yet.

NEW Kwikset Lever Lock --- Cannot Add - Solved!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    NEW Kwikset Lever Lock --- Cannot Add - Solved!

    I am running Homeseer 2.5.0.81; Z-Troller is 1.17.

    I bring the lock within a foot of the Z-Troller (which is connected to computer); I use the ADD NODE function... all that happens is the following:

    9/1/2013 7:30:37 PM Z-Wave **********
    9/1/2013 7:30:37 PM Z-Wave ********** Adding Z-Wave Device with Node ID of 42 Type GENERIC_TYPE_ENTRY_CONTROL=40H **********
    9/1/2013 7:30:37 PM Z-Wave **********
    9/1/2013 7:30:37 PM Z-Wave Contacting node 42 to get supported features
    9/1/2013 7:30:38 PM Z-Wave Negotiating SECURITY SCHEME for (42)


    ...15 minutes later I still cannot perform any management of the Z-Wave interface because an error message stating a command is still in progress! ...I have to restart Homeseer, then disconnect the Z-Troller and take out the batteries to get around this...and I still cannot add the lock. I have gone through multiple ADD/DELETE cycles just using the Z-Troller buttons, but I've only managed to waste Z-Wave nodes as a result. I would think the Security Scheme negotiation is hanging based on this behaviour... as I see no Timeout message at all. Any thoughts on this? (The Kwikset lock is brand new...maybe they made some firmware changes?)

    #2
    ...Homeseer Warning Message;

    9/1/2013 7:54:00 PM Z-Wave Warning SyncNodes Trap 1: HomeSeer thinks it is still synchronizing nodes after 15 minutes - the command queue processing will now be resumed.

    this shows up in the log eventually;

    Comment


      #3
      Do you have a lot of other Z-Wave devices? Do you have any devices being polled? If so disable the polling while adding the lock as this is a slow process and will have issues if the Z-Troller is attempting to do other communications.
      -Rupp
      sigpic

      Comment


        #4
        12 Hours laster and HS is still trying to sync with the lock?

        Yes, I do have a number of devices...not sure how to disable polling though?

        12 Hours later (without any intervention from me), I still see this message when atempting to perform any Z-Wave management:

        Another Z-Wave Controller Function is already in progress - please wait for that to finish or cancel that action before requesting another one.

        Clicking the CANCEL button is ineffectual ... on the surface this looks like an HS coding issue, if the Lock is not responding as expected (which is beyond my control), shouldn't the HS code be able to handle that and abort the Add Node request and carry on?

        Comment


          #5
          RESOLVED ...Quickset Lock Issue

          This is what I did...

          I used the Remove Node Function to get rid of all of the failed Nodes.
          I then backed up the Ztroller configuration.
          I then ERASED the Ztroller; restarted it, and reloaded my backed up configuration.
          After doing all of this I was able to used the Add Node function without issue.

          Comment

          Working...
          X