Announcement

Collapse
No announcement yet.

Can't Connect Restored Z-Wave.me UZB Controller to Any Devices

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Can't Connect Restored Z-Wave.me UZB Controller to Any Devices

    Hi,

    I have purchased a Z-NET for Australia, which comes with a Z-Wave.me UZB adapter for the Australia Z-Wave frequency. To get the system up and running I have connected the UZB directly into a COM port and intend to then tackle configuring the Z-NET later.

    I have about 50 devices. Originally I had a Aeon Labs Z-Stick, but encountered some issues and so thought I'd give the Z-NET a go. I had taken backups of the config, but had not realised that there was a backup of the Controller. In a past post zwolfpack suggested that I import a latest *Zwave file from the ZWave folder. That seemed to work at the time, and I thought I was on the right track. However, things have turned to custard!

    I started having issues with a rogue Node, which I think was blocking adding any further Devices (I can see this from looking at the *.ZWave file that this node was in the wrong format compared to all other nodes). Anyway, I thought I could just re-import an uncorrupted *.ZWave file with an associated config file and this would all be good. However, no matter what I do I can't seem to get the controller to talk to any devices. For example, delete HS3 from the PC and reinstall a clean version, import the config file, restore the *.ZWave file (with the same Controller name (E24C57B4) as in the devices). Shouldn't this work?

    The following is a screenshot Testing Connectivity, which shows that none of the Devices is responding. The sensor details are reporting back to HS3, but I can't get any commands from HS3 to turn on lights, switches, etc.

    Click image for larger version

Name:	006.PNG
Views:	502
Size:	107.4 KB
ID:	1279335

    Similar to post from others, I don't really want to do a full rebuild of my system, and am hoping I can import details from relevant files into HS3 as I assume this is how a backup should work.

    Any suggestions or has anyone had this issue? Does this sound like a problem with the UZB? If so how can I tell?

    #2
    Please try this.

    Stop the z-wave plugin
    Unplug the UZB from the computer
    Insert the UZB into the computer
    Restart z-wave plugin




    Comment


      #3
      Re-reading from your other thread and adding this in, I'm wondering about your UZB.

      1) You had to unplug/plug it to get it to work initially. It really shouldn't need that
      2) It initially joined as a secondary controller and you had to erase it to clear that
      3) It won't stay connected when used with the Z-Net
      4) Doesn't seem to be talking once restored

      Are we sure this UZB is set to the correct frequency? Have you tried including a node? Hopefully you have a spare z-wave device of some type that you can test with.

      When using the UZB in the COM port, do any log messages appear that indicate it's having intermittent comm issues? If so, I'd conclude that the UZB is a lemon.

      Comment


        #4
        Hi Brentim. Another AUS follower, so you will be aware of our limited products. I had another post (noted byzwolfpack above), that related to problems with communication of the UZB. I have tried your suggestion multiple times as I'm getting the annoying yellow exclamation mark all the time and this is the ongly way to get it initialized and the green tick. Changing COM port has little effect.

        Comment


          #5
          Hi zwolfpack. I'm starting to think along your lines as well! Comments 1) to 3) require me to click/unclick the initialize section of HS3 controller manager to get the green tick, unplug the UZB, etc. F5 has become my goto button for this. Eventually it finally works, but this can't be normal?

          Comment 4) is the weird one. Yesterday I did an install from config and *.ZWave restore and happy days the controller was talking to the devices. However, now I can't replicate this. I added a few devices and then I was unable to add any more to the UZB and the system couldn't find one of the nodes (74). Looking at the *.ZWave file this appears to be corrupted so was planning to just update this in the *.ZWave file and restore. I never actually got that far as I wanted to make sure I could restore any *Zwave controller before Node 74 was added.

          Click image for larger version

Name:	006a.PNG
Views:	364
Size:	30.7 KB
ID:	1279506

          It's as if controller can't reference the devices. Data is being communicated from sensors back to HS3 but can't get connection to the Devices the other was. When importing the *.ZWave file the UZB sometimes has trouble erasing itself. In terms of the log file have a look at the following.

          This error message is a concern on startup!

          Click image for larger version

Name:	007.PNG
Views:	409
Size:	98.2 KB
ID:	1279504

          This one is to be expected as I know I can't get any communication when I try and control a device (in this case turning on the Bath 1 light).

          Click image for larger version

Name:	008.PNG
Views:	372
Size:	479.8 KB
ID:	1279505

          Even worse are these ones, if I disable the UZB and it has trouble reconnecting. They don't make any sense to me.

          Click image for larger version

Name:	007a.PNG
Views:	377
Size:	113.3 KB
ID:	1279507


          Do I have a bricked UZB? Is this common? I'm now going to install HS3 on another machine to make sure it isn't something relating to my PC and Windows 10 Pro and the way COM ports are configured.

          Any help is appreciated. I have 50 devices and want to avoid a rebuild. I'm worried that if I do a rebuild I'll may get back to the same position I'm in now, which is a dead system!

          Comment


            #6
            To disable/enable the controller, I find it easier to disable/enable the Z-Wave plugin on the Plugins->Manage page. I've found that the Z-Wave Controller page doesn't consistently refresh while enabling the controller from there.

            If you are getting frequent errors of the sort shown in your 2nd image "UZB interface did not respond ...." I'd suspect a bad UZB. Those are symptoms of basic communication issues which shouldn't be happening unless there was something wrong with the UZB, or the USB port its plugged into.

            Comment


              #7
              Hi zwolfpack. Thanks for your tips about disabling/enabling the Z-Wave plugin, which I will use.

              I think I have exhausted every possible option at all hours to get the UZB back on line. It's pretty frustrating trying to resolve a binary problem. Ie the whole system either works or it doesn't work. The only thing I know have is lack of sleep!

              I tried installing a completely clean version of HS3 on a separate PC to test the comms issues, but had the same problems. As you pointed out it is either the UZB or the COM port appeared to be the issue. I received the following error and has been impossible to get the UZB to communicate in the other PC. Although they are both Lenovo's and different types of machines the chance of 2 PCs with COMs failures is remote (given all other USBs in the PCs work and the history of my issue with the Z-NET in my other post). I also get the error message from Windows about the device problem, although in the Device Manager, the COM4 port is being recognised.

              Click image for larger version

Name:	009.PNG
Views:	350
Size:	18.3 KB
ID:	1279537
              Click image for larger version

Name:	010.PNG
Views:	345
Size:	35.1 KB
ID:	1279538

              I think it is now time for RIP of this current UZB and I will be back to HomeSeer for a replacement.

              Comment


                #8
                Hi zWolfPack,

                Here's an update on progress. I ordered a replacement UZB, which arrived earlier this week and bingo, the problems were solved!

                Well not immediately solved. I had a lot of trial and error with various backups (restore and ZWave), until I got 80% of the system running.

                In addition the trick of Optimizing and restoring a number of times seemed to flush out dead nodes and make adding the remaining devices easier.

                Thanks for all your help.

                Cheers

                Comment


                  #9
                  Good deal! Seems you lucked out with the version of your UZB. Apparently the EU versions now come with a newer version 5.25 that doesn't support restore

                  https://forums.homeseer.com/forum/ho...restore-backup

                  Comment


                    #10
                    It's maybe a few months to late but for others: maybe this thread can help
                    https://forums.homeseer.com/forum/li...b-restore-back

                    Comment

                    Working...
                    X