No announcement yet.

Upgrade to Z-Net. Unable to restore backup.

  • Filter
  • Time
  • Show
Clear All
new posts

    Upgrade to Z-Net. Unable to restore backup.

    Running HS3 (Also tried using on Windows 10.
    Z-Wave Plugin:
    Z-Net firmware: 1.0.23

    Today I'm using Aeotec Z-stick. Just got a (new) Homeseer Z-Net (EU).

    Using this guide:

    Step 1:
    OK! Running Z-wave version

    Step 2:
    Backup: OK!
    Delete interface and physically remove Z-stick: OK!

    Step 3:
    Setting up Z-Net: OK! Running DHCP with DHCP-reservation in my DHCP-server. Firmware 1.0.23.

    Step 4:
    Adding Z-Net to Homeseer using «Ethernet interface» and port 2001. OK!

    Step 5:
    Restore backup from Z-stick seems OK according to the log. Home ID is correct:

    Click image for larger version

Name:	02-restore-ok.jpg
Views:	1981
Size:	89.3 KB
ID:	1279259Click image for larger version

Name:	03-log.jpg
Views:	1545
Size:	103.7 KB
ID:	1279260

    Trying to «Test Node Connectivity on a Network» fail. Device list is empty:

    Click image for larger version

Name:	04-error.jpg
Views:	1580
Size:	21.2 KB
ID:	1279261

    See detailed information about the Z-Net interface on screenshot:

    Click image for larger version

Name:	06-nodeinfo.jpg
Views:	1518
Size:	30.0 KB
ID:	1279262Click image for larger version

Name:	05-info.jpg
Views:	1564
Size:	44.4 KB
ID:	1279263

    The Z-Net seems to have only 1 node (the controller itself) even though the restore seems to be OK according to the log.
    Here’s the strange thing: At this point, I am able to control devices close to the controller, but the nodelist is empty! And I'm unable to test connectivity on the network.

    Please help, as I don't want to set up 50+ devices from scratch.

    there is a new z-net version in beta. But try Scan existing devices (light) first to see if you can get things back.


      Result from light (and full) scan:

      Click image for larger version

Name:	07-lightscan.jpg
Views:	1553
Size:	47.3 KB
ID:	1279350Click image for larger version

Name:	08-fullscan.jpg
Views:	1536
Size:	26.0 KB
ID:	1279351

      I also tried to add the Z-Net as "HomeSeer Z-NET Ethernet" instead of "Ethernet Interface". No luck.

      Where can I find the Z-Net beta firmware, and is there a changelog?

      PS: I don't know if it's necessary to remove the home ID-name from the screenshots, but I've seen others do it.


        Other than loading the new beta that fixes some issues with 52/53, I am out of league on this. Now would be a good time to backup things before you go to much further.


          I've got several backups already. I'm back at Z-Stick for now...

          I'm unable to find the beta-firmware for the Z-Net.


            Sorry, I meant to say z-wave and not z-net.
            HomeSeer Z-Wave
            Release Info
            Plug-in BETA


              There is no beta Z-Net firmware. There is a beta Z-Wave plugin but that won't help in this case.

              Can you post the section of the log where the connection is made to the Z-Net? I'm particularly interested in the controller manufacturer and firmware version lines.

              It will look something like this

              Z-Wave    UZB: Z-Wave Ethernet at IP, connected to interface ok.
              Z-Wave    UZB: The Z-Wave API Execution Thread was Started or Restarted.
              Z-Wave    UZB: Getting node information from controller...
              Z-Wave    UZB: [COLOR=#FF0000]Controller Manufacturer: PowerLynx, ID=0x1, Type=0x4[/COLOR]
              Z-Wave    UZB: [COLOR=#FF0000]Controller firmware version: 5.5[/COLOR]
              Z-Wave    UZB: Z-Wave services for the SECURITY COMMAND CLASS were successfully started.
              Z-Wave    UZB: Z-Wave Serial API version: 5
              Z-Wave    UZB: Z-Wave interface node ID: 1, Home ID: F2954E94
              Z-Wave    UZB: Found 1 Z-Wave nodes in interface node ID 1 (UZB)
              Z-Wave    The interface's security support has been set.
              Z-Wave    UZB Controller chip type is ZW050x.
              Z-Wave    UZB Controller is static lib.
              Z-Wave    UZB There is a SUC/SIS in the network.
              Z-Wave    UZB is the SIS for the network.
              Reference post:

              A couple of us have been working with HS support with a similar problem when restoring to a RaZberry controller. The restore transcript looks identical to what you posted, with "Restoring Data ..." lines. Once complete, the HomeID is set but the node list is empty. However, when successfully restoring to other controller types (including a UZB), the transcript will show "Restoring node information for node ..."

              So I'm wondering if your firmware version is different from that I posted above. That UZB was able to be restored to successfully.

              BTW, HomeID's aren't PIA


                Firmware version of controller is 5.25:

                Click image for larger version

Name:	09-znet-fw.JPG
Views:	1537
Size:	139.1 KB
ID:	1279640

                For testing purposes, I downgraded the Z-wave plugin to version and tried new restore:

                Click image for larger version

Name:	11-plugin_210.JPG
Views:	1558
Size:	92.6 KB
ID:	1279641
                This time it says "Restoring node information for node XXX...", but it still ends up with just 1 node after restore. However, an error occurred.


                  5.25 is a newer firmware version than I've seen reported on UZB's before. Mostly been seeing 5.5, which I know works.

                  For my RaZberry controller (from the same manufacturer as the UZB), it started responding like yours does when I upgraded to version 5.27 (with the prior version 5.4, restore option wasn't even in the menu). HomeSeer has indicated that they can make it work, but doesn't seem a high priority. However since yours is a product provided by them the priority should be much higher.

                  I'd suggest contacting HS support and report these findings.


                    I have a spare UZB. This has firmware 5.25 as well! I was unable to restore to that too when connected directly to my computer, so I start to believe that the firmware is the issue.

                    I will contact support.


                      FYI. Reply from support:

                      I apologize for the inconvenience you've had in backing up your Z-Wave network. At the moment, it is not possible to back up a Z-Wave network to a Z-Net with a UZB Z-Wave interface. We are discussing the issue with the manufacturers, but do not have a time frame for when this will be resolved. It is possible to send the Z-Wave network from the Aeon Labs interface to the Z-Net though! This will require two installations of HS3, and a second one can be obtained easily via the free trial.
                      That's too bad.


                        Message from support when I reported the issues with the restore option on 6th of may:

                        However, we have moved to a new bug logging format which makes it easier to keep track of how many users reach out to us about this. Since we moved to this new format, you are the first person to report this. I recommend asking others who are experiencing this to report the issue so that we may get an accurate count.
                        So anyone who would like to see the restore option restored, please report to support.


                          I just wrote to Homeseer, and waiting for a response.
                          see also:
                          exactly the same problem AND ALL THE HARDWARE DIRECTLY BOUGHT FROM HOMESEER!
                          Hope for service from Homeseer!
                          I'm on Win 10 and HS3 Pro

                          Dear sir, madam,

                          I hope you are healthy and ok with the corona crisis. We are in a lockdown. And so I had time to upgrade my Homeseer system with some Z-wave devices. And know I have a HUGE problem. I hope you will help?

                          I bought in 2018 and 2019 three sets of z-net and EU hardware directly from Homeseer, so that the restore function would work. And it did in the past. But now I have a seriously broken system! The restore does NOT work anymore. And this is nowhere documented! So I used this function and now 2 sticks are worthless. And my Homeseer system also. There are no nodes inside the stick anymore. At first I thought it should be the stick, because it did work in the past on this stick. So I tried the second one. No luck, only worth, because I have no stick anymore to take an image from. As it is a work around.

                          So I searched the forum and found that Homeseer does not support this function anymore since mid 2019. I have all the backups as advised by Homeseer but they are now all worthless. Just as my Homeseer system. The z-wave in my house is not functioning correctly anymore. I put maybe a 1000 hours and a lot more money in it. It is the core of my house systems. Had I know Homeseer stopped restore support in time, then I could have worked around it.

                          On the forum they say, there are no sticks anymore for the EU that support Homeseer restore function. So my problem is really big and maybe definite. I found an Australian supplier (Blackcat), in the forum described as the only z-wave stick that supports restore at all. But they don’t have the EU model, unless I buy 100 pieces. And they say that they have offered Homeseer there stick, but Homeseer does not have time for them. Now all the EU users have a huge problem I read in the forum. That cannot be the way Homeseer takes care of his customers.

                          Can you please help? And advise me which EU stick does work with HS restore? Or better, please make the restore function work again for This problem is SO HUGE.

                          I use Homeseer for more than 10 years, even bought HS4. But now everything is worthless. I’m desperate. Rick has helped me very good in the past. So mayby you can ask Rick for help?

                          PLEASE HELP?


                            I worked on this last year but never posted.

                   is the manufacturer of the UZB Z-Wave controller used in the Z-Net EU/AU versions. They provide a command-line backup/restore utility "ZMESerialUpdater". This reads the contents of the controller's internal NVRAM to a binary image file and vice-versa.

                            Usage is cryptic, so I wrote a couple of scripts to make it easier:

                   - this outputs the NVRAM contents to a binary image file.

                   - this writes an image file to the NVRAM.

                            From analysis of several NVRAM images, I mapped the contents of the HomeSeer Z-Wave backup file to the NVRAM contents. "" reads a HomeSeer .ZWave backup file and creates an NVRAM image file.

                            With this I was able to restore a Z-Net backup to a Razberry controller.

                            If you want to try this ...

                            Unzip the attached zip file to a workspace on the Z-Net device, then run

                            make setup
                            This downloads the ZMESerialUpdater utility from the site.

                            Make sure your device is disconnected from the Z-Wave plugin.

                            Create a backup of the current NVRAM contents.

                            This reads the NVRAM contents to a file zme-nmv_date_time.bin

                            Transfer a Z-Wave backup file from your HS server. These are located in the <hs_root>/Data/Z-Wave/ folder.

                            Generate NVRAM image

                            ./ [I]backup[/I].ZWave
                            Resulting file is named backup.ZWave.bin

                            Write this file to the NVRAM

                            ./ [I]backup[/I].ZWave.bin
                            Attached Files
                            Last edited by zwolfpack; October 23, 2021, 05:26 PM. Reason: Added now supports restore to secondary controllers


                              Originally posted by lasseruud View Post
                              FYI. Reply from support:

                              That's too bad.
                              Hei, did you ever find a solution to this? I`m trying to do the same and are experiencing exactly what you described last year,