Announcement

Collapse
No announcement yet.

SUPER SLOW Z-wave event response times.....

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • SUPER SLOW Z-wave event response times.....

    I have events that are manually driven that turn off everything in a specific room. I use them in conjunction with the main light switch so that as you leave a room, a triple tap shuts EVERYTHING off. They work pretty fast or fast enough. SO, I created an event that when a switch at the bottom of the stairs is triple tapped, it goes room by room running these manual events. It takes FOREVER. Not 10 second. Not 30 seconds. Up to 3 minutes. I have run them manually and it takes less time to run them one at a time than it does all together. I get no error messages either way and I can see in the log that the command gets sent. ….but it can take 3 minutes for the device to turn off. It is not HORRIBLE. It always works...eventually. I am just wondering if there is a better way to accomplish this event. I originally set it up this way because I was adding things to different rooms on a regular basis. It allowed me to make ONE change and all other events would use that change. Seemed smart at the time.... Is it best practices? How is everyone else doing this sort of event?

    I do have a couple of OLD 9.6 devices and a few non plus devices. I experimented with removing them from the events completely and with moving them to the end of the event. It only saved about 10 seconds when they were out completely. To me, that says they are not the problem.

    Any words of wisdom?

    Rob
    .

  • #2
    I have similar problem with ZWave sometimes, two reasons:
    1. Some devices can't be reached (or disconnected) - probably they are included in other routes, so ZWave is waiting for these devices. Try Z-Seer+ to test/optimise.
    2. Sometimes ZWave plugin CPU usage goes high - and it becomes slow. Could be actually caused by first problem.

    Comment


    • #3
      Don't know how many devices you're trying to control across multiple rooms, but I was having trouble doing the same when trying to turn off a large group. Spud added a feature in EasyTrigger that solved it--the command is only sent if the device is already on. Instead of sending, say, 75 off commands simultaneously, it only sends the dozen or so that are needed.

      It's included in beta 3.0.0.66 (release notes) and discussed in this thread.

      That's just one of many possible uses for the Set Device to Expression function, of course.
      -Wade

      Comment


      • #4
        THANK YOU! I am experimenting with y'alls advice!
        .

        Comment

        Working...
        X