Announcement

Collapse
No announcement yet.

Turn off wifi on Znet?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Turn off wifi on Znet?

    I have my Znet hardwired but still see the wifi IP on my router controller. I haven't added any wifi creds, so it's not doing anything but sitting there. Can I turn off the wifi on it, or should I even care?

    or should I setup wifi in parallel with the Lan connection? does that give me any additional bonus?

  • #2
    This should work: https://blog.sleeplessbeastie.eu/201...aspberry-pi-3/.

    The only benefit of leaving WiFi enabled is that if you need to move the z-net close to a device, then it becomes easy to do so. No real issue leaving it on.
    HS 3.0.0.548: 1990 Devices 1172 Events
    Z-Wave 3.0.1.262: 126 Nodes on one Z-Net

    Comment


    • #3
      Originally posted by sparkman View Post
      This should work: https://blog.sleeplessbeastie.eu/201...aspberry-pi-3/.

      The only benefit of leaving WiFi enabled is that if you need to move the z-net close to a device, then it becomes easy to do so. No real issue leaving it on.
      Thanks sparkman … makes sense. so would you then add the wifi creds and let it be connected both LAN and Wifi?

      Comment


      • #4
        Bringing this back up as i'm working through a znet issue this morning.

        If I leave both on, would I add the creds for the wifi side and have them both connected? right now I don't have the creds in, and it shows up as a guest on my LAN network.

        Comment


        • #5
          Originally posted by Tomgru View Post
          right now I don't have the creds in, and it shows up as a guest on my LAN network.
          Not sure how this is possible... If you can, log into the Raspberry Pi and run 'iwconfig wlan0' -- that will tell you whether/what its connected to.

          Comment


          • #6
            Originally posted by Tomgru View Post
            right now I don't have the creds in, and it shows up as a guest on my LAN network.
            Do you have a VAP configured then without any security? How is the Z-Net able to get on your wireless network without credentials?

            Comment


            • #7
              Originally posted by RoChess View Post

              Do you have a VAP configured then without any security? How is the Z-Net able to get on your wireless network without credentials?
              Yes, my guest network on my UB setup has no creds, but can only access the internet and is walled off from my home LAN, etc. Maybe a bad idea as anyone can jump on, but i'm kinda remote so that's not easy or likely.

              I do have the guest portal setup, so they need a simple password to logon there, and then they are on.

              I never setup the wifi on the znet to gain access at all... it just shows up as a guest client on that guest network in the device listing on my UB dashboard.

              Happy for suggestions here.

              Comment


              • #8
                Run the command

                Code:
                iwconfig wlan0
                on the Z-Net; that will tell you if you are really connected and to what.

                As far as disabling... you have two choices. (1) if you want to blast it completely to oblivion, you can disable/remove the driver; this will make the wlan0 device go away; (2) you can set up wireless "roaming", where a connection on the wired eth0 interface forces wlan0 to disconnect, and wireless re-activates when the wired connection is removed. This is how I have mine set up.

                Note that we discovered that on the elderly OS running on the Z-Net, option (2) only works when configured for DCHP which I think you said you have.

                I've run across instructions for (1) at some point but would have to search for it. I have instructions for (2) at home.

                Comment

                Working...
                X