Announcement

Collapse
No announcement yet.

Z-net starting to hang once per day

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Z-net starting to hang once per day

    I have a first generation Z-Net that has treated me well for many years. Once in a blue moon (maybe once or twice a year) the device would hang - become no longer pingable. However recently it’s been happening more often, and in the last week it’s started to be a daily thing. Giving it a power cycle brings it back.

    I had planned to buy a remote power control device to auto power cycle it if it goes offline, but now I’m starting to wonder if the device is simply flaking out and maybe I need to consider replacing it. Anyone have any ideas or suggestions to investigate and/or breath more life into it or should I just bite the bullet and replace it?

    #2
    I still have a gen1 Z-Net from when it was first released. Yearly, I re-image to a new SD card. You might try that first to make sure it's not the SD card failing.
    After that, try changing the power supply. Mine is running on a POE splitter.
    HS4Pro Running on a Raspberry Pi4
    79 Z-Wave Nodes, 131 Events, 383 Devices
    Z-Wave, UPB, WiFi
    Plugins: EasyTrigger, weatherXML, OMNI, Z-Wave, Tuya, Device History
    HSTouch Clients: 3 Android, 1 Joggler

    Comment


      #3
      The two things Rob mentioned are most common. The early power supplies were less reliable than the later ones and the OEM 4gb cards are best replaced by a high quality Sandisk, Samsung or other more durable card. I went to SanDisk Ultra 16GB cards and POE power for all of my Z-Nets in 2017 and have not had a single hiccup.

      Comment


        #4
        Randy, good to know. I didn't know Z-net supported POE or are you using the POE adapter? If so, which one are you using. I wouldn't mind losing a wall wart ...
        HS3PRO 3.0.0.500 as a Fire Daemon service, Windows 2016 Server Std Intel Core i5 PC HTPC Slim SFF 4GB, 120GB SSD drive, WLG800, RFXCom, TI103,NetCam, UltraNetcam3, BLBackup, CurrentCost 3P Rain8Net, MCsSprinker, HSTouch, Ademco Security plugin/AD2USB, JowiHue, various Oregon Scientific temp/humidity sensors, Z-Net, Zsmoke, Aeron Labs micro switches, Amazon Echo Dots, WS+, WD+ ... on and on.

        Comment


          #5
          Originally posted by langenet View Post
          Randy, good to know. I didn't know Z-net supported POE or are you using the POE adapter? If so, which one are you using. I wouldn't mind losing a wall wart ...
          I've been using this POE adapter from amazon for a couple years with no issues.
          -Wade

          Comment


            #6
            Originally posted by langenet View Post
            Randy, good to know. I didn't know Z-net supported POE or are you using the POE adapter? If so, which one are you using. I wouldn't mind losing a wall wart ...
            I’ve used these in the past. They are compact and make a reasonably trim package.

            Click image for larger version  Name:	8076F04A-043E-4527-902B-E873381506B9.jpeg Views:	0 Size:	45.6 KB ID:	1485329



            The TP-Link ones have been fine as well.

            Click image for larger version

Name:	DED7E1A5-DB48-482A-877D-64B12304A997.jpeg
Views:	0
Size:	37.3 KB
ID:	1485330


            I am currently using the Raspberry Pi POE hat with Pi 3B+ boards. I wrote about the project here. I have 5 up and running for almost 3 years.

            Comment


              #7
              One more thing I will add is that with my Ubiquiti system I can remotely reboot my Z-Nets by power cycling the switch port. I’ve never needed it due to a hung Z-Net but I do have an event that 1) power cycles all Z-Nets and 2) shuts down HS and reboots the server. On a couple of occasions over the last several years my Z-Wave network has experienced high latency and this routine has cleared it.

              Click image for larger version

Name:	31D10A57-BAC7-407C-941D-98CD302FE2D1.jpeg
Views:	0
Size:	53.2 KB
ID:	1485335

              Click image for larger version

Name:	30D30086-B32E-426E-9B4B-F3D3899C6A0D.jpeg
Views:	0
Size:	59.5 KB
ID:	1485336

              Comment


                #8
                Thanks Wade for that. I ordered one up. I really need to reduce the number of wall warts I have with my setup... . I've never had an issue with my Z-net and therefore never had to reboot/restart it... well, at least not yet.
                HS3PRO 3.0.0.500 as a Fire Daemon service, Windows 2016 Server Std Intel Core i5 PC HTPC Slim SFF 4GB, 120GB SSD drive, WLG800, RFXCom, TI103,NetCam, UltraNetcam3, BLBackup, CurrentCost 3P Rain8Net, MCsSprinker, HSTouch, Ademco Security plugin/AD2USB, JowiHue, various Oregon Scientific temp/humidity sensors, Z-Net, Zsmoke, Aeron Labs micro switches, Amazon Echo Dots, WS+, WD+ ... on and on.

                Comment


                  #9
                  Ok, so to be clear - you’re not saying the device supports POE, you’re saying you’re using a POE splitter to pull power from POE and split it to the power port on the device. That’s a good idea, I might try that, though I’m (relatively) sure it’s not power that is my current problem. I did indeed have to replace my power adapter once, and currently when the device hangs, it appears that the power to the device is still there. Unless it’s JUST flaky enough that it causes the device to hang. I’ll have to test.

                  swapping the SD card is a good idea - anyone have a link to the safest/best procedure to do the imaging?

                  regards,

                  Paul

                  Comment


                    #10
                    Correct - the Pi does not support a POE direct connection. You must use either a POE splitter or a POE hat.
                    For imaging, you can use Win32DiskImager or BalenaEtcher.
                    HS4Pro Running on a Raspberry Pi4
                    79 Z-Wave Nodes, 131 Events, 383 Devices
                    Z-Wave, UPB, WiFi
                    Plugins: EasyTrigger, weatherXML, OMNI, Z-Wave, Tuya, Device History
                    HSTouch Clients: 3 Android, 1 Joggler

                    Comment

                    Working...
                    X