Announcement

Collapse
No announcement yet.

Linux* Mono and ASPX page compilation

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    I'm testing on Raspberry Pi (stretch), mono 5.18 currently. The bsobel patch was all that was needed to get it running.

    gregoryx, what version(s) are you running? Post results of these commands

    Code:
    mono --version
    more /etc/os-release

    Comment


    • #17
      And the vbnc compiler version...

      Comment


      • #18
        I just tried this on my raspberry pi
        It helped get rid of the error but now I see this error:
        System.BadImageFormatException

        Description: HTTP 500.Error processing request.

        Details: Non-web exception.
        Exception stack trace:
        at (wrapper managed-to-native) System.Reflection.Assembly.LoadFrom(string,bool) at System.Reflection.Assembly.LoadFrom (System.String assemblyFile) [0x00000] in <b0e32063e1e04cbf802ab56dcffac4b0>:0 at System.Web.UI.TemplateParser.AddAssemblyForNamespace (System.String namesp) [0x000ce] in <52b8d38f1da445f7ad770be558c9fed4>:0 at System.Web.UI.TemplateParser.AddImport (System.String namesp) [0x00040] in <52b8d38f1da445f7ad770be558c9fed4>:0 at System.Web.UI.TemplateParser.RegisterNamespace (System.String tagPrefix, System.String ns, System.String assembly) [0x00000] in <52b8d38f1da445f7ad770be558c9fed4>:0 at System.Web.UI.TemplateControlParser.AddDirective (System.String directive, System.Collections.IDictionary atts) [0x0009e] in <52b8d38f1da445f7ad770be558c9fed4>:0 at System.Web.UI.PageParser.AddDirective (System.String directive, System.Collections.IDictionary atts) [0x00135] in <52b8d38f1da445f7ad770be558c9fed4>:0 at System.Web.Compilation.AspGenerator.TagParsed (System.Web.Compilation.ILocation location, System.Web.Compilation.TagType tagtype, System.String tagid, System.Web.Compilation.TagAttributes attributes) [0x000d8] in <52b8d38f1da445f7ad770be558c9fed4>:0 at System.Web.Compilation.AspParser.OnTagParsed (System.Web.Compilation.TagType tagtype, System.String id, System.Web.Compilation.TagAttributes attributes) [0x00019] in <52b8d38f1da445f7ad770be558c9fed4>:0 at System.Web.Compilation.AspParser.Parse () [0x000ff] in <52b8d38f1da445f7ad770be558c9fed4>:0 at System.Web.Compilation.AspGenerator.Parse (System.IO.TextReader reader, System.String filename, System.Boolean doInitParser) [0x00031] in <52b8d38f1da445f7ad770be558c9fed4>:0 at System.Web.Compilation.GenericBuildProvider`1[TParser].Parse () [0x0003c] in <52b8d38f1da445f7ad770be558c9fed4>:0 at System.Web.Compilation.GenericBuildProvider`1[TParser].GenerateCode () [0x00000] in <52b8d38f1da445f7ad770be558c9fed4>:0 at System.Web.Compilation.GenericBuildProvider`1[TParser].GenerateCode (System.Web.Compilation.AssemblyBuilder assemblyBuilder) [0x00008] in <52b8d38f1da445f7ad770be558c9fed4>:0 at System.Web.Compilation.BuildManager.GenerateAssembly (System.Web.Compilation.AssemblyBuilder abuilder, System.Web.Compilation.BuildProviderGroup group, System.Web.VirtualPath vp, System.Boolean debug) [0x00077] in <52b8d38f1da445f7ad770be558c9fed4>:0
        Version Information: 5.8.0.108 (tarball Fri Jan 19 18:55:10 UTC 2018); ASP.NET Version: 4.0.30319.42000
        Cheers,
        Bob
        Web site | Help Desk | Feature Requests | Message Board

        Comment


        • #19
          Looks like it must be something with my code as the test.aspx is working
          Cheers,
          Bob
          Web site | Help Desk | Feature Requests | Message Board

          Comment


          • #20
            Originally posted by zwolfpack View Post
            I'm testing on Raspberry Pi (stretch), mono 5.18 currently. The bsobel patch was all that was needed to get it running.

            gregoryx, what version(s) are you running? Post results of these commands

            Code:
            mono --version
            more /etc/os-release
            Man, I don't get actual notifications and I forget to check for them. <eye-roll>

            Code:
             Mono JIT compiler version 5.18.0.240 (tarball Wed Jan 16 10:18:14 UTC 2019)
            Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
            TLS:           __thread
            SIGSEGV:       normal
            Notifications: epoll
            Architecture:  armel,vfp+hard
            Disabled:      none
            Misc:          softdebug  
            Interpreter:   yes
            LLVM:          yes(600)
            Suspend:       preemptive
            GC:            sgen (concurrent by default)
            Code:
            :::::::::::::
             /etc/os-release ::::::::::::::
            PRETTY_NAME="Raspbian GNU/Linux 8 (jessie)"
            NAME="Raspbian GNU/Linux"
            VERSION_ID="8"
            VERSION="8 (jessie)"
            ID=raspbian
            ID_LIKE=debian
            HOME_URL="http://www.raspbian.org/"
            SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
            BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"
            not sure how I'd get the VBNC compiler version.... ?

            Comment


            • #21
              Maybe try to update to stretch ?? And then try the raspbian 9 instalation of mono ??gregoryx
              https://www.mono-project.com/downloa...d-lin-raspbian

              Comment


              • #22
                Good thoughts, @MttL0. I'll have to take that on when I'm not remote from the condo!

                Comment


                • #23
                  Here upgraded my Pine64 to Armbian Ubuntu 18.04 Still same issues here.

                  ____ _
                  Code:
                               __   _  _  
                  |  _ \(_)_ __   ___ / /_ | || |  
                  | |_) | | '_ \ / _ \ '_ \| || |_
                  |  __/| | | | |  __/ (_) |__   _|
                  |_|   |_|_| |_|\___|\___/   |_|  
                  
                  
                  Welcome to ARMBIAN 5.73 stable Ubuntu 18.04.2 LTS 4.19.25-sunxi64  
                  System load:   0.23 0.29 0.27      Up time:       24855 days        
                  Memory usage:  27 % of 2001MB     IP:            192.168.244.149
                  CPU temp:      43°C              
                  Usage of /:    27% of 30G
                  Pine64:/# mono --version
                  Mono JIT compiler version 5.18.1.0 (tarball Fri Mar 15 20:45:58 UTC 2019)
                  Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
                  TLS: __thread
                  SIGSEGV: normal
                  Notifications: epoll
                  Architecture: arm64
                  Disabled: none
                  Misc: softdebug
                  Interpreter: yes
                  LLVM: yes(600)
                  Suspend: preemptive
                  GC: sgen (concurrent by default)

                  Pine64:/# more /etc/os-release
                  NAME="Ubuntu"
                  VERSION="18.04.2 LTS (Bionic Beaver)"
                  ID=ubuntu
                  ID_LIKE=debian
                  PRETTY_NAME="Ubuntu 18.04.2 LTS"
                  VERSION_ID="18.04"
                  HOME_URL="https://www.ubuntu.com/"
                  SUPPORT_URL="https://help.ubuntu.com/"
                  BUG_REPORT_URL="https://bugs.launchpad.net/ubuntu/"
                  PRIVACY_POLICY_URL="https://www.ubuntu.com/legal/terms-and-policies/privacy-poli
                  cy"
                  VERSION_CODENAME=bionic
                  UBUNTU_CODENAME=bionic

                  Click image for larger version

Name:	mmono.jpg
Views:	195
Size:	48.9 KB
ID:	1297737
                  - Pete

                  Auto mator
                  Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.8X
                  Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.8X
                  HS4 pro - 4.0.3.0 - Ubuntu 18.04/W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono 6.8X

                  X10, UPB, Zigbee, ZWave and Wifi MQTT automation. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

                  Comment


                  • #24
                    Does anyone know how to apply this patch on a Mac running Mono 5.18.1.3?

                    Comment


                    • #25
                      I do not think i can help, but maybe you can tell what steps you already tried?

                      Comment


                      • #26
                        loading the new mono version 5.20.1.34 change the vbnc file. Replacing it with the workaound here does not help


                        now i get things like that in the log
                        Jul-17 19:47:35 Z-Wave Error The Simple AV Commands encountered an exception upon loading (Only affects Z-Wave infrared devices): Could not load type of field 'Microsoft.VisualBasic.FileIO.TextFieldParser:m_PeekedLine' (11) due to: Could not resolve type with token 010000a6 from typeref (expected class 'System.Collections.Generic.Queue`1' in assembly 'mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089') assembly:mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089 type:System.Collections.Generic.Queue`1 membernull)
                        Jul-17 19:47:31 Error Compiling script Startup.vb: Could not load type of field 'vbnc.Scanner:m_PeekedChars' (21) due to: Could not resolve type with token 010000d1 from typeref (expected class 'System.Collections.Generic.Queue`1' in assembly 'mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089') assembly:mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089 type:System.Collections.Generic.Queue`1 membernull) at vbnc.Main.Main (System.String[] CmdArgs) [0x00016] in :0 Failed compilation took 00:00:00.0416820
                        Attached Files

                        Comment


                        • #27
                          also get this ( I just reinstalled mono )
                          Jul-17 20:07:20 Error Compiling script /HomeSeer/scripts/DoShutdown.vb: Could not load type of field 'vbnc.Scanner:m_PeekedChars' (21) due to: Could not resolve type with token 010000d1 from typeref (expected class 'System.Collections.Generic.Queue`1' in assembly 'mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089') assembly:mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089 type:System.Collections.Generic.Queue`1 membernull) at vbnc.Main.Main (System.String[] CmdArgs) [0x00016] in :0 Failed compilation took 00:00:00.0268050
                          Jul-17 20:07:20 Event Running script and waiting: /HomeSeer/scripts/DoShutdown.vb("Main")
                          Jul-17 20:07:10 Pushover 3P Pushover Notification Sent - Message Title HS3 Linux is shutting down
                          Jul-17 20:07:10 JowiHue socket closed for bridge Conbee II on 192.168.1.3:20877
                          Jul-17 20:07:10 Error Compiling script /tmp/K1.vb: Could not load type of field 'vbnc.Scanner:m_PeekedChars' (21) due to: Could not resolve type with token 010000d1 from typeref (expected class 'System.Collections.Generic.Queue`1' in assembly 'mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089') assembly:mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089 type:System.Collections.Generic.Queue`1 membernull) at vbnc.Main.Main (System.String[] CmdArgs) [0x00016] in :0 Failed compilation took 00:00:00.0354330

                          Comment


                          • #28
                            Compiling script Startup.vb: Could not load type of field 'vbnc.Scanner:m_PeekedChars' (21) due to: Could not resolve type with token 010000d1 from typeref (expected class 'System.Collections.Generic.Queue`1' in assembly 'mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089') assembly:mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089 type:System.Collections.Generic.Queue`1 membernull) at vbnc.Main.Main (System.String[] CmdArgs) [0x00016] in :0 Failed compilation took 00:00:00.0365950



                            will remove mono and pinned the version the the last one..

                            Comment


                            • #29
                              they released mono 6.0 All seems to be back to normal!

                              Comment


                              • #30
                                Originally posted by MattL0 View Post
                                they released mono 6.0 All seems to be back to normal!
                                Typical, I was doing my monthly "maintenance", so I stopped HS, apt-get upgrade (Mono mostly), installed latest HS3, read post #3 and installed that patch-file and started HS again. Happy to see all working great! I then read through the rest of this post and see your comment...
                                And:
                                mono --version
                                Mono JIT compiler version 6.0.0.313 (tarball Sun Jul 14 10:02:21 UTC 2019)
                                So, I probably didn't need the patch-file, just had to update Mono... :P
                                I didn't backup the original vbnc, should I do something to revert back and not use the patched file from #3?

                                Comment

                                Working...
                                X