Announcement

Collapse
No announcement yet.

HomeSeer Mobile Beta 1.0

Collapse
This topic is closed.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • HomeSeer Mobile Beta 1.0

    Overview
    HomeSeer Mobile is a new FREE mobile app that's designed to work with HomeSeer HS3-based systems including the following:
    • HS3, HS3PRO & HS3-Pi Software
    • HomeTroller Zee S2
    • HomeTroller-SEL (standard & PRO versions)
    • HomeTroller S6 (standard & PRO versions)
    Click image for larger version

Name:	Featured-Graphic3.png
Views:	1
Size:	416.2 KB
ID:	1244204

    This first beta release is for Android mobile devices. An IOS version will be available shortly. As with any beta release, bugs and other issues may be encountered and these may impact the stability of your HomeSeer system. If this is not acceptable, you should wait for the final release version.

    The App supports Android version 5 and later (Lollipop).

    Features
    • Customizable dashboard. Add any device, resize, control items to show. Multiple dashboards are supported
    • Device list. Shows all devices, supports sorting and controlling any device and adding devices to the dashboard.
    • Event list. Show all events, run an event, add to the dashboard.
    • Camera list. Shows the latest snapshot from all cameras. Click on a camera to display larger real time view and pan/tilt controls. The camera list is auto updated every 10 seconds.
    • Supports log in from MyHS and local IP.


    Getting Started
    To get started, you must have HS3 version 3.0.0.460 or later. You can grab that from here:

    https://forums.homeseer.com/showthread.php?t=181241

    You will need to install from the Google Play store: https://play.google.com/store/apps/d...mobile.android

    We have a knowledge base with some documentation here:

    https://helpdesk.homeseer.com/catego...omeseer-mobile

    You can also get to this knowledge base from the help menu in the app.

    Reporting Bugs / Issues
    If you run into any crashes, you will be prompted with a dialog to submit crash info, please submit this! It will contain valuable information.

    If you find a non-crash bug or there is an enhancement you would like to request, from within HomeSeer Mobile select the menu icon (upper left corner) then the "Send Feedback" item. This will start an email. Fill it in and submit. You can include screen shots as attachments. This will create a ticket in our bug tracking system.

    You can also post any issue to this forum so others can review, but an issue will not get addressed unless it is in our bug tracker.

    Fixes in this update:

    [HSM-18] - Device list searching is janky
    [HSM-55] - Nest thermostat temp shows as ?
    [HSM-66] - Searching or filtering the device list causes a stutter
    [HSM-68] - Font color of Status text on dashboard widget fades near the bottom edge of the widget
    [HSM-69] - Widget border color doesn't display when dimmer value is below 26%
    [HSM-72] - If you click in the search box the keyboard pops up when clicking the devices icon
    [HSM-128] - Interaction with thermostats crashes or loops system

    Improvements:

    [HSM-9] - Increase touch zone for widget resizing border
    [HSM-74] - Full widget configuration options for thermostat widgets
    [HSM-76] - Assign primary on widgets separately from device
    [HSM-125] - Script button control
    [HSM-135] - Connect by hostname
    [HSM-152] - Confirm to run option for widgets
    [HSM-153] - Always open menu when event is clicked in list
    [HSM-154] - Drop down primary device selection method
    [HSM-157] - Lift animation on widgets

    Open Issues
    • Landscape mode is not supported (will be added after IOS support is completed)



    We are looking for feedback on how well the app displays plugin devices. Thanks in advance to everyone who participates in this beta. Please be sure to submit your bugs, issues or suggestions using the email function in the app or by posting to this thread.
    Last edited by macromark; August 28th, 2018, 01:28 PM.
    website | buy now | support | youtube

  • #2
    I got 4 crash with the app, sorry i missed the dialog box.

    3 of them when i tried to control a device in the device page of the app. The reason is because i changed the buttons of the device in HS3. Finally i had to close and refresh the app to get the device with the new buttons

    The last crash was when i tried to edit a scene icon in the dashbboard. The app just crashed after that.
    AMD 2700x 16gb - Ubuntu 18.10 Server -
    • HS3 Pro 3.0.0.507
      AirplaySpeak - APCUPSD - Big5 - BLGData - CPS Links - CPS Tags - DeviceHistory - EasyTrigger - JowiHue - Kodi - LutronCaseta - McsMQTT - MediaController - MeiHarmonyHub - PHLocation2 - Pushover - SceneMaster - SqueezeBox - UltraLog3 - Z-Wave - Jon00 stuff - HTTP calls
    • Openhab 2.5 Milestone 1 AmazonEchoControl - Plex - SystemInfo
    • Home Assistant 0.87 Plex - Roku
    • Node-red 19.5
    • Deconz 2.05.59
    • Logitech Media Server 7.9.2
    • Plex Server

    Comment


    • #3
      Originally posted by rjh View Post
      Getting Started
      To get started, you must have HS3 version 3.0.0.460 or later. You can grab that from here:

      https://forums.homeseer.com/showthread.php?t=181241
      The link to the 3.0.0.460 actually downloads the 459 relases. Here's the URL link that I copied from the above thread. The text of the link shows the correct URL.

      Code:
      <a href="https://homeseer.com/updates3/SetupHS3_3_0_0_459.msi" target="_blank">https://homeseer.com/updates3/SetupHS3_3_0_0_460.msi</a>

      Comment


      • #4
        Originally posted by slbuck View Post

        The link to the 3.0.0.460 actually downloads the 459 relases. Here's the URL link that I copied from the above thread. The text of the link shows the correct URL.

        Code:
        <a href="https://homeseer.com/updates3/SetupHS3_3_0_0_459.msi" target="_blank">https://homeseer.com/updates3/SetupHS3_3_0_0_460.msi</a>
        I can confirm the same.

        However if you manualy put https://homeseer.com/updates3/SetupHS3_3_0_0_460.msi in the browser it will download the .460 file.
        Billy Draper

        Comment


        • #5
          The download links on the HS3 beta post have been fixed.
          website | buy now | support | youtube

          Comment


          • #6
            "Error: Trust Failure"

            When trying to connect via hostname.

            The app does not respect the user imported certificate store perhaps?

            Comment


            • #7
              I am not able to see the following Z-Wave devices:
              Z-Wave deadbolt - Brand is Yale Model is B1L
              Garage door sensor and the ancillary devices/monitors associated with it. - Brand is Ecolink
              I have verified the "show in mobile" ect boxes are checked.


              I am able to see the following Z-Wave devices:
              Fibaro Button along with all the other ancillary devices/monitors created with it (Battery, status, ect)
              Front door sensor along with all the other ancillary devices/monitors created with it (Battery, status, ect) - Brand is Monoprice
              HS Multi sensor shows up fine as well - Brand is HomeSeer
              Remote Outdoor outlet - Brand is GE


              Would like to be able to lock and unlock directly.
              I created a Battery Dashboard so I could monitor all the Z-Wave device's batteries and can only see the Front door sensor and the Fibaro button.
              Cannot see the Deadbolt or the Garage door sensor battery monitors at this time.
              Last edited by Dan-O; July 27th, 2018, 08:52 PM.

              Comment


              • #8
                OK, one more weird thing.
                This concern is with X-10 motion sensors.

                Some sensors I click on and it immediately changes from motion to no motion (Like controlling a light)
                Some sensors I click and the control dialog box pops up at the bottom of the screen

                I have compared settings in both HS and in the App, all are the same.

                Comment


                • #9
                  Don't know if it's the backend servers, the HS update or the HS Mobile, but once it has started it feels just faster and snappier.

                  It does take longer to start up, though. After logging in I get a black screen for a few seconds (up to 7-8?), and then the app starts like normal.
                  HSPro 3.0.0.458, Z-NET with Z-wave plugin 3.0.1.190, RFXCOM + 2x RFXtrx433E, HSTouch, Squeezebox plugin, iTach IP/WF2IR & GC-100-6 with UltraGCIR, BLDenon, NetcamStudio, Jon00s Webpage builder, Harmony Hub plugin, SCSIP (with FreePBX), Arduino plugin, IFTTT, Pushalot plugin, Device History plugin.
                  Running on Windows 10 (64) virtualized
                  on ESXi (Fujitsu Primergy TX150 S8).
                  WinSeer (for Win10) - TextSeer - FitbitSeer - HSPI_MoskusSample

                  Are you Norwegian (or Scandinavian) and getting started with HomeSeer? Read the "HomeSeer School"!

                  Comment


                  • #10
                    I updated the app and HS (to 460). The app immediately crashes my device. I'm using Android 5.0.2.

                    Comment


                    • #11
                      would it be at all possible to look at the sizing of the widgets? Perhaps auto sizing? I know it appears minor but if I use the below device as an example then if I make it smaller in height I lose the on/off buttons (the outlines do not show in the picture oddly), making it wider and lowering the height also loses the buttons. It seems this is the smallest size to keep the buttons but there is a lot of wasted space - or the buttons could be bigger/center aligned?
                      My Plugins:

                      Pushover 3P | DoorBird 3P | Current Cost 3P | Velleman K8055 3P | LAMetric 3P | Garadget 3P | Hive 3P |
                      Yeelight 3P | Nanoleaf 3P

                      Comment


                      • #12
                        I still get a crash when scrolling through my devices without a filter when I get towards the end of the list. If I filter I can see all of the devices eventually. So my guess is that a specific device isn't causing it but the amount of devices is?

                        Current Date/Time: 7/28/2018 9:27:17 AM
                        HomeSeer Version: HS3 Standard Edition 3.0.0.460
                        Operating System: Microsoft Windows 10 Pro - Work Station
                        System Uptime: 0 Days 11 Hours 52 Minutes 17 Seconds
                        IP Address: 192.168.2.39
                        Number of Devices: 239
                        Number of Events: 58
                        Available Threads: 400
                        HSTouch Enabled: True
                        Event Threads: 0
                        Event Trigger Eval Queue: 0
                        Event Trigger Priority Eval Queue: 0
                        Device Exec Queue: 0
                        HSTouch Event Queue: 0
                        Email Send Queue: 0
                        Anti Virus Installed: Windows Defender Norton Security Suite

                        Enabled Plug-Ins
                        3.1.3.33206: Blue-Iris
                        1.3.2.0: Honeywell WiFi Thermostat
                        3.0.0.14: NetCAM
                        3.0.0.15: Vista Alarm
                        3.0.0.88: weatherXML
                        3.0.1.190: Z-Wave

                        Comment


                        • #13
                          Version 1.0 works fine on LG6 with Oreo but it instantly reboots my Fire HD8 and HD10 when I start the app.

                          Comment


                          • #14
                            Originally posted by rjh View Post
                            The download links on the HS3 beta post have been fixed.
                            Hey Rich, I'm still seeing the 459 in the href for the download links on the beta page for hs3.

                            EDIT: The links look good now as of 7/28/18 4:06PM CDT.

                            Code:
                            <a href="https://homeseer.com/updates3/SetupHS3_3_0_0_459.msi" target="_blank">https://homeseer.com/updates3/SetupHS3_3_0_0_460.msi</a>
                            
                            <a href="https://homeseer.com/updates3/hs3_linux_3_0_0_459.tar.gz" target="_blank">https://homeseer.com/updates3/hs3_li...0_0_460.tar.gz</a>
                            Last edited by slbuck; July 28th, 2018, 04:07 PM.

                            Comment


                            • #15
                              When I try to run the HS# 460 update, whether I select Modify or Repair, it always states the "specified account already exists", and exits prematurely.

                              Comment

                              Working...
                              X