Announcement

Collapse
No announcement yet.

HomeSeer Mobile Beta 3.6

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • rjh
    replied
    We have posted Beta 3.8 with some bug fixes, update from the App Store. See the sticky post.

    Leave a comment:


  • rjh
    replied
    We are moving to an architecture where the root and child devices are not dispalyed as separete items. So you need to make sure you have the root and all the children visible. You can hide some children if you want but some devices may not display properly.


    Originally posted by racerfern View Post
    I'm trying to understand why virtually no devices show up and it has something to do with "Show In Mobile". In HS Touch I could hide the root or other child devices, but in HS Mobile it seems the root has to have "Show In Mobile" enabled So it either shows correctly in HS Touch or in HS Mobile, but not both.

    I have the word "Root" in all root devices so now in HS Mobile I would want to remove that word, but in HS Touch I now see two kitchen lights as opposed to being able to hide the root. I get it, but the WAF will just drop unless I'm missing something basic.

    Leave a comment:


  • racerfern
    replied
    I'm trying to understand why virtually no devices show up and it has something to do with "Show In Mobile". In HS Touch I could hide the root or other child devices, but in HS Mobile it seems the root has to have "Show In Mobile" enabled So it either shows correctly in HS Touch or in HS Mobile, but not both.

    I have the word "Root" in all root devices so now in HS Mobile I would want to remove that word, but in HS Touch I now see two kitchen lights as opposed to being able to hide the root. I get it, but the WAF will just drop unless I'm missing something basic.

    Leave a comment:


  • Dan-O
    replied
    I have solved the hidden device issue and wanted to share.

    I was having trouble seeing my batteries for my deadbolt and my garage door sensor, both Z-Wave devices.
    Both 'devices' that were my battery monitors were checked (or not checked) to show but the PARENT devices were checked off to hide from mobile or just hide from views.
    Once I unchecked the boxes on my Main HS web page so that they could be seen, I was able to see the parent and subsequently was able to see the batteries and add them to my HS Mobile Batteries Dashboard.

    Hopefully this helped someone.
    Last edited by Dan-O; September 5th, 2018, 09:53 AM.

    Leave a comment:


  • antoon
    replied
    Yesterday I upgraded the app and HS software to the latest versions.
    Since then I don't see any device and when I press on the location 1 or 2 there comes a message "location list not loaded"
    Sometimes a couple of devices show on the screen.
    Before the upgrade everything was working fine.
    Have I missed something?


    Click image for larger version

Name:	Screenshot_20180904-070141_HomeSeer Mobile_01.jpg
Views:	2
Size:	21.9 KB
ID:	1245432

    Leave a comment:


  • B1Trash
    replied
    Originally posted by Mr_Resistor View Post
    It would be good to provide an option to "cache" the data locally with a manual "refresh devices". That being said, my system loads almost 5k devices and 500 events in under 13 seconds over 4G and under 10 on local wifi. And the response to controlling devices is nearly instantaneous. So far, very impressive.
    To add on, maybe send a hash or checksum on the device structure... no change = use cached data?

    Originally posted by Mr_Resistor View Post
    Another vote for adding geofencing. This would be truly useful to have reliable geo data available. Each beta is getting better and better. Keep up the good work.
    +1

    Thanks for innovating!

    Leave a comment:


  • Mr_Resistor
    replied
    Originally posted by Moskus View Post
    Yes, but it will stay in memory as long as the app is running. When it's closed (Android is eager to close apps that aren't up front) I have to download the list again...

    Perhaps you can make an option to actually save the device list and images, and add a manual "re-download device list" button. Most of the time I don't need to get all devices, just update their status...
    Appreciate the continued vigilance on security by only showing devices which the users has permission to view/change.

    It would be good to provide an option to "cache" the data locally with a manual "refresh devices". That being said, my system loads almost 5k devices and 500 events in under 13 seconds over 4G and under 10 on local wifi. And the response to controlling devices is nearly instantaneous. So far, very impressive.

    Another vote for adding geofencing. This would be truly useful to have reliable geo data available. Each beta is getting better and better. Keep up the good work.
    Last edited by Mr_Resistor; September 3rd, 2018, 09:58 PM.

    Leave a comment:


  • petez69
    replied
    After upgrading I can confirm that locally the app works very quickly. WHen I connect usign my phone on 4G, controlling an MQTT device is VERY sluggish.... I have 70 devices....Also the downloading of the devices and associated images on app start via mobile network is slow....The mobile app was way snappier on v1.0

    Leave a comment:


  • Moskus
    replied
    Originally posted by rjh View Post
    In the previous version we were getting the devices in the background, but now we have to get all the device info at startup. This is so we can check the user security on the devices and only show the ones the user has access to. With many devices this is a lot of data. We are looking at what we can do to speed things up. But after you load it, it will stay in memory and accessing it going forward is instant.
    Yes, but it will stay in memory as long as the app is running. When it's closed (Android is eager to close apps that aren't up front) I have to download the list again...

    Perhaps you can make an option to actually save the device list and images, and add a manual "re-download device list" button. Most of the time I don't need to get all devices, just update their status...
    Last edited by Moskus; September 1st, 2018, 01:36 AM.

    Leave a comment:


  • MattL0
    replied
    hi just see the meiharmonyhub root device in the mobile app again. no child device with their dropdown list of device

    Leave a comment:


  • deanrparry
    replied
    I see them again but one new issue... The phevohome plugin zone status icon crashes the dashboard completely once you open the room its associated to. Can't delete it either instantly crashes on that specific dashboard only solution would be clear data and restart.

    Leave a comment:


  • rjh
    replied
    Update to the latest version B0.3.7 to fix issues with the drop lists.

    Leave a comment:


  • rjh
    replied
    We posted an update, see if you have B0.3.7 installed. (version is displayed under help menu)

    Originally posted by deanrparry View Post
    My envisalink devices are still in dashboard on latest beta but they are no longer available as devices existing or new. For some reason they no longer show at all except in dashboard for ones added prior to this release. Plugin Spuds Envisalink DSC

    Leave a comment:


  • deanrparry
    replied
    My envisalink devices are still in dashboard on latest beta but they are no longer available as devices existing or new. For some reason they no longer show at all except in dashboard for ones added prior to this release. Plugin Spuds Envisalink DSC

    Leave a comment:


  • rjh
    replied
    In the previous version we were getting the devices in the background, but now we have to get all the device info at startup. This is so we can check the user security on the devices and only show the ones the user has access to. With many devices this is a lot of data. We are looking at what we can do to speed things up. But after you load it, it will stay in memory and accessing it going forward is instant.

    Originally posted by Moskus View Post
    Locally HS Mobile is flying. No really, it's insanely fast.

    Via MyHS it's very slow.

    Leave a comment:

Working...
X