Announcement

Collapse
No announcement yet.

HomeSeer Mobile Beta v1.1 (iOS)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #91
    Originally posted by rjh View Post
    Just to clarify. If you log in using MyHS and create some dashboards, then log in with IP, you will not see the dashboard unless you log in locally with the same user pass as your MyHS login. Is that what is happening here? Did you say you are logging in differently now? The dashboard is tied to your user and license, so those cannot be different.


    For the past 2-3 Weeks Ihave been logging in via myHS. However, I did login yesterday to my local IP address just to see if my dashboards would be there. A few old dashboards were there. They were probably months old (within days of the release of the first beta). I think I then logged out of local and back into myHS. Last night I made a few changes to one of my dashboards then went to bed. I did not shut down or log out. This morning I had to restart the app and login to myHS; no dashboards. I am always logging in to myHS with my myHS credentials. ​​​​​I only have one account.
    HomeSeer Version: HS3 Pro Edition 3.0.0.368, Operating System: Microsoft Windows 10 - Home, Number of Devices: 373, Number of Events: 666, Enabled Plug-Ins
    2.0.83.0: BLRF, 2.0.10.0: BLUSBUIRT, 3.0.0.75: HSTouch Server, 3.0.0.58: mcsXap, 3.0.0.11: NetCAM, 3.0.0.36: X10, 3.0.1.25: Z-Wave,Alexa,HomeKit

    Comment


    • #92
      Originally posted by rjh View Post
      Would it possible to make that image available over the Internet so I can access it here? I bet there is something in the header that is messing it up on this end. We do load some headers in the request, so maybe we are missing something there that blueiris is looking for.

      Or, I can run blueiris here, is this an issue with any camera? I can load one of our cameras on it.
      I don't have Blue Iris connected to the Internet currently. Will have to look into what it would take (not before the weekend). It is the same issue for all 7 cameras, i.e. the Blue Iris URL for all 7 cameras (The cameras themselves are of different brands but the Blue Iris URL hides that from its URL).

      Comment


      • #93
        I am sure this is not the issue, but for sure there is no port blocking going on? I am sure blueiris is on a different port, correct? You have included this port in the manual camera setup in HS?

        On your local Lan, from a PC, can you try these URL's, put in the IP of your HS3 system:

        This should get you list of all your cameras, make sure the camera is there:

        http://HSIP/json?request=getcameras

        Now get an image with:

        http://HSIP/json?request=getcamerasnapshot&camid=ID

        Get the camera ID from the getcameras call, you will something like:

        "Name":"IPCamera-242","ID":"28AD3E63D508" What is returned may help us figure out what is wrong.

        Originally posted by pcp View Post

        I don't have Blue Iris connected to the Internet currently. Will have to look into what it would take (not before the weekend). It is the same issue for all 7 cameras, i.e. the Blue Iris URL for all 7 cameras (The cameras themselves are of different brands but the Blue Iris URL hides that from its URL).
        website | buy now | support | youtube

        Comment


        • #94
          Originally posted by Steve Q View Post

          Have you tried replacing the location 1/2 names with some custom text? I think it is possible.
          I can’t see where to do that, but I want to hide those 2 rows entirely so that I can get more widgets on the screen.
          cheeryfool

          Comment


          • #95
            Originally posted by cheeryfool View Post

            I can’t see where to do that, but I want to hide those 2 rows entirely so that I can get more widgets on the screen.
            I think the app is designed around the 3 sizes of the widgets. If the widgets were odd sizes it would be very difficult to rearrange them.. if you need smaller widgets, why not use a slim event widget. The event can do anything you want. I will be using a combination of sizes.

            I would like to have text widgets and image widgets and the ability to set the background color of the widget.
            HomeSeer Version: HS3 Pro Edition 3.0.0.368, Operating System: Microsoft Windows 10 - Home, Number of Devices: 373, Number of Events: 666, Enabled Plug-Ins
            2.0.83.0: BLRF, 2.0.10.0: BLUSBUIRT, 3.0.0.75: HSTouch Server, 3.0.0.58: mcsXap, 3.0.0.11: NetCAM, 3.0.0.36: X10, 3.0.1.25: Z-Wave,Alexa,HomeKit

            Comment


            • #96
              Kudos for all the fixes in rc18. Too many to mention. Building dashboards is easier and much faster. Thanks for listening and incorporating many of the suggestions posted here.
              HomeSeer Version: HS3 Pro Edition 3.0.0.368, Operating System: Microsoft Windows 10 - Home, Number of Devices: 373, Number of Events: 666, Enabled Plug-Ins
              2.0.83.0: BLRF, 2.0.10.0: BLUSBUIRT, 3.0.0.75: HSTouch Server, 3.0.0.58: mcsXap, 3.0.0.11: NetCAM, 3.0.0.36: X10, 3.0.1.25: Z-Wave,Alexa,HomeKit

              Comment


              • #97
                I need some guidance: Which should I use? Local IP or myHS. I don’t quite understand the capabilities of local vs myHS.
                HomeSeer Version: HS3 Pro Edition 3.0.0.368, Operating System: Microsoft Windows 10 - Home, Number of Devices: 373, Number of Events: 666, Enabled Plug-Ins
                2.0.83.0: BLRF, 2.0.10.0: BLUSBUIRT, 3.0.0.75: HSTouch Server, 3.0.0.58: mcsXap, 3.0.0.11: NetCAM, 3.0.0.36: X10, 3.0.1.25: Z-Wave,Alexa,HomeKit

                Comment


                • #98
                  Originally posted by Steve Q View Post
                  I need some guidance: Which should I use? Local IP or myHS. I don’t quite understand the capabilities of local vs myHS.
                  That is entirely a personal choice. Using MyHS will try to connect through wifi first if you are on the same LAN or utilize the MyHS tunnel if you aren't. Connecting directly via IP/Hostname is available for those who do not want to use MyHS and prefer an offline system or to manage their own tunnel. If you do not have a specific reason for using IP/Hostname it is advised to connect through MyHS.
                  - JL West
                  HomeSeer Software Engineer
                  sigpic

                  Comment


                  • #99
                    Thanks, but still not clear. What do you mean by “prefer an offline system”. Are you talking about an HS3 setup that is not connected to the internet???? Is anybody doing this??? We are talking about a mobile app here - a phone app! People use their phone outside their home and expect their app to work anywhere. It sounds like myHS is a requirement.

                    So I created a bunch of dashboards via my local IP. How do I move them to MyHS?
                    HomeSeer Version: HS3 Pro Edition 3.0.0.368, Operating System: Microsoft Windows 10 - Home, Number of Devices: 373, Number of Events: 666, Enabled Plug-Ins
                    2.0.83.0: BLRF, 2.0.10.0: BLUSBUIRT, 3.0.0.75: HSTouch Server, 3.0.0.58: mcsXap, 3.0.0.11: NetCAM, 3.0.0.36: X10, 3.0.1.25: Z-Wave,Alexa,HomeKit

                    Comment


                    • Originally posted by Steve Q View Post
                      Thanks, but still not clear. What do you mean by “prefer an offline system”. Are you talking about an HS3 setup that is not connected to the internet???? Is anybody doing this??? We are talking about a mobile app here - a phone app! People use their phone outside their home and expect their app to work anywhere. It sounds like myHS is a requirement.

                      So I created a bunch of dashboards via my local IP. How do I move them to MyHS?
                      Yes actually. We have quite a few customers that operate systems that are considered "off the grid" or that prefer to manage their own tunnel. HomeSeer is one of the only home automation controllers on the market that does not require a constant connection to the internet to monitor and control your system. (unless you are using plug-ins and hardware that utilize cloud services) In the instance that someone is running their system "off the grid" you are correct that they would not be able to access their system unless they are on that network. In the instance that someone has their own tunnel setup they can still access their system as long as they can access the tunnel. These are both advanced configurations and are not a typical setup for most users; so you are correct that, for the majority of users, MyHS is a requirement.

                      There is currently no mechanism for moving dashboards from one session to another. You will have to recreate them.

                      - JL West
                      HomeSeer Software Engineer
                      sigpic

                      Comment


                      • [QUOTE=JLDubz

                        There is currently no mechanism for moving dashboards from one session to another. You will have to recreate them.

                        [/QUOTE]

                        OK but not what I wanted to hear.

                        I have multiple ios devices. Will the dashboards I create on my iPad Pro work on my iPhone, iPad Air and I touch?
                        HomeSeer Version: HS3 Pro Edition 3.0.0.368, Operating System: Microsoft Windows 10 - Home, Number of Devices: 373, Number of Events: 666, Enabled Plug-Ins
                        2.0.83.0: BLRF, 2.0.10.0: BLUSBUIRT, 3.0.0.75: HSTouch Server, 3.0.0.58: mcsXap, 3.0.0.11: NetCAM, 3.0.0.36: X10, 3.0.1.25: Z-Wave,Alexa,HomeKit

                        Comment


                        • In case anyone didn't see the official announcement, HomeSeer Mobile is officially released today! https://forums.homeseer.com/forum/ho...e-v1-0-release
                          website | products | support | youtube

                          Comment


                          • Originally posted by rjh View Post
                            I am sure this is not the issue, but for sure there is no port blocking going on? I am sure blueiris is on a different port, correct? You have included this port in the manual camera setup in HS?

                            On your local Lan, from a PC, can you try these URL's, put in the IP of your HS3 system:

                            This should get you list of all your cameras, make sure the camera is there:

                            http://HSIP/json?request=getcameras

                            Now get an image with:

                            http://HSIP/json?request=getcamerasnapshot&camid=ID

                            Get the camera ID from the getcameras call, you will something like:

                            "Name":"IPCamera-242","ID":"28AD3E63D508" What is returned may help us figure out what is wrong.

                            The first URL reported all cameras through the ID is the Name (and no ID in the ini file). The second URL for a specific ID from the first URL (which was actually the Camera Name) did not report any snapshot content.

                            Then made some changes with good progress and got it to work: I removed all camera definitions and recreated them (still using Blue Iris URL). This created them with IDs as expected. Second I used the IP address to the Blue Iris server (actually same server running HS3) instead of a host name in the URL. With these two changes I got images in the Mobile App and HS3Touch.

                            But after a while, I get errors in the HS3 log and images don't refresh (or flick er/ disappear in HS3Touch). It could also be that Blue Iris or one of my security software is blocking access due to security considerations when queried at high frequency. I will have to look into that.

                            Is there a way to control the rate at which HS3 is fetching images from the Cameras/Blue Iris for the Mobile App?

                            Click image for larger version

Name:	2019-02-01_19-59-57.png
Views:	13
Size:	163.6 KB
ID:	1281565

                            Comment


                            • I keep getting this

                              Comment


                              • I have been getting this unexpected network error since the very beginning, I have to turn off WiFi to connect thru HomeSeer mobile can’t do it locally. Now I updated HS3 app it doesn’t work st all. I turned of windows firewall and still get error, please help

                                Comment

                                Working...
                                X