Announcement

Collapse
No announcement yet.

It forgets my username/password when I reboot, even though remember me is checked

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • It forgets my username/password when I reboot, even though remember me is checked

    Title pretty much says it all.

  • #2
    Basically the same thing here. Logging into the IP of my server, checked the 'Remember Me' option. Once I log out and go to log back in, All server settings are gone... IP Address, Port, Username and Password are all empty. Here's my info:

    Current Date/Time: 2/3/2019 10:38:55 AM
    HomeSeer Version: HS3 Pro Edition 3.0.0.500
    Linux version: Linux HS3-Laptop 4.4.0-141-generic #167-Ubuntu SMP Wed Dec 5 10:40:15 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux System Uptime: 0 Days 10 Hours 5 Minutes 40 Seconds
    IP Address: 172.16.1.101
    Number of Devices: 131
    Number of Events: 41
    Available Threads: 800
    HSTouch Enabled: True
    Event Threads: 0
    Event Trigger Eval Queue: 0
    Event Trigger Priority Eval Queue: 0
    Device Exec Queue: 0
    HSTouch Event Queue: 0
    Email Send Queue: 0

    Enabled Plug-Ins
    3.0.19.0: BLLock
    3.1.3.33206: Blue-Iris
    3.0.1.252: Z-Wave

    Comment


    • #3
      My "Remember Me" disappeared too.

      Comment


      • #4
        Same here on android samsung note 10, being logged out each time app goes out of memory. I am trying to set it up for my wife, she basically cannot/will not use it if she needs to type email and password each time (that must contain one capital, one symbol, one letter etc..).
        When we try to use local access then she must enter ip and port and some other credentials each time.

        Comment


        • #5
          Originally posted by dakipro View Post
          Same here on android samsung note 10, being logged out each time app goes out of memory. I am trying to set it up for my wife, she basically cannot/will not use it if she needs to type email and password each time (that must contain one capital, one symbol, one letter etc..).
          When we try to use local access then she must enter ip and port and some other credentials each time.
          Are you using the myHomeSeer login?
          -Rupp
          sigpic

          Comment


          • #6
            Yes, when using remote access I use myhs account, and it works great as long as the app is active in the background. If I kill it it asks to login again. (This could be coincidence that I also connect to my local WiFi, not sure if that has something to do with it)
            For local access I can write IP and "local" credentials from the homeseer admin , and app works fine, however server and credential details are again lost when Android removes apps from memory.

            Ps. Openhab solved this very conveniently as you write both credentials in the settings, and it will automatically try to connect locally first, if it fails it will just connect remotely, very very high WAF
            i think OH app is also opensource, perhaps similar solution can be implemented in homeseer as well

            Comment


            • #7
              Originally posted by dakipro View Post
              Yes, when using remote access I use myhs account, and it works great as long as the app is active in the background. If I kill it it asks to login again. (This could be coincidence that I also connect to my local WiFi, not sure if that has something to do with it)
              For local access I can write IP and "local" credentials from the homeseer admin , and app works fine, however server and credential details are again lost when Android removes apps from memory.

              Ps. Openhab solved this very conveniently as you write both credentials in the settings, and it will automatically try to connect locally first, if it fails it will just connect remotely, very very high WAF
              i think OH app is also opensource, perhaps similar solution can be implemented in homeseer as well
              What version of HSMobile are you running? I just logged out and didn't check remember me. When I logged backed in I had to log in. I then selected remember me and closed the app. Restarted the app and it worked. If you are running the latest versions of HS3 and HSMobile then I'd recommend putting in a help desk ticket at support@homeseer.com
              -Rupp
              sigpic

              Comment


              • #8
                Thank you for your assistance Rupp , I see that HS3 is not the latest version, it is .500 (I installed it from some docker image, that seams to not be updated). On mobile it is the latest version available on playstore I installed few days ago when I purchased the software, 1.1.0-100 .
                I am yet to configure system as I am migrating from openhab, I hope to get a bit more details before I submit help desk ticket, then I can isolate and describe the issue properly.
                One more thing I am experiencing, and might be related to this login/logout is that on local network I cannot login thru myhs, so perhaps that is why I am being presented with login screen.
                Possible troublesome scenario: I am home testing, then I must use Local instance link, I then go to work and try to check something, I must login again using myhs, and when I get home to open the app it cannot login to remote system for some reason. could be that docker is causing this issue, could be that it is something on my network, so I am yet to narrow it down a bit more to isolate what is going on, but that will come soon when I get all the basics set up

                Comment

                Working...
                X