Announcement

Collapse
No announcement yet.

Mobile can't login to camera

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Mobile can't login to camera

    My camera ( Foscam - auto discovered) has a password that contains a special character. When I navigate to the camera page of HSMobile it shows a black block and the spinning arrow. I checked the HS3 log and find the following error message:
    Feb-11 1:18:26 PM CAM Error with request: The remote name could not be resolved: 'xxxxxx'
    The 'xxxxxx' represent the last 6 characters of my password. It seems to have truncated right after the special character.

    Can we not use special characters in a password?
    Last edited by cfrudolphy; March 3rd, 2019, 11:04 AM. Reason: Solved - see post below.

  • #2
    Bump???? Acknowledgement of issue would be appreciated.

    Comment


    • #3
      Urls in setup are correct I assume ?

      Comment


      • #4
        There are no settings I can find in Homeseer Mobile app (android - Amazon fire 8HD) that allow you to change anything about the camera settings.

        In HS3 setup, camera tab, the camera (Foscam) was auto discovered. The IP address is correct. The only other fields are for user name and password. They are set to the ones I successfully use to login to the camera via the Foscam app (android - galaxy s7).

        Note all of this is being done on my local LAN not externally from outside my local network.

        ​​​​​​Chuck

        Comment


        • #5
          I assumed you tried a simple password?

          Comment


          • #6
            No, I haven't changed the password. I could change it but quite frankly for security purposes it should be complicated, not simple. The other thing is that the portion of the password that was in the log is in clear text. Helps for diagnosis but that is not very secure. That kind of bothers me.

            What else bothers me is that it is obvious from reading other posts that homeseer employees are responding to other posts and not this one. Others complain about this from time to time. Even if they can't fix it right now an acknowledgement of the problem would be nice.

            Chuck

            Comment


            • #7
              An update to my original post. I reluctantly changed my password so that it did not contain a special character. That character being the "@" character. Now my camera feed is viewable in HSMobile. Not sure what other special characters might break the login in process. It may have something to do with passing the credentials in some sort of http request.

              the foscam camera also lets you login with its app via a user name and/or an email address. I believe that using an email address with its use of the "@" sign would also break the HSMobile login process.

              Comment

              Working...
              X