Announcement

Collapse
No announcement yet.

No devices found. Locations not available. JSON errors in event log.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • No devices found. Locations not available. JSON errors in event log.

    RESOLVED! Install mono-complete!

    I'm trying to get Homeseer Mobile working with my Home automation system. I've looked at some of the other threads and none seem to fit my problem. I cannot see any devices, and locations listed as not available. In the log, I get the following error.
    Problem serializing data for JSON request: Could not load file or assembly or one of its dependencies.
    Homeseer is running on an old laptop running Debian stretch.

    I've seen other people talking about invalid devices, but that doesn't seem to be my problem. I've tried to get the mobile app working with just a handful of Z-wave devices on the network, and no other plugins and got the same error.

    How do I fix this?

    System information follows.

    Current Date/Time: 9/5/2019 3:16:50 AM
    HomeSeer Version: HS3 Standard Edition 3.0.0.548
    Linux version: Linux MEGAman 4.9.0-9-amd64 #1 SMP Debian 4.9.168-1+deb9u5 (2019-08-11) x86_64 GNU/Linux System Uptime: 1 Day 20 Hours 14 Minutes 59 Seconds
    IP Address: 192.168.2.41
    Number of Devices: 182
    Number of Events: 7
    Available Threads: 192
    HSTouch Enabled: True
    Event Threads: 0
    Event Trigger Eval Queue: 0
    Event Trigger Priority Eval Queue: 0
    Device Exec Queue: 0
    HSTouch Event Queue: 0
    Email Send Queue: 0

    Enabled Plug-Ins
    4.1.5.0: mcsMQTT
    3.0.9.3: SDJ-VStat
    3.0.1.252: Z-Wave
    Last edited by TankHankerous; September 11th, 2019, 12:40 PM. Reason: Issue resolved

  • #2
    This error seemed to be a result of not installing the complete version of mono.
    Code:
    sudo apt-get install mono-complete
    Should resolve this issue should you encounter it.

    Comment

    Working...
    X