Announcement

Collapse
No announcement yet.

HomeSeer Mobile - Multiple Errors [Solved][PSA]

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    HomeSeer Mobile - Multiple Errors [Solved][PSA]

    Issue:
    1. Unable to login: "Error Please check username and password and try again"
    2. When direct connecting to IP it would show devices but be unable to load data "Error An unexpected error has occurred. Object reference not set to an instance of an object"

    So, after dealing with very little response from HomeSeer support over the past 9 days. I decided to dedicate more time to research the issue myself.
    I figured out the issue is a "#" in my password as the special character.

    HomeSeer must be sending an unencrypted username in the password from the app. When doing that, apparently you can't have a password that contains a "#". I tried a getstatus request with localhost to see if it would give me any additional errors, and when I put my un/pw in the URL, it cut it off at the #. In the test example, I passed through the pw "THISisA#TEST". When looking at the dev tools, it shows the data as "http://localhost/JSON?user=email@domain.com&pass=THISisA", cutting off at the # sign.

    Hopefully, this post helps at least one person not have to deal with HomeSeer support.
Working...
X