No announcement yet.

Gmail errors

This is a sticky topic.
  • Filter
  • Time
  • Show
Clear All
new posts

    Gmail errors

    If you enable the SEL unit for Gmail and enable the receive email feature, you may get a TLS certificate error in the log. To fix this, open a terminal window and enter the following:

    sudo certmgr -ssl -m smtps://

    Units sold after 2/26/16 will have this done during manufacturing and should not need this run.
    💁‍♂️ Support & Customer Service 🙋‍♂️ Sales Questions 🛒 Shop HomeSeer Products

    When I run the command you gave form Linux tools. Below is the response I get back:

    running comand sudo certmgr -ssl -m smtps://
    Mono Certificate Manager - version
    Manage X.509 certificates and CRL from stores.
    Copyright 2002, 2003 Motus Technologies. Copyright 2004-2008 Novell. BSD licensed.

    X.509 Certificate v3
    Issued from: C=US, O=Equifax, OU=Equifax Secure Certificate Authority
    Issued to: C=US, O=GeoTrust Inc., CN=GeoTrust Global CA
    Valid from: 5/21/2002 4:00:00 AM
    Valid until: 8/21/2018 4:00:00 AM
    *** WARNING: Certificate signature is INVALID ***
    Import this certificate into the CA store ?

    If I type y or yes and hit the execute button nothing happens.

    I still get the below error:

    Unable to log into Gmail server: Authenticate as SSL client failed. You might be connecting to non SSL port.:Inner Exception: System.IO.IOException: The authentication or decryption has failed. ---> Mono.Security.Protocol.Tls.TlsException: Invalid certificate received from server. at Mono.Security.Protocol.Tls.Handshake.Client.TlsServerCertifi cate.LocalValidation (Mono.Security.Protocol.Tls.ClientContext context, AlertDescription description) [0x00000] in :0 at Mono.Security.Protocol.Tls.Handshake.Client.TlsServerCertifi cate.validateCertificates (Mono.Security.X509.X509CertificateCollection certificates) [0x00000] in :0 at Mono.Security.Protocol.Tls.Handshake.Client.TlsServerCertifi cate.ProcessAsTls1 () [0x00000] in :0 at Mono.Security.Protocol.Tls.Handshake.HandshakeMessage.Proces s () [0x00000] in :0 at (wrapper remoting-invoke-with-check) Mono.Security.Protocol.Tls.Handshake.HandshakeMessage:Proces s () at Mono.Security.Protocol.Tls.ClientRecordProtocol.ProcessHands hakeMessage (Mono.Security.Protocol.Tls.TlsStream handMsg) [0x00000] in :0 at Mono.Security.Protocol.Tls.RecordProtocol.InternalReceiveRec ordCallback (IAsyncResult asyncResult) [0x00000] in :0 --- End of inner exception stack trace --- at Mono.Security.Protocol.Tls.SslStreamBase.AsyncHandshakeCallb ack (IAsyncResult asyncResult) [0x00000] in :0


      I am having the same issues. Was anyone able to find a solution?