No announcement yet.

How to get root access to HomeTroller?

  • Filter
  • Time
  • Show
Clear All
new posts

    How to get root access to HomeTroller?

    I am facing some problems with the RFXcom plugin (due to using a prototype 868 MHz version). Therefore I got a special beta-version of the plugin from Bert and need to load that into my HomeTroller SEL.

    However this is where I am too Linux-stupid apparently.

    Was told to rename the original HSPI_RFXCOM.EXE into e.g. HSPI_RFXCOM.OLD - tried to do this from the Linux tools menu item in my Hometroller SEL. Nothing happens. I assume this is due to lacking access rights. The file has the following permissions:

    -rw-r--r-- 1 root root 658432 Jul 1 2015 HSPI_RFXCOM.exe

    tried a CHMOD on the file... That fails too. Probably because only "root"-user has rw-access??

    How can I proceed? I have no ideas myself...

    Thanks for any help.

    Take a look at this post: It should give you the info you need.
    HS 2134 Devices 1252 Events
    Z-Wave 133 Nodes on one Z-Net


      No root access on Hometroller SEL

      Tried all of the the above and the referenced link with success. I am trying to install the OpenSprinkler plugin and need to move some files to an image folder and the ini file to the config folder and exe to the HomeSeer folder.

      I can SSH in using homeseer and the password I created and log in and get the proverbial "permission denied" response when attempting to copy the files.

      Any ideas?

      have tried homeseer/hsthsths3 (wrong password error)
      homeseer/mypw gets in but no luck with permissions

      Found I have to use the sudo command before each copy command and then everything worked.
      Last edited by ocxoman; February 7, 2017, 09:47 PM. Reason: found my solution


        If memory serves, when I had to roll back a Z-Wave plug-in, I ran into this same issue. What I ended up doing was removing the ssd from the SEL box, and plugging it into my computer so I could copy the appropriate files.


          So I too had the same problem while trying to install PHLocation. But I finally figured out an easy solution if you have a Windows machine available.

          This will all be done on your Windows machine.

          First download and install the latest version of putty.

          Then download and install the latest version of WinSCP.

          Then open WinSCP..type the IP address or your SEL machine then username = homeseer and The password you created when setting up the SEL machine.

          Then Click on the open putty session icon in the top left second row of Icons.

          Once putty is open and running.

          Type in sudo passwd root

          It will ask you for you current password. Type in the same password you did earlier.

          Then it will ask you to create a password for ROOT. You can make it anything you like but I kept mine the same as the one I set up for homeseer

          Then it will ask you to verify it. So type it in again.

          When that's done.

          Close the Putty client then close WinSCP.

          Then reopen WinSCP and login with Username = root and the password you just created.

          You now have root access to change any file you would like.

          With WinSCP it's as easy as drag and drop from your windows file over to the SEL device.

          Just becareful to not delete anything important as you now have root access.

          Let me me know how it goes. It fixed my problem and I couldn't seem to find the answer anywhere. Hope it helps out someone else!


            Thanks cass2115, works great