Announcement

Collapse
No announcement yet.

Hometroller Zee keeps timing out

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Hometroller Zee keeps timing out

    Hello All,

    For some reason the past month or so my hometroller has become somewhat unreliable. It will work through the night then when i get home it is shut off.

    Based on the Log it looks like it tried to reboot at 7:17 this morning then just shut off. Any ideas on how proceed would be appreciated.
    Feb-11 4:27:42 PM email Initializing email, found 1527 messages
    Feb-11 4:27:40 PM Plug-In Found plug-in: EasyTrigger, version: 3.0.0.56
    Feb-11 7:17:17 AM Startup Checking for available plug-ins
    Feb-11 7:17:17 AM Info Remote plug-in API interface started on port 10400
    Feb-11 7:17:17 AM Warning Plug-in developer mode is enabled and connection time out is set to 900000 milliseconds.
    Feb-11 7:17:17 AM email Start checking server for email using POP
    Feb-11 7:17:17 AM Web Server Web Server authorized local login successful from: 192.168.0.24 User: Kanker80538
    Feb-11 7:17:17 AM Startup Initializing email, will check server for new email
    Feb-11 7:17:17 AM Web Server Web Server started on port 80
    Feb-11 7:17:17 AM Web Server Local IP address is: 192.168.0.21
    Feb-11 7:17:17 AM Startup This version of HomeSeer is registered as a HS3ZEES2 version.
    Feb-11 7:17:17 AM Startup Creating Speaker Client Interface Object...
    Feb-11 7:17:17 AM Startup HomeSeer version is: 3.0.0.500
    Feb-11 7:17:16 AM Load Config Loading TIMERS...
    Feb-11 7:17:16 AM Load Config Loading COUNTERS...
    Feb-11 7:17:16 AM Load Config 102 total events loaded.
    Feb-11 7:17:16 AM Load Config Loading Events...
    Feb-11 7:17:16 AM Load Config Loading Event Groups...
    Feb-11 7:17:16 AM Database Opening (Mode=Read/Write) up HomeSeer LOG database /tmp/HomeSeerLog.hsd
    Feb-11 7:17:16 AM Load Config 149 total devices loaded.
    Feb-11 7:17:16 AM Database Loading Devices...
    Feb-11 7:17:14 AM Database Opening (Mode=Read Only) up HomeSeer database /usr/local/HomeSeer/Data/HomeSeerData_10.hsd
    Feb-11 7:17:14 AM Startup Loading configuration file ...
    Feb-11 7:17:14 AM Startup Database SAVE process started.
    Feb-11 7:17:14 AM Startup Local voice recognition class started.
    Feb-11 7:17:14 AM Startup Plug-In Interface class started.
    Feb-11 7:17:14 AM Startup E-Mail RECEIVE class started.
    Feb-11 7:17:14 AM Startup E-Mail SEND class started.
    Feb-11 7:17:14 AM Startup Web server class started.
    Feb-11 7:17:14 AM Startup Application interface class started.
    Feb-11 7:17:14 AM Startup COM port classes started.
    Feb-11 7:17:14 AM Startup Creating Class Objects...
    Feb-11 7:17:14 AM Startup
    Feb-11 7:17:14 AM Startup ************************************************************ ********************
    Feb-11 7:17:14 AM Startup HomeSeer version 3.0.0.500 Edition: HS3 ZEE S2 Starting Now
    Feb-11 7:17:14 AM Startup ************************************************************ ********************
    Feb-11 7:17:14 AM Startup
    Feb-11 7:17:12 AM Startup Settings Loaded.



    MESSAGE BOARD (copy/paste section below to message board posts)

    Current Date/Time: 2/11/2019 4:35:01 PM
    HomeSeer Version: HS3 ZEE S2 Edition 3.0.0.500
    Linux version: Linux HomeTrollerZeeS2V2 4.1.19-v7+ #858 SMP Tue Mar 15 15:56:00 GMT 2016 armv7l GNU/Linux System Uptime: 0 Days 9 Hours 17 Minutes 45 Seconds
    IP Address: 192.168.0.21
    Number of Devices: 149
    Number of Events: 100
    Available Threads: 386
    HSTouch Enabled: True
    Event Threads: 0
    Event Trigger Eval Queue: 0
    Event Trigger Priority Eval Queue: 0
    Device Exec Queue: 0
    HSTouch Event Queue: 0
    Email Send Queue: 0

    Enabled Plug-Ins
    3.0.0.56: EasyTrigger
    1.2018.717.1011: MyQ
    3.0.0.31: Nest
    3.0.0.88: weatherXML
    3.0.1.190: Z-Wave

    #2
    Current Date/Time: 2/11/2019 4:35:01 PM
    ...
    ... System Uptime: 0 Days 9 Hours 17 Minutes 45 Seconds
    Doing the math, current time - uptime indicates it's been running since ~ 7:17AM. What make you think it shut off after that?

    Comment


      #3
      None of the events were working when i got home. i did not restart it at 7:17. The log for the previous days is all gone. The sensors are working but none of the events are. WHen I unplug and replug it back in everything starts to work again.

      My guess is that it is timing out or something. I cannot connect to it via the web or FTP when this happens.

      Comment


        #4
        Not being able to connect via FTP makes it sound like a networking issue.

        When you say unplug & replug, do you mean power or network connection? Or are you running wireless?

        Is it possible to connect a monitor & keyboard?

        Comment


          #5
          Power connection. I am connected to the controller via Ethernet cable though a switch.

          Comment


            #6
            So it rebooted on its own at 7:17AM and has been running since then. It is reachable now, since you are able to post the log. Is it running correctly now, and if so has it been running OK since the 7:17 reboot?

            Comment


              #7
              no. it has been running since pulled power at 4:27. It looks to me like it hung up looking for plugins.

              Comment


                #8
                If you pulled power at 4:27 it couldn't have a system uptime of 9 hours 27 minutes at 4:35 ...

                Comment


                  #9
                  Have you looked at the syslog files in /var/log/ , they have more detail than a HS3 log
                  HS3 SEL running Pro Edition 3.0.0.531 on Ubuntu 18.04, mono 5.20, 656 devices, 209 events.
                  Plug-Ins: Chromecast, Device History, EasyTrigger, Ecobee, JowiHue, LutronCaseta, MeiUnifi, PHLocation2, Pushover 3P, SDJ-Health, Sonos, WeatherFlow, weatherXML
                  Scripts: SparkMan's Lock Event, 5 of Jon00 scripts.

                  Comment


                    #10
                    UPDATE: was working last night when i went to bed at 11. Events were working. This morning nothing is working again. Looking at the hometroller the light is Green, the ethernet light is blinking. Sensors are working, seeing the LED's activate on the motion sensors. I switched ethernet ports. changed ethernet cables. tried to use find.homeseer.com to find it. If I cycle power it comes back.

                    Looks like at 1:17 it Timedout. This looks suspicious to me.
                    Feb-12 1:17:18 AM Warning Plug-in developer mode is enabled and connection time out is set to 900000 milliseconds.
                    Everytime i reboot i get this error and dont see the above statement.
                    Feb-12 5:26:38 AM EasyTrigger ERROR System.FormatException: Input string was not in a correct format. at System.Number.StringToNumber (System.String str, System.Globalization.NumberStyles options, System.Number+NumberBuffer& number, System.Globalization.NumberFormatInfo info, System.Boolean parseDecimal) <0x749e0400 + 0x00130> in :0 at System.Number.ParseInt32 (System.String s, System.Globalization.NumberStyles style, System.Globalization.NumberFormatInfo info) <0x749df090 + 0x000eb> in :0 at System.Int32.Parse (System.String s) <0x749aa628 + 0x0001f> in :0 at System.Linq.Enumerable+WhereSelectArrayIterator`2[TSource,TResult].MoveNext () <0x72f66400 + 0x00093> in :0 at System.Collections.Generic.List`1[T]..ctor (System.Collections.Generic.IEnumerable`1[T] collection) <0x74ccb864 + 0x002a7> 25222 in :0 at System.Linq.Enumerable.ToList[TSource] (System.Collections.Generic.IEnumerable`1[T] source) <0x72f66110 + 0x00033> in :0 at HSPI_EasyTrigger.DeviceGroup.SetDevices (System.String devices) <0x7481bd98 + 0x000c3> in :0
                    Let me know how to find the syslog. i dont see it.

                    Thanks for your help

                    Jason

                    Comment


                      #11
                      If you ssh into the box or hookup a keyboard and screen it should be in the /var/log/ directory. Full path would be /var/log/syslog

                      That is if a Zee writes to the Ubuntu standard syslog file? Does anybody know if they changed that?
                      HS3 SEL running Pro Edition 3.0.0.531 on Ubuntu 18.04, mono 5.20, 656 devices, 209 events.
                      Plug-Ins: Chromecast, Device History, EasyTrigger, Ecobee, JowiHue, LutronCaseta, MeiUnifi, PHLocation2, Pushover 3P, SDJ-Health, Sonos, WeatherFlow, weatherXML
                      Scripts: SparkMan's Lock Event, 5 of Jon00 scripts.

                      Comment


                        #12
                        @zwolf pack:

                        The only way i can pull that log is to cycle power on the Zee S2 so i can connect with my computer via the LAN. There should be activity on the controller between 717 and 427. Kinda stuck here.

                        drparker151
                        I will give that a try when I get home tonight.

                        Comment


                          #13
                          Looks like you may have developer mode selected. Let's turn that off first.

                          Go to Plugins->Manage and make sure that Developer Mode checkbox is unchecked.

                          Click image for larger version

Name:	dev-mode.png
Views:	41
Size:	82.3 KB
ID:	1284366

                          Comment


                            #14
                            Once you're logged into the command line, its a good idea to check that you don't have a runaway log file that's filled up the disk. Run this command:

                            Code:
                            df -h
                            Look for any entries with 5th column (Use%) is 100% or close to that.

                            Code:
                            Filesystem      Size  Used Avail Use% Mounted on
                            /dev/root        15G  3.3G   11G  24% /
                            devtmpfs        460M     0  460M   0% /dev
                            tmpfs           464M   40K  464M   1% /dev/shm
                            tmpfs           464M   24M  441M   6% /run
                            tmpfs           5.0M  4.0K  5.0M   1% /run/lock
                            tmpfs           464M     0  464M   0% /sys/fs/cgroup
                            tmpfs           464M   56K  464M   1% /tmp
                            /dev/mmcblk0p1   43M   23M   21M  52% /boot
                            tmpfs            93M     0   93M   0% /run/user/1000

                            Comment


                              #15
                              Next time it locks up, see if it's pingable from another machine.

                              From Windows or Linux,

                              Code:
                              ping <zee ip-address>

                              Comment

                              Working...
                              X