No announcement yet.

Installing HomeSeer to a USB SSD

  • Filter
  • Time
  • Show
Clear All
new posts

    Installing HomeSeer to a USB SSD

    I got a 3B+ to start in Raspbeian directly from a USB Connected 64gb ssd mast card on an 85 usb adapter board. I have HomeSeer loaded into /usr/local/HomeSeer
    I got a fan running in a script on boot and now I am trying to get Homeseer to auto start.
    I can go into terminal and cd to usr/local/HomeSeer and type ./go and homeseer starts and I can get to the web page.
    When I add a new line just above exit 0 in rc.local "/usr/local/HomeSeer/autostart_hs"
    Nothing happens.
    Did I miss something? Is there a linux command that I need to run to finish the install? I unpacked the tar.gz file to /home/ then moved it to /usr/local
    ./go works but autostart_hs just sits there

    Go here : The same may apply.

    TinkerLand : Life's Choices,"No One Size Fits All"


      So I found that I was typing in a lower case y to load mono when it asked Y/n, I really need to take linux commands more literally.
      I responded to both get-apt questions with capital Y and it loaded mono.

      Now I get homeseer to load the webpage and start(Not sure it really works but the webpage comes up,) by typing in the line /usr/local/HomeSeer/autostart_hs
      Now if it would only start on that same line in rc.local.
      My last two lines in rc.local are
      exit 0
      But it wi not autostart


        So I had a script in front of the homeseer script. I tried moving my fan script to after and moved autostart script to inside rc.local and it worked a treat!!!!
        like this; (Now I wonder if my fan script is working?)

        #!/bin/sh -e
        # rc.local
        # This script is executed at the end of each multiuser runlevel.
        # Make sure that the script will "exit 0" on success or any other
        # value on error.
        # In order to enable or disable this script just change the execution
        # bits.
        # By default this script does nothing.
        # Print the IP address
        _IP=$(hostname -I) || true
        if [ "$_IP" ]; then
        printf "My IP address is %s\n" "$_IP"

        export LANG=en_US.UTF-8
        cd /usr/local/HomeSeer
        mono HSConsole.exe

        sudo python /home/pi/CpuFan/

        exit 0


          So I gave up on the pi and went with a RockPi4A and a 32gb emmc instead of a USB msata ssd. M.2 is next.