Announcement

Collapse
No announcement yet.

Changing out a failed Zee S2

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Changing out a failed Zee S2

    I could use some expert help on this one.

    I am trying to understand the process to use to move my network from a failed S2 to a new S2 controller. I have a current backups from the failed unit with the ZW plugin disabled. I also have a backup with the ZWave plugin enabled. The restore with ZW plugin disabled, loads with the ZW off in new S2 As I understand, I do the following:

    1. Remove power from the old Zee S2 to insure it is not active on the network.
    2. Attach a Keyboard and Monitor to the new S2 and boot it up.
    3. Install updates and plugins
    4. Restore the current backup(with ZW Off) that came from the now failed S2 to the new S2.
    5. When the new S2 reboots after the restore completes, do an "r' reset of the network settings at the bootup pause to move the new S2 to DHCP IP to avoid having both S2s ending up of the same IP address.
    6. In the setup menu on the HS app, change the license information from that of the failed S2 to that of the new S2 controller
    7. Verify that the device list and events are complete.
    8. Enable the ZWave plugin.

    At this point in the process, the questions take over. My questions are as follows:

    1. Will the node info get loaded even with the ZW plugin disabled?
    2. Will the new S2 be set as the primary controller on Node 1 or will it default to secondary controller status?
    3. Is there any additional procedures that will need to be performed on the ZWave interface such as: Import and Scan, Full Scan, Re-include, etc.
    4. Will battery powered nodes need special treatment? 17 of my 50 nodes are battery powered.
    5. Will the node Association settings get linked to the new S2 controller?

    This became an important issue for me recently when my S2 continued to run the ZW network but refused to be contacted using any of the several HS Tools. It was purchased in early 2016. The backup from the now failed S2 loaded into the new S2 but all the IF statements were missing from the events and would not allow editing of the events. I concluded that all of the several backups I had were probably corrupted and had to completely manually rebuild all 50 nodes and reprogram all 188 events to get my automation back which was not fun. The factory reset that HS support recommended I do on the old S2, bricked the unit. It would perform the factory reset but displayed errors on some of the file loads during the boot. It would boot up Linux but not start the HS app. Not being the type to give up, I re-flashed(several times) the SD card, and also replaced the card. After the re-flash, it boots up once and bricks when rebooted. The re-flash actions also deleted the factory reset capability that was in the original Linux load. My conclusion is that either the unit takes a Linux version no longer available or it has suffered a failure most likely related to the network interface area. It shows up as on-line in the router IP list but refuses all contact. I would greatly appreciate comments on my questions - Thanks.

    #2
    I have the same problem. Getting ready to install new Zee S2, but I read your post and you are more advanced than I am in this process.Any way we can excahgne numbers and talk?

    Comment


      #3
      Having done a lot of testing, I wanted to provide and update which should answer the questions I raised.

      I have Three S2s. I bought the third one because it appeared that the original unit failed. I had to manually rebuild my network and re-create all the events because my backups from the 84xxx controller(V1), which was the one that failed, seemed to be corrupted. I have since recovered that S2 by copying a V6 image from one of my new units and re-flashing that image to the old V1. I had to upgrade it to a 16Gb Sd to do this. First the best procedure for moving your network to a new S2:

      1. Since there are issues with how the S2 handles port changes, it is best that you start with your source system set to DHCP for its IP settings.
      2. Go to the Manage Plugins-Zwave Controller Management-ZWave interface menu and select the Backup this interface option. This will backup up your node list which resides in the ZWave daughter board on the S2.
      3. Go to Tools-Setup an perform a backup of your HS3 configuration. Note this backup zip file will include the ZWave node backup as long as you did the ZWave backup first.
      4. Power down your source S2 if it is powered up or disable the ZWave interface to keep it disconnected from your ZWave network.
      5. Log in to your target system. and clear it of all previous data by:
      a. Go to devices list and click the small box at the top to select all entries and then select delete in text box and delete all entries in the devices list
      b. Go to the Events page and select the small red X at the top of the page and delete all the events in the event list.
      c. Go to the Manage-Zwave-Controller Management-Zwave menu and select the Erase this network choice to erase your node list.
      6. The above 3 actions will have cleared all data from the devices, events, and ZWave Node list that may have been there from a prior configuration.
      7. Now go to Tools Setup and Click on the Restore button and browse to the backup file you want to restore and start the restore. It will take a few minutes and will show the loading progress next to the Restore button in the Tools Setup area. Wait until it reports that it is done.
      8. Go to the Manage ZWave Controller Management ZWave interface menu and select: Restore a network to this interface and select the newest entry in the list which is probably at the bottom of the list of backup files shown. It take maybe 15 seconds to fully load this into your zwave node list.
      9. Your system should be ready to run your network. Since the source S2 and the target S2 now can control the same network, do allow them to be enabled at the same time.

      The above procedure worked fine with the tests I ran to verify it. The only issue I had is that group 2-5 associations that my Wallmote Duo Switch uses did not configure but that was easy to correct.

      That is how it is supposed to work. I just thought I had a corrupted original backup from the S2v1(early 2016 84xxx series) which caused me to have to manually re-enter all of my network configuration until yesterday when a friend who has multiple S2s(one V1, three V6) called and was planning to update his V1 to a V6 by using an image copy from one of his V6s.

      It seems his V1(also an early 2106 84xxx series) based backup produced the same results as I had experienced which included seemingly assigning the nodes to a different network and corrupting the events and not allowing edits to be performed to correct any events. it was these issues that caused me to post my original post on this topic.

      I have since tested using a backup of my newly recreated network(created on a V5-125xxx series that was factory reset to V2) and it restored fine using the above procedure on both the V2 and the V6 unit. I have since re-flashed the v2 to a V6 and that restore also works fine.
      Given these two independant experiences which produced almost identical corrupted results, I have to conclude that backups produced by V1 S2s are probably not compatible with V2 through V6 systems,

      Comment

      Working...
      X