Announcement

Collapse
No announcement yet.

Startup error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Startup error

    I just noticed that I am getting this error in my HS log at startup.
    Jun-01 15:04:25 Error Compiling script Startup.vb: Error running vbnc: Cannot find the specified file

    Is that something I need to investigate or be concerned about?
    Malcolm

    #2
    With that error, you will not be able to run any scripts. Looks like a repair of mono is required.
    Jon

    Comment


      #3
      I think it means the Startup.vb file is missing - I could be wrong though...
      HS4Pro Running on a Raspberry Pi4
      68 Z-Wave Nodes, 175 Events, 359 Devices
      UPB modules via OMNI plugin/panel
      Plugins: Z-Wave, OMNI, HSTouch, weatherXML, EasyTrigger
      HSTouch Clients: 3 Android, 1 Joggler

      Comment


        #4
        Originally posted by jon00 View Post
        With that error, you will not be able to run any scripts. Looks like a repair of mono is required.
        I went through a mono re-install using this https://helpdesk.homeseer.com/articl...date-to-mono-5 and confirmed it was successful.

        Unfortunately, I'm still getting the start up message.
        Malcolm

        Comment


          #5
          Originally posted by rmasonjr View Post
          I think it means the Startup.vb file is missing - I could be wrong though...
          Is this the file?
          Click image for larger version

Name:	Annotation 2020-06-01 174306.png
Views:	36
Size:	22.6 KB
ID:	1390301
          Malcolm

          Comment


            #6
            I don't believe I have ever edited this so it must be "as installed"?
            Attached Files
            Malcolm

            Comment


              #7
              Verify vbnc package is properly installed:

              Code:
              dpkg -V mono-vbnc
              This only outputs problems. No output indicates all good.

              Comment


                #8
                from the prompt, just type vbnc you should get some compiler response
                HS4Pro Running on a Raspberry Pi4
                68 Z-Wave Nodes, 175 Events, 359 Devices
                UPB modules via OMNI plugin/panel
                Plugins: Z-Wave, OMNI, HSTouch, weatherXML, EasyTrigger
                HSTouch Clients: 3 Android, 1 Joggler

                Comment


                  #9
                  Originally posted by zwolfpack View Post
                  Verify vbnc package is properly installed:

                  Code:
                  dpkg -V mono-vbnc
                  This only outputs problems. No output indicates all good.
                  it returns


                  homeseer@HomeTrollerZeeS2V2:~ $ dpkg -V mono-vbnc
                  dpkg: package 'mono-vbnc' is not installed
                  Malcolm

                  Comment


                    #10
                    Originally posted by MalcolmS View Post

                    it returns


                    homeseer@HomeTrollerZeeS2V2:~ $ dpkg -V mono-vbnc
                    dpkg: package 'mono-vbnc' is not installed
                    Well there you have it - that's required.

                    Code:
                    sudo apt-get -y install mono-vbnc

                    Comment


                      #11
                      perfect, thank you
                      Malcolm

                      Comment

                      Working...
                      X