Announcement

Collapse
No announcement yet.

How To Configure HomeTroller Zee for Multi-Protocol (Z-Wave / X10) Operation

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    How To Configure HomeTroller Zee for Multi-Protocol (Z-Wave / X10) Operation

    Steps to initialize Z-Wave and X10 on a Hometroller Zee

    PROBLEM: HomeTroller Zee includes an automatic port assignment function that's designed to simplify setup for users with a single protocol system (Z-Wave or X10). However, users with a multi-protocol system (Z-Wave and X10) may experience port assignment problems if the Z-Wave or X10 interfaces are detached and reattached to/from the system before being fully configured. If you have a multi-protocol system, follow the configuration steps below to ensure proper port assignment.

    SOLUTION
    1. Navigate to the PLUG-INS > Z-Wave > Controller Management page and disable the Z-Wave interface. If there is a white button with a green checkbox at the top of the area, click it. If there is a yellow button with a red circle, no action is needed.
    2. Navigate to the PLUG-INS > Manage page and disable the X10 and Z-Wave plug-ins.
    3. Detach the X10 and Z-Wave interfaces from your HomeTroller Zee. Leave these detached until prompted to reattach below.
    4. Navigate to the TOOLS > System > Restart System page and click the [Restart...] button to restart your HomeTroller Zee.
    5. After the Zee has fully booted, attach the X10 interface cable to one of the USB ports. Navigate to the PLUG-INS > Manage page, select the available port and enable the X10 plug-in. Test the X10 plugin by creating an X10 device in the device management page.
    6. If X10 testing was successful, navigate to then PLUG-INS > Manage page and enable the Z-Wave plug-in. NOW, attach to Z-Stick to the remaining USB port. The system will reboot and assign a port to the ZStick.
    7. Once the box has restarted, navigate to PLUG-INS > Z-Wave > Controller Management page and click the yellow button with the red crossed circle to enable the Z-Stick interface.

    At this point, both interfaces should be properly connected and fully functional.
    Note: To avoid future port assignment problems, do not disconnect the X10 interface cable.
    Learn About HomeSeer

    #2
    X10 and Zwave Procedure Startup

    The setup procedure recommended for X10, Zwave and a T103 works for me if followed exactly and the T103 choice is made. However, if I do a power boot or remove the Zstick for a new Zwave device addition, which starts a reboot, the Zee defaults back to the CM11A choice and there is an X10 device fatal error. The error can be corrected by going back and re-setting the Zee to the T103 again. Nothing is lost but any sort of reboot will require the reset all over again. I hope this Zee behavior can be corrected with a firmware update soon since any power failure will cause the X10 operation to fail.

    Comment


      #3
      Originally posted by zeronsawp View Post
      The setup procedure recommended for X10, Zwave and a T103 works for me if followed exactly and the T103 choice is made. However, if I do a power boot or remove the Zstick for a new Zwave device addition, which starts a reboot, the Zee defaults back to the CM11A choice and there is an X10 device fatal error. The error can be corrected by going back and re-setting the Zee to the T103 again. Nothing is lost but any sort of reboot will require the reset all over again. I hope this Zee behavior can be corrected with a firmware update soon since any power failure will cause the X10 operation to fail.
      Please put in a bugzilla bug ticket on this issue.
      homeseer.com/bugzilla/
      -Rupp
      sigpic

      Comment


        #4
        The next update should take care of revert to the CM11A.
        Wade

        sigpic

        website | products | support | youtube
        I know nothing...., nothing!!!

        Comment


          #5
          USB port ?

          New to this. On initial setup for x10 interface can't find proper port assignment in dropdown list. Please help.

          Current Date/Time: 12/14/2017 8:15:40 AM
          HomeSeer Version: HS3 ZEE Edition 3.0.0.368
          Linux version: Linux HomeTrollerZEE 3.10.25+ #622 PREEMPT Fri Jan 3 18:41:00 GMT 2014 armv6l GNU/Linux System Uptime: 0 Days 13 Hours 22 Minutes 23 Seconds
          IP Address:
          Number of Devices: 0
          Number of Events: 0
          Available Threads: 99

          Enabled Plug-Ins
          3.0.0.4: CM15A
          3.0.0.36: X10

          Comment

          Working...
          X