No announcement yet.

How To Display 24 Hour Time in HomeTroller Zee

This is a sticky topic.
  • Filter
  • Time
  • Show
Clear All
new posts

    How To Display 24 Hour Time in HomeTroller Zee

    On the Zee, Zee S2, and SEL, you can make a change so HS3 displays times in 24 hour format.

    To ensure that HS uses the 24 hr time format:
    1. SSH to your unit, log in, then go to the HS folder with:
    2. cd /usr/local/HomeSeer
    3. Now edit the autostart_hs file, the file contains the locale that the unit will run under, the first line is:
    4. export LANG=en_US.UTF-8
    5. Change this line to the locale you want to use, 24 HR time will be displayed if you set it to:
    6. export LANG=en_GB.UTF-8
    7. You can edit the file with the command:
    8. sudo nano autostart_hs
    9. After making the change, type CONTROL X to save and exit.
    10. Reboot the unit and HS will now display times in 24 hr format.

    Note, on the Zee and Zee S2 you may need to generate the locale you want to use (GB is already there). Run the following command to enter a tool where you can generate new locales:

    sudo raspi-config

    Select the "Internationalisation" option to select the locale you want to generate.
    website | buy now | support | youtube

    LANG=nb_NO.UTF-8 = Norway
    Certified installer for HomeSeer, Control4, KNX and Eaton/xComfort


      And when you start to get problems with sunset and sunrise after any adjustment above and live in a county with metric system, please remember that US is using decimal point instead of decimal comma as in the metric system.

      The drop down list with different timezons is still in US and not metrics.

      So to get this working, select the correct timezone, and go to manual and change to DECIMAL COMMA!!!


        Maybe that works in Hometroller but I cannot get it to work on a Linux box with either Mint 18 or Ubuntu 16.
        I tried about a dozen European locales, none works.
        Any ideas?