Announcement

Collapse
No announcement yet.

Zwave Device "Unknown" Status

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Zwave Device "Unknown" Status

    When a zwave deice goes into unknown status I clicked on the Advanced tab to look at the status value and it either says On or Off with a value of either 0, 100 or 255. How does HS know the device is unknown and what is the value of this device? Why does it stay on or off in the advanced tab?

    Thank you

  • #2
    It is a flag (DeviceInvalidValue) in the device that is not shown. It can be cleared with
    Code:
    &hs.DeviceInvalidValue(xxxx) = False
    where xxxx is the RefID of the device showing Unknown.
    Randy Prade
    Aurora, CO
    Prades.net

    PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

    Comment


    • #3
      I get unknown when a device can't be reached. Usually a plugin device and the socket has been switched off.

      Comment


      • #4
        Originally posted by rprade View Post
        It is a flag (DeviceInvalidValue) in the device that is not shown. It can be cleared with
        Code:
        &hs.DeviceInvalidValue(xxxx) = False
        where xxxx is the RefID of the device showing Unknown.
        Can an event be triggered if the flag becomes True?


        Michael

        HS3 Pro 3.0.0.470 | 849 devices | 349 events | OpenSprinkler | BLShutdown | EasyTrigger | NetCAM | Harmony Hub | Sonos | SDJ-Health | BLUPS | PHLocation | BLBackup | BLLock | Z-Wave 3.0.1.243 | weatherXML | Pushover 3P | Blue-Iris | AirPlaySpeak

        Comment


        • #5
          There are no event triggers that would see that flag. It might be possible to run a script on a recurring trigger.

          EDIT: There is a trigger for "An Invalid or Error State" for Z-Wave devices. This may work.
          Last edited by rprade; August 25th, 2018, 06:19 PM.
          Randy Prade
          Aurora, CO
          Prades.net

          PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

          Comment


          • #6
            Originally posted by rprade View Post
            There are no event triggers that would see that flag. It might be possible to run a script on a recurring trigger.
            I've never used this, but your comment made me recall there is a trigger for "changes and becomes an INVALID/ERROR state." I have a Z-Wave door lock that has issues on a frustratingly frequent basis and ends up showing "Unknown", so I'm going to try this...

            Comment


            • #7
              Originally posted by shill View Post

              I've never used this, but your comment made me recall there is a trigger for "changes and becomes an INVALID/ERROR state." I have a Z-Wave door lock that has issues on a frustratingly frequent basis and ends up showing "Unknown", so I'm going to try this...
              I forgot that was there. It is only on Z-Wave devices, so it should work. If I remember correctly, I tried to use it 3 or 4 years ago when I had a Z-Wave switch module in the garage that was going to Unknown status and it never triggered.

              Let us know if it works for you.

              Randy Prade
              Aurora, CO
              Prades.net

              PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

              Comment


              • #8
                Originally posted by rprade View Post
                There are no event triggers that would see that flag. It might be possible to run a script on a recurring trigger.

                EDIT: There is a trigger for "An Invalid or Error State" for Z-Wave devices. This may work.
                I have tried the event trigger "An Invalid or Error State", but for me it does not work. It does not trigger when the device changes to status unknown. Would be good if it did, you can send a notification so you know there is a problem...

                Comment

                Working...
                X