Announcement

Collapse
No announcement yet.

Newbe getting HS3 going is not easy

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Newbe getting HS3 going is not easy

    Hi there, I have run into a problem getting HS3 going on a very average WIN10 box.

    Here is the error log from the initial HS3 startup screen:

    28-11-2018 20:26:19 ~!~Warning~!~Error starting web server, port in use? Are you running a web server on the designated port? Edit settings.ini in the Config folder and change gWebSvrPort=## to a different port #. Det blev forsøgt at få adgang til en socket på en måde, der er forbudt af den pågældende sockets adgangstilladelser
    Startup Complete, 1 errors detected, check the log for more information.

    Part of the text is in Danish, saying that there was an atemt to access a socket in a way that was not alowed by the socket accessaproval.

    After reaching out to tech support, who asked if I had tried to change the port number, like described.. Frankly I had not tried anything as I was expecting 600USD worth of software to just at least launch without any problems... Anyway, I tried to look in the settings.ini file and here is what it contains:
    [Settings]
    gLastShutdownOK=False
    gFirstTimeRun=False
    gConfigFilename=HomeSeerData.hsd
    gLocLabel=Room
    gLocLabel2=Floor
    bUseLocation2=True
    bLocationFirst=False
    gLongitude=71.03
    gLatitude=42.22
    SADProc=True
    gLastRunVersion=3.0.0.435
    [Display]
    gSelectedGroupWeb=All Groups

    Like you see it does not even contain the line gWebSvrPort=##

    I was expecting to see a bunch of other user posts about this problem but I see none, am I really the only one who faced this problem? My windows version is quite unused/new upgraded with upgrade version1809 and is running very stable.




  • #2
    Are you running another webserver on this box? Something is using port 80 which is what HS3 is complaining about.

    Comment


    • #3
      See this post:
      https://forums.homeseer.com/forum/ho...er-port-errors
      Mike____________________________________________________________ __________________
      HS3 Pro Edition 3.0.0.548

      HW: Stargate | NX8e | CAV6.6 | Squeezebox | PCS | WGL 800RF, Rain8Net+ | RFXCOM | QSE100D | Vantage Pro | Green-Eye | X10: XTB-232, -IIR | Edgeport/8 | Way2Call | Ecobee3

      Comment


      • #4
        I will add that most Windows 10 installs end up with the "World Wide Web Publishing Service" enabled which occupies port 80. Read this thread. It is really not HomeSeer's fault that Windows does stupid things like this There is no need for Windows to enable this service unless the IIS role is installed. It would be easier to disable the service than to move HomeSeer to a nonstandard port.
        Randy Prade
        Aurora, CO
        Prades.net

        PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

        Comment


        • #5
          Originally posted by rprade View Post
          It is really not HomeSeer's fault that Windows does stupid things like this
          While true, and I agree, I think this is an example of an opportunity for HST to supply context help - a pop-up window, perhaps? - to guide new users past a common nuisance problem when installing HS for the first time.

          Mike____________________________________________________________ __________________
          HS3 Pro Edition 3.0.0.548

          HW: Stargate | NX8e | CAV6.6 | Squeezebox | PCS | WGL 800RF, Rain8Net+ | RFXCOM | QSE100D | Vantage Pro | Green-Eye | X10: XTB-232, -IIR | Edgeport/8 | Way2Call | Ecobee3

          Comment


          • #6
            Absolutely. While this conflict is easy to overcome for many of us who understand ports and web servers, the vast majority of users will not have such knowledge. When I say it is not HST's "fault", I do believe they should take some actions to help a user become aware of the issue and steps they might take.

            Preferably during installation and definitely at startup there should be a check that the standard HTTP port is open and if it is not, there should be some sort of mechanism to provide clear notification of the problem. If I was asked what to do, I would have the program present a popup at startup with the notification that the standard port is unavailable, offering an alternative port and the ability for the user to pick his own. The popup would explain that some other service on the computer is using port 80, "would you like HomeSeer to configure for port 81 (this would be a text box prompting you to enter a port) or would you like to shutdown (or stop installation) and stop the service to free port 80. At the bottom there would be a hyperlink for help linking to a page on the HomeSeer website. This page would explain the steps to check for what is occupying the port and some suggestions of the usual culprit.

            But that is just how I would handle it.
            Randy Prade
            Aurora, CO
            Prades.net

            PHLocation - Pushover - EasyTrigger - UltraECM3 - Ultra1Wire3 - Arduino

            Comment


            • #7
              Thanks guys for all your helpfull inputs.

              I could not figure how to stop win10 using port 80, so ended up changing to another port in HS3. I'd like to comment rprade for his opinion in post #6. What you described was exactly what I was expecting and needed. Setbacks is not what the smarthome world needs. (in order to not scare everyone away. :-) By everyone I'm thinking of all those that sort of like the idear of a smart home, but lacks time and/or will to fiddle with wired stuff like changing win10 ports, using commandline scripst. :-))

              Kind regards Kasper

              Comment

              Working...
              X