Announcement

Collapse
No announcement yet.

Simple program doesnt always run when it is supposed to.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Uncle Michael
    replied
    Originally posted by MichaelV View Post
    I am trying to control a thermostat with an insteon dimmer switch. . . .look at what I wrote but it does not work. Any suggestions?
    I have no experience with either Insteon or the Honeywell plug-in, so there are probably many ways this could fail that I'm not aware of. When you say it does not work, what do you see? Do the events not trigger or do they trigger, but the set point doesn't change? Something else? Any errors in the log?

    Leave a comment:


  • MichaelV
    replied


    Hey Uncle Michael,

    would you have a look at this one? I am trying to control a thermostat with an insteon dimmer switch. When I go up to my office on my third floor, I would like to be able to set my thermostat to 68 by turning the lights over my desk on by turning them on to 100% and then write another program to turn the heat down when I switch the lights down to 0%. look at what I wrote but it does not work. Any suggestions?

    Thanks!!

    Click image for larger version

Name:	heat with light switch.png
Views:	26
Size:	122.7 KB
ID:	1286225
    Click image for larger version

Name:	stop heat with light switch.png
Views:	21
Size:	123.2 KB
ID:	1286226

    Leave a comment:


  • MichaelV
    replied
    Thanks, that was the problem.

    Leave a comment:


  • sparkman
    replied
    Originally posted by MichaelV View Post
    Hi Michael, I went to edit my programs the way you said and the tools on the far right hand side of the screen are missing so I can't edit them. Any ideas what is going on? I restarted my hometroller and still no tools.
    Try using any other browser other than IE or Edge. Chrome, Firefox, etc. should all show them.

    Leave a comment:


  • MichaelV
    replied
    Hi Michael, I went to edit my programs the way you said and the tools on the far right hand side of the screen are missing so I can't edit them. Any ideas what is going on? I restarted my hometroller and still no tools.

    Leave a comment:


  • MichaelV
    replied
    Thanks Michael, I have read Randy's thread. I'll try what you suggest.

    Leave a comment:


  • Uncle Michael
    replied
    First, I'd highly recommend that you read Randy's excellent description of event triggers and conditions in the Event Clinic'
    I'd also suggest using a delayed event action to turn your flag off. A six hour wait is going to tie up a thread for a long time, and it may not be reliable. (I've never tried a wait that long.)
    You should also change the first trigger to be the zone change, not the flag state, then add the condition that the flag is on to each of the OR IF triggers. As written the flag state only pertains to the first item.
    So,
    If zone 1 opened
    And If Flag is on

    OR IF zone 2 opened
    And IF Flag is on

    OR IF zone 3 is opened
    And If Flag is on

    Leave a comment:


  • MichaelV
    started a topic Simple program doesnt always run when it is supposed to.

    Simple program doesnt always run when it is supposed to.

    I have what I think is a simple program to adjust my thermostat when I get up in the morning. Some times it works, and sometimes it doesn't work. I have a virtual flag turn on at 4am and then off 6 hours later. Then, I have a program that will adjust the thermostat if one of three motion detectors sense motion while the 4am flag is on. The program last ran today at 2:14pm. how can that be if the 4am flag was off? Is there a better way to write the program??
    Attached Files
Working...
X