Announcement

Collapse
No announcement yet.

Homeseer restart causing me to lose all ZNET information

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Homeseer restart causing me to lose all ZNET information

    Every time I restart Homeseer, the ZNET (I have two) get reset to new HomeID's and I lose all my node information.
    I have the node information saved, but it doesn't want to restore.

    I am not too sure what is going on...if someone could point me in the right direction I would be grateful.

  • #2
    I can rescan the znet and the nodes will get rediscovered, however, I lose all the node naming/floor/room information.

    And all the motion sensors (on battery) don't get rediscovered.

    Completely lost on how to restore a system

    Comment


    • #3
      That does seem strange. Perhaps if you shared some specifics it might be possible to lend some assistance. For instance, what OS/versions are you running and how exactly are you performing the restart.

      Comment


      • #4
        Using Win 10
        I have 2 ZNETs
        Click image for larger version

Name:	find.JPG
Views:	101
Size:	106.2 KB
ID:	1313410

        I have used the reset plugin
        - whenever I add in the ZNET it adds a bunch of different homeid's -- I can delete these (multiple times) and eventually it gets the correct homdID for the ZNET
        - I can 'import node information and scan controller' to get the nodes back onto each ZNET - but they are labeled - node2,3,4,5...and all the other information is gone
        - the events that were associated with the named nodes are also gone

        Comment


        • #5
          I have tried the restore znet per the instructions
          - restore network to this controller using the file I had saved
          - the run the test node - but no nodes are detected

          - If I run a light (or full) scan the nodes get added, but none of the names are added

          Comment


          • #6
            Wasn't there an update in a the z-wave plug-in that fixed the re-start issue that you're having?

            Comment


            • #7
              Not that I have seen.

              It has totally screwed my system.

              Can't even restore things.

              Comment


              • #8
                I'm using 6 Z-Nets, and I have had this issue in the past occasionally. I can usually track it back to a Z-Net being momentarily assigned a new IP address by the router before it negotiates to the assigned fixed IP address.

                Basically what i think is happening is the Z-Wave controller sees the new IP address and thinks it is a new Z-Net on the system (even though this not supposed to happen according to HS). That's why you can't restore to it, because the controller believes you would be creating a dupe HomeID and nodes that already exist on the network.

                Here's a few things to try:

                1) Check your Z-Wave.ini file (located under Homeseer HS3 > Config) and scroll down to the list of HomeIDs. If your Z-Nets are connected by LAN and you also have a wireless network, you should have 4 HomeIDs in the list (2 for the Z-Net LAN connections, and 2 for the Z-Net wireless connections). If you are solely on wireless or solely on LAN, then there should only be 2 HomeIDs listed.

                2) Assign fixed IPs to each Z-Net in your router settings. If you have both wireless and LAN connections to the Z-Nets, assign fixed IPs to each connection type.

                3) Once fixed IPs are assigned (and assuming you are using a LAN connection for the Z-Nets), navigate to the Z-Net settings under "Controller Management", choose "Ethernet Interface" under "Interface Model", and then hard-code the fixed IP address for each of the Z-Nets.

                Click image for larger version

Name:	zwave.png
Views:	92
Size:	41.5 KB
ID:	1313508

                Hopefully this will help keep your Z-Nets stable each time HS or the Z-Wave plugin is restarted.

                --Barry

                Comment


                • #9
                  The IP address is the same and has been consistent - it is DHCP on the ZNET device, but I have reserved the address on the router side. Both are wired connections.

                  Comment


                  • #10
                    Does the error occur every time it restarts or just sometimes? And if every time, does it also also happen when HS is stopped from the UI (clicking on X in upper right corner)?

                    What is the Z-Wave plugin version ?

                    Any errors in the log?

                    Comment


                    • #11
                      Originally posted by bills.hancock@gmail.com View Post
                      The IP address is the same and has been consistent - it is DHCP on the ZNET device, but I have reserved the address on the router side. Both are wired connections.
                      Curious as to why the DHCP server on the ZNET device and not the router? Are you running multiple DHCP servers?

                      Comment


                      • #12
                        So I have the ZNET radio button set to allow the address to be assigned by the router and then I use the router to then reserve that address for the devices.

                        I will see if I can get any error logs and post them

                        The sequence that led up to this event started with z-tools. I was trying to pair a Sensative Strip, but the z-tools would not connect with Homeseer. I have run into this problem in the past and simple reset would get things up and running. When I ran the reset this time, all the node information from both z-nets was gone. I had just saved each of the znet profiles a few hours prior. When I tried to restore the znet to the controller Homeseer would create multiple new HomeID's wiht no associated nodes. I would delete all the new HomeID's and eventually get back to the correct HomeID.

                        When using the 'test node connectivity on a network' drop down option it would give me an error - no nodes on the system. If I 'scan existing devices (light)' the majority of the nodes would repopulate, but all the node names would be lost.

                        I have tried to reset multiple times -- in order to clear the system I have deleted the nodes listed under devices, removed the ZNET's, and even reset one of the ZNETs back to factory settings (using the ERASE this interface and create a new network). Still has the same problem with re-acquiring the node information. As a result of the lost names, my events have also been erased/lost/misplaced.

                        Comment


                        • #13
                          I guess I need a lot more help...I repaired all my nodes including battery motion sensors. Set up a few events.

                          I used the RESTART pluggin to restart Homeseer and when the system rebooted everything was gone except my ecobee thermostat.

                          I had backed up each znet and homeseer. I would run the restore function from the znet and it add information, but it would not find any nodes. I had to run a light scan. After the light scan the nodes were all there, but none of the names and all the events were lost.


                          Can anyone help me at least to a restore properly...this is killing me

                          Thanks

                          Comment

                          Working...
                          X