Announcement

Collapse
No announcement yet.

Where did I go wrong?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by ericg View Post
    JLehnert , your screenshots show that your events are invoking Options, but you don't say what they are. Is it possible that any of your selected options may be relevant to your problem?
    Not that I can see. Pretty much the only two options I use are "Power Fail Recovery" and "Do Not Log". In the case of the event that wasn't working, it was only "Do Not Log".
    My system is described in my profile.

    Comment


    • #17
      This won't solve your problem, but it may offer a clue to another investigator.

      Trying to replicate your event failure, I created the following event, modelled after the one in your post #4:

      Click image for larger version

Name:	2019-10-16_16-29-43.jpg
Views:	47
Size:	97.6 KB
ID:	1333553

      By manually incrementing and decrementing TestCounter on the Global Variables, Timers, & Counters page, I triggered the event reliably every time it decremented to zero. So I gave up.

      I came back and hour or so later, thinking about the issue some more. I reran the same test, just incrementing and decrementing TestCounter. This time, however, the event would not execute when TestCounter reached zero. I tried decrementing to zero 3 times, and the event simply would not trigger. This is the unmodified event that had run as expected just an hour or so earlier!

      On a hunch, I rebuilt just the trigger (IF) part of the event by resetting its parts to exactly the same thing. Result: decrementing counter to zero triggered the event every time.

      So, I don't know what to make of this. I would especially like to resolve this because I think I may have tripped over this one previously -- though details presently escape me.

      Comment


      • #18
        Yeah. For me it worked every time I manually changed the value using the Global Variables page, but it failed every time I had an event modify it.

        Uncle Michael suggested reworking it so the counter comparison was a condition instead of a trigger, and that seems to be working. Like you though, I'd like to know if it's a bug, a known system limitation, or incorrect understanding on my part.
        My system is described in my profile.

        Comment

        Working...
        X