Announcement

Collapse
No announcement yet.

Event Logic Help

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Event Logic Help

    Having an issue here. If the garage door is closed and "Gdoor1 open no motion" is triggered, the icon will not change. It will only change if it sees motion and then "Gdoor1 open motion" fires and icon changes. It is not executing "Gdoor1 open no motion" Likewise if I close the garage door the Icon will not change from event Gdoor1 open no motion The icon will only change if it sees "Gdoor1 closed motion."

    Click image for larger version

Name:	Capture.JPG
Views:	88
Size:	73.7 KB
ID:	1373016Click image for larger version

Name:	Capture1.JPG
Views:	75
Size:	78.8 KB
ID:	1373017Click image for larger version

Name:	Capture2.JPG
Views:	78
Size:	78.9 KB
ID:	1373018Click image for larger version

Name:	Capture3.JPG
Views:	73
Size:	67.7 KB
ID:	1373019Click image for larger version

Name:	Capture4.JPG
Views:	74
Size:	46.0 KB
ID:	1373020

  • #2
    Am not so sure about this but change your numbers from 0,10,20 and 30 to 0,1,2,and3 respectively because of the discrepancies between them. (Don't take my word for this but try)


    Eman.
    The People's Advocate.

    Comment


    • #3
      Originally posted by Spudjr View Post
      If the garage door is closed and "Gdoor1 open no motion" is triggered, the icon will not change. It will only change if it sees motion and then "Gdoor1 open motion" fires and icon changes. It is not executing "Gdoor1 open no motion" Likewise if I close the garage door the Icon will not change from event Gdoor1 open no motion The icon will only change if it sees "Gdoor1 closed motion."
      Have you confirmed that the value changes as expect? That is, the value changes, but the icon does not?

      Mike____________________________________________________________ __________________
      HS3 Pro Edition 3.0.0.548

      HW: Stargate | NX8e | CAV6.6 | Squeezebox | PCS | WGL 800RF, Rain8Net+ | RFXCOM | QSE100D | Vantage Pro | Green-Eye | X10: XTB-232, -IIR | Edgeport/8 | Way2Call | Ecobee3

      Comment


      • #4
        Eman
        Thanks for the suggestion but no luck

        Comment


        • #5
          Uncle Michael
          The device page for my garage door is showing open and close. Working correctly.
          The virtual Device value is not changing when i close the door. Only changes if i close the door and have motion. No log entry when i just close the door from the Event "Door1 close no motion" etc

          Comment


          • #6
            This just got complicated I dug up some dirt here : https://forums.homeseer.com/forum/homeseer-products-services/system-software-controllers/hs3-hs3pro-software/hs3-hs3pro-discussion/110151-updating-status-only-device-with-event looks like related and also compare notes with this : https://www.youtube.com/watch?v=6mamsNIfeEc


            Eman.
            The People's Advocate.

            Comment


            • #7
              My virtual device does not have "Status Only Device" ticked. Wanted the buttons so I can check that I had the correct icons for the different states. Thanks for digging

              Comment


              • #8
                What happens when you drag (swap) the motion detector below "Bettys Door" on every event? There may be a lost in translation for what is being tracked! (Again don't take me hostage on this one either!)


                Tip :Often times events misbehave when not collapsed (save state)


                Eman.
                The People's Advocate.

                Comment


                • #9
                  If I swap the order than the motion does not toggle but the door does. Just the opposite

                  Comment


                  • #10
                    I would create a manually triggered event to set the value of the virtual device. Run the test event and see if the values are changing as expected. If not you have a problem in the virtual device. You didn't show the icons part of the virtual device. Are these created and set?

                    Comment


                    • #11
                      Originally posted by AllHailJ View Post
                      I would create a manually triggered event to set the value of the virtual device. Run the test event and see if the values are changing as expected. If not you have a problem in the virtual device. You didn't show the icons part of the virtual device. Are these created and set?
                      Do you mean four different icons?


                      Eman.
                      The People's Advocate.

                      Comment


                      • #12
                        Originally posted by Spudjr View Post
                        If I swap the order than the motion does not toggle but the door does. Just the opposite
                        This seems like an important clue, but I can't think of a reason it would matter.
                        What is the reason for using the 'Set to' trigger instead of 'Changes and becomes'?
                        Mike____________________________________________________________ __________________
                        HS3 Pro Edition 3.0.0.548

                        HW: Stargate | NX8e | CAV6.6 | Squeezebox | PCS | WGL 800RF, Rain8Net+ | RFXCOM | QSE100D | Vantage Pro | Green-Eye | X10: XTB-232, -IIR | Edgeport/8 | Way2Call | Ecobee3

                        Comment


                        • #13
                          Originally posted by Eman View Post
                          Am not so sure about this but change your numbers from 0,10,20 and 30 to 0,1,2,and3 respectively because of the discrepancies between them. (Don't take my word for this but try)
                          They can be whatever values you want them to be.
                          HS 3.0.0.548: 1990 Devices 1172 Events
                          Z-Wave 3.0.1.262: 126 Nodes on one Z-Net

                          Comment


                          • #14
                            Originally posted by sparkman View Post

                            They can be whatever values you want them to be.
                            Then Uncle Michael at post #12 may wright because for at least two of the event things remain static, lost in translation!


                            Eman.
                            The People's Advocate.

                            Comment


                            • #15
                              Originally posted by Spudjr View Post
                              Uncle Michael
                              The device page for my garage door is showing open and close. Working correctly.
                              The virtual Device value is not changing when i close the door. Only changes if i close the door and have motion. No log entry when i just close the door from the Event "Door1 close no motion" etc
                              I think I may be getting a clearer picture.
                              If I am interpreting the event below and your statement above correctly, then you are expecting this event to run when you close the door, but it does not.

                              If that is the case, then I think the problem is that you are looking for two triggers for each event, but you only have one.
                              One way to achieve what (I think) you intend is to add a second trigger.
                              This is how I think it should look:
                              If Motion Detector changes and becomes no motion (I assume Closed means no motion in this case)
                              And If Bettys Door is closed

                              Or If Bettys Door changes and becomes closed
                              And If Motion Detector is no motion (Closed)

                              See here for a detailed explanation of If, And If, and Or If


                              Click image for larger version  Name:	D1CNM.png Views:	0 Size:	289.7 KB ID:	1373094
                              Mike____________________________________________________________ __________________
                              HS3 Pro Edition 3.0.0.548

                              HW: Stargate | NX8e | CAV6.6 | Squeezebox | PCS | WGL 800RF, Rain8Net+ | RFXCOM | QSE100D | Vantage Pro | Green-Eye | X10: XTB-232, -IIR | Edgeport/8 | Way2Call | Ecobee3

                              Comment

                              Working...
                              X