Announcement

Collapse
No announcement yet.

Event Ignoring Condition of Nighttime

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Event Ignoring Condition of Nighttime

    I have an event to turn on my outside light if they get turned off. Really simply but this event fires and keeps the lights on all the time when enabled. Seems to be ignoring the And If The time is nightime condition.

    I have a Enerwave ZWN-RSM2 Dual Relay Switch Module that works fine but has one quirk in that if it looses power it powers back in the off position unlike all my other Zwave modules which power back in the condition they were in when power went off. This one does not and I need an event to turn them back on but only at night if they change to off.
    Attached Files

    #2
    I believe you need the AND IF used with each IF or OR IF.
    Also, your image shows the event off with the line through the red circle.
    Jim
    ----
    Plugins:Z Wave 3.0.1.55, HS3 Pro 3.0.0.208, HS3Touch, HS3Touch IOS, Z-Net, SceneMaster, XBMC, Sonos, Media Controller, Envisalink (52 Virtual nodes), JowiHue, EasyTrigger, Liftmaster MyQ, BLBackup, BLLAN, BLRadar, Pushover

    Devices:Cooper RF9540, Cooper Scene, Yale Locks, Sonos, Phillips Hue and Lux, DSC, Somfy Blinds

    Comment


      #3
      You have an AND IF after your OR IF. You need to have the same AND IF after your first trigger.



      IF outside light changes and becomes off
      AND IF it's nighttime

      OR IF the other outside light changes and becomes off
      AND IF it's nighttime

      THEN.....


      The problem is that the OR IF is an entirely new rule set.

      When you have an OR IF you are essentially creating two (or more) events that share a single action all tidily contained within one event.
      Originally posted by rprade
      There is no rhyme or reason to the anarchy a defective Z-Wave device can cause

      Comment


        #4
        Ok will try adding the AND IF after the OR IF. I have it disabled because it keeps the lights on during the day.


        Sent from my iPad using Tapatalk

        Comment


          #5
          S-F is correct. Each OR starts a new set of conditions. So an AND on one of the OR's doesn't bubble down.

          Comment


            #6
            It still turned the lights back on after sunrise. I have one event turns all the light off at sunrise. How does HS handle events like this? One event turn light off at sunrise and this one says turn them on if it nighttime. Is there a small window of overlap at the instance in time of sunrise that may cause this to loop?


            Sent from my iPad using Tapatalk

            Comment


              #7
              Originally posted by srodgers View Post
              It still turned the lights back on after sunrise. I have one event turns all the light off at sunrise. How does HS handle events like this? One event turn light off at sunrise and this one says turn them on if it nighttime. Is there a small window of overlap at the instance in time of sunrise that may cause this to loop?


              Sent from my iPad using Tapatalk

              If you set up your event exactly like I described it will not turn the lights on after sunrise or before sunset. Either your event is different than what I described or you have another event which is doing it. Could you post screenshots of both of your events? Also what does your log say? Which event does it say is turning the lights on?
              Originally posted by rprade
              There is no rhyme or reason to the anarchy a defective Z-Wave device can cause

              Comment


                #8
                Here is the events that turns off the lights.

                Here is the log from this morning.

                Oct-02 6:37:07 AM Event Deleting event after run: "Delayed Actions Soffit Lighting (Delayed Action)"
                Oct-02 6:37:07 AM Device Control Device: Outside Front Yard Soffit Lighting to On (255)
                Oct-02 6:37:07 AM Device Control Device: Outside Front Yard Security Flood Lights to On (255)
                Oct-02 6:37:07 AM Event Event Trigger "Delayed Actions Soffit Lighting (Delayed Action)"
                Oct-02 6:37:07 AM Event Deleting event after run: "Delayed Actions Soffit Lighting (Delayed Action) - 1"
                Oct-02 6:37:07 AM Device Control Device: Outside Front Yard Soffit Lighting to On (255)
                Oct-02 6:37:07 AM Device Control Device: Outside Front Yard Security Flood Lights to On (255)
                Oct-02 6:37:07 AM Event Event Trigger "Delayed Actions Soffit Lighting (Delayed Action) - 1"
                Oct-02 6:36:40 AM Z-Wave Error Failed sending Z-Wave command to some nodes of a multi-node "All" command. Failed to send to: 7, 6
                Oct-02 6:36:37 AM Event Event Trigger "Lighting OutsideLightPowerFail"
                Oct-02 6:36:37 AM Event Event Trigger "Lighting OutsideLightPowerFail"
                Oct-02 6:36:37 AM Z-Wave Device: Inside Master Bedroom Table Lamp Set to 255
                Oct-02 6:36:37 AM Event Event Trigger "TouchScreen DIm_100"
                Oct-02 6:36:37 AM Device Control Device: Outside Front Yard Soffit Lighting to Off (0)
                Oct-02 6:36:37 AM Device Control Device: Outside Front Yard Security Flood Lights to Off (0)
                Oct-02 6:36:37 AM Device Control Device: Inside Master Bedroom Table Lamp to On (255)
                Oct-02 6:36:37 AM Event Event Trigger "Lighting Outside Lights Off"
                Attached Files

                Comment


                  #9
                  This appears to be the culprit:

                  Oct-02 6:37:07 AM Device Control Device: Outside Front Yard Soffit Lighting to On (255)
                  Oct-02 6:37:07 AM Device Control Device: Outside Front Yard Security Flood Lights to On (255)
                  Oct-02 6:37:07 AM Event Event Trigger "Delayed Actions Soffit Lighting (Delayed Action) - 1"
                  Originally posted by rprade
                  There is no rhyme or reason to the anarchy a defective Z-Wave device can cause

                  Comment


                    #10
                    It now does not trigger during the day but the one time right at sunrise. Not sure what is causing that. Will try removing the delayed turn on and see what logs tomorrow. I do not have any other events that turn on or off the soffit lighting.


                    Sent from my iPad using Tapatalk

                    Comment


                      #11
                      Not sure exactly what fixed this but I changed the events slightly and now the problem I had before went away. I removed the the extra Off command to turn off my Soffit and Security lights at sunrise. They are turned off by a All Zwave Off command.

                      Also I removed the 30 second delay in the PowerFail Event. One of these two fixes cured my problem but was weird that is acted that way to begin with. Thanks for the suggestions.
                      Attached Files

                      Comment


                        #12
                        Nighttime ignored in event

                        I'm having similar issues, though I'm not sure if it's the nighttime condition that's being ignored, or if all AND IF conditions are being ignored.

                        I set up an event to change an LED color to red if the event is run manually AND IF the time is nighttime. The LED always changes to red (and of course I'm testing in the daytime).

                        I also set up the event to change the LED if the event is run manually AND IF the value of a virtual device is OFF. The LED changes no matter that the value of the virtual device is.

                        All of my other events are disabled, and there are no group conditions or group actions set anywhere.



                        Code:
                        Oct-17 10:19:23 AM	 	Device Control	Device: First Living Room Color Control to Blue (3)
                        Oct-17 10:19:23 AM	 	Event	Event Trigger "Time Based Events test"
                        Oct-17 10:19:23 AM	 	Event	Event Time Based Events test triggered by the event page 'Run' button.
                        Attached Files
                        HS Pro 3.0 | Linux Ubuntu 16.04 x64 virtualized under Proxmox (KVM)
                        Hardware: Z-NET - W800 Serial - Digi PortServer TS/8 and TS/16 serial to Ethernet - Insteon PLM - RFXCOM - X10 Wireless
                        Plugins: HSTouch iOS and Android, RFXCOM, BlueIris, BLLock, BLDSC, BLRF, Insteon PLM (MNSandler), Device History, Ecobee, BLRing, Kodi, UltraWeatherWU3
                        Second home: Zee S2 with Z-Wave, CT101 Z-Wave Thermostat, Aeotec Z-Wave microswitches, HSM200 occupancy sensor, Ecolink Z-Wave door sensors, STI Driveway Monitor interfaced to Zee S2 GPIO pins.

                        Comment


                          #13
                          Originally posted by reidfo View Post
                          I'm having similar issues, though I'm not sure if it's the nighttime condition that's being ignored, or if all AND IF conditions are being ignored.

                          I set up an event to change an LED color to red if the event is run manually AND IF the time is nighttime. The LED always changes to red (and of course I'm testing in the daytime).

                          I also set up the event to change the LED if the event is run manually AND IF the value of a virtual device is OFF. The LED changes no matter that the value of the virtual device is.

                          All of my other events are disabled, and there are no group conditions or group actions set anywhere.
                          Setting the IF condition to MANUAL will cause additional conditions (AND IF) to be ignored - because there is no trigger mechanism for the event (because it's set to manual). Running the event from another event or script will only run the actions, not evaluate the conditions. You should just trigger on If nighttime...
                          Mike

                          Comment


                            #14
                            Originally posted by mwaite View Post
                            Setting the IF condition to MANUAL will cause additional conditions (AND IF) to be ignored - because there is no trigger mechanism for the event (because it's set to manual). Running the event from another event or script will only run the actions, not evaluate the conditions. You should just trigger on If nighttime...

                            IF Nighttime isn't a trigger.

                            If the event in question is being run from another event make sure to set the action to run only if other event conditions are true under the advanced options.
                            Originally posted by rprade
                            There is no rhyme or reason to the anarchy a defective Z-Wave device can cause

                            Comment


                              #15
                              Originally posted by S-F View Post
                              IF Nighttime isn't a trigger.
                              .
                              That's what I was trying to get across, maybe not worded well.
                              Mike

                              Comment

                              Working...
                              X